Pakete werden zurück gehalten, trotz dist-upgrade

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Emess, 21.09.2009.

  1. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    seit heute Morgen kann ich kein dist-upgrade mehr ausführen.

    Code:
    squeeze:/home/michael# apt-get dist-upgrade
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Lese Status-Informationen ein... Fertig
    Berechne Upgrade (Paketaktualisierung) ...Fertig
    Die folgenden NEUEN Pakete werden installiert:
      libbs2b0
    [COLOR=Red]Die folgenden Pakete sind zurückgehalten worden:
      ffmpeg grub libavcodec52 libavdevice52 libavfilter0 libavformat52 mplayer
    Die folgenden Pakete werden aktualisiert:[/COLOR]
      libavutil50 libpostproc51 libswscale0
    3 aktualisiert, 1 neu installiert, 0 zu entfernen und 7 nicht aktualisiert.
    Es müssen 308kB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 73,7kB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren [J/n]?
    
    Kennt einer dieses Problem und kann mir auf die Sprünge helfen.

    Falls ihr mehr Infos braucht! Einfach melden.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    http://www.debian.org/doc/manuals/apt-howto/ch-apt-get.de.html ->
     
  4. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Also soll hier lieber mal die neuen Pakete nicht installieren,

    Code:
    squeeze:/home/michael# apt-get -u install grub
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Lese Status-Informationen ein... Fertig
    Die folgenden zusätzlichen Pakete werden installiert:
      grub-pc
    [COLOR="Red"]Die folgenden Pakete werden ENTFERNT:
      grub-legacy[/COLOR]
    Die folgenden NEUEN Pakete werden installiert:
      grub-pc
    Die folgenden Pakete werden aktualisiert:
      grub
    1 aktualisiert, 1 neu installiert, 1 zu entfernen und 9 nicht aktualisiert.
    Es müssen 812kB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 1.004kB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren [J/n]?
    
    oder?
     
  5. foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    Also es kann mehrere Möglichkeiten geben das apt die pakete zurück hält.

    Zum einen du hast sie via dpkg --set-selections auf hold gesetzt.
    Oder es gibt eine Abhängigkeit die eine gewisse version eines Paketes benötigt, wofür es aber schon eine neuere Version gibt.
     
  6. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    was wäre in diesem Falle zu tun? :think:
     
  7. towo

    towo Haudegen

    Dabei seit:
    16.05.2003
    Beiträge:
    649
    Zustimmungen:
    1
    Ort:
    Pößneck
    Abwarten.
     
  8. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Na dann geh ich jetzt erst mal zum Frühschoppen (Winzerfest, Groß-Umstadt). :D:D:D:oldman
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 bitmuncher, 21.09.2009
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Ich würde ja erstmal prüfen, ob die evtl. einfach auf hold gesetzt sind. In dem Fall hold-Flag entfernen und dist-upgrade nochmal durchlaufen lassen.
     
  11. nikaya

    nikaya Guest

    Sieht nach Squeeze aus, da ist mittlerweile Grub2 (=grub-pc) Standard. Das wird auch nicht wieder rückgängig gemacht!! Das wirst Du wohl installieren müssen, oder ewig auf hold setzen.

    Mache Dich aber vorher mit der Anwendung von Grub2 vertraut, da hat sich zu grub-legacy einiges geändert.

    http://wiki.ubuntuusers.de/Baustelle/GRUB_2
    http://wiki.ubuntuusers.de/baustelle/grub_2_konfiguration
    http://www.kanotix.com/index.php?module=pnWikka&tag=Grub2
     
Thema:

Pakete werden zurück gehalten, trotz dist-upgrade

Die Seite wird geladen...

Pakete werden zurück gehalten, trotz dist-upgrade - Ähnliche Themen

  1. Debian Etch Installation: Welche Pakete werden installiert?

    Debian Etch Installation: Welche Pakete werden installiert?: Hallo, ich hänge gerade bei der Installation von Etch und frage mich, ob ich mir das Leben etwas erleichtern könnte und die gebotenen...
  2. neuinstallation-pakete werden nicht gefunden

    neuinstallation-pakete werden nicht gefunden: hiho, ich hatte mich jetzt einfach entschieden mein SuSE wieder neu zu installieren, da ich einige Fehler beim letzten mal gemacht hatte bei...
  3. Netzwerkaufbau mit simulierten Paketen unter Linux

    Netzwerkaufbau mit simulierten Paketen unter Linux: Hallo, ich habe folgendes Problem. Da ich noch sehr unerfahren in Sachen Linux bzw. Netzwerkaufbau bin, wollte ich fragen, ob Ihr mir vllt etwas...
  4. Adapt ermöglicht Pakete anderer Distributionen bei Ubuntu

    Adapt ermöglicht Pakete anderer Distributionen bei Ubuntu: Im Januar stellte Ubuntu-Entwickler Dustin Kirkland auf einer Konferenz mit Adapt eine interessante Entwicklung vor, die nun in Ubuntu als PPA...
  5. Emacs 24.4 mit Webbrowser und signierten Paketen

    Emacs 24.4 mit Webbrowser und signierten Paketen: Die Emacs-Entwickler haben ihr Editor-Urgestein in der Version 24.4 veröffentlicht. Emacs ist ein plattformunabhängiger, unter der GPL...