openSUSE bootet nicht mehr

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von baracuda, 23.09.2008.

  1. #1 baracuda, 23.09.2008
    baracuda

    baracuda Mitglied

    Dabei seit:
    01.08.2008
    Beiträge:
    40
    Zustimmungen:
    0
    Hallo!

    Ich habe erstmal folgende Konfiguration:
    * Windows XP SP3
    * Dualboot mit openSUSE 11
    * GNOME
    * Bootmanager GRUB
    * und das alles auf einem Dell Inpspiron 1300 Laptop

    und folgendes Problem:
    Auf einmal bootet openSUSE erstmal ordnungsgemäß bis kurz vor dem Gnome-Desktop und bleibt dann mit dem Mauszeiger und schwarzem Bildschirm stehen.
    Wenn ich failsafe boote, kommt man ja in den Textmodus und dort habe ich dann nach meiner Benutzeranmeldung mal den Befehl "gnome" eingegeben und dann kam folgende Ausgabe:

    Code:
    gnome-session:2704):
    Gtk-WARNING **: cannot open display:
    
    Windows XP bootet hingegen ganz normal...
    Bitte um Hilfe, ich kann XP nicht mehr sehen :(

    Danke im Voraus,
    lg baracuda

    PS: an Veränderungen an openSUSE selbst kann ich mich eigentlich nur an die JDK-Installation erinnern, die in den Zeitraum fallen würde... aber bis jetzt sehe ich da noch keinen Zusammenhang^^
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 blue-dev, 23.09.2008
    blue-dev

    blue-dev stranger with blue eyes

    Dabei seit:
    30.06.2007
    Beiträge:
    438
    Zustimmungen:
    0
    Der Fehler ist ganz normal, X ist noch nicht gestartet und desshalb kann es keine Oberfläche geben.

    Zu deinem eigentlichen Problem: Guck dir mal an ob dein hostname richtig aufgelößt wird, hast du vielleicht in letzter Zeit mit der Firewall von Suse rumgespielt oder so?
    Wenn der hostename nicht richtig aufgelößt werden kann, tritt nämlich genau der Fehler ein: Gnome bleibt direkt nach dem Splashscreen hängen, da die Kommunikation zwischen den Diensten behindert wird.
     
  4. Gast1

    Gast1 Guest

    Code:
    df -h
    
    su -c "egrep 'EE|WW' /var/log/Xorg.0.log"
    sagt?

    Welche Grafikkarte?

    Falls ATI oder NVidia, dann

    Code:
    modinfo fglrx nvidia nv radeon
    
    grep Driver /etc/X11/xorg.conf
    //Edit:

    Da die Ausgaben im Wortlaut benötigt werden, sich das hier ansehen:

    www.bin-bash.de/komfort.php

    (Ausgabeumleitung in eine Datei)
     
  5. #4 baracuda, 24.09.2008
    baracuda

    baracuda Mitglied

    Dabei seit:
    01.08.2008
    Beiträge:
    40
    Zustimmungen:
    0
    Hi!

    bei df -h su -c "egrep 'EE|WW' /var/log/Xorg.0.log" sagt mir die bash dass sie das Kommando nicht kenne. Ohne 'df-h' gibts schon einen ordentlichen Output.. aber mit der Ausgabeumleitung komme ich nicht weiter. Irgendwie muss ich ja auch noch an die Datei rankommen (USB-Stick?);
    Ich bin ja noch ein ziemlicher Linux-Neuling, aber nicht völlig unerfahren.
    Ein weitere Verdacht tut sich auf. Ich habe mal nach dem Abmelden bei Sitzungsart aus Versehen "Metacity" gewählt, kann es vll daran liegen?
    Weil eigentlich ist es ja nicht explizit installiert worden, der Wikipedia-Artikel will mich doch eines Besseren belehren.

    Danke im Voraus,
    baracuda
     
  6. Gast1

    Gast1 Guest

    Und auf die Idee, daß diese in zwei Zeilen stehen, weil es auch zwei Kommandos sind, bist Du nicht gekommen?

    Ja, USB. Stick wäre ne Idee.
     
  7. #6 baracuda, 24.09.2008
    baracuda

    baracuda Mitglied

    Dabei seit:
    01.08.2008
    Beiträge:
    40
    Zustimmungen:
    0
    sorry das hab ich nicht beachtet...

    Wie kann man die Datei auf den USB-Stick kriegen?
    Wahrscheinlich funktioniert der Zugriff nach dem Verbinden über /media/USB-Stick/ ja wahrscheinlich nicht?!
     
  8. Gast1

    Gast1 Guest

    Indem man den Stick von Hand mountet.

    Code:
    su
    
    Passwort
    
    mount -t auto /dev/*irgendwas* /mnt
    und die Daten rüberkopiert (cp oder mit dem MidnightCommander "mc").

    Danach den Stick mittels "umount /mnt/" als root wieder aushängen.

    Was das "irgendwas" ist, verrät Dir

    Code:
    su -c "fdisk -l"
    einmal vor und einmal nach dem Einstöpseln des Sticks ausgeführt.

    Um sich Gefummel mit der Umleitung in einem "su -c"-Befehl zu ersparen, am besten die ganzen Befehle als root absetzen.
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 gropiuskalle, 24.09.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Am interessantesten fände ich dennoch die Ausgabe von

    Code:
    df -h
    poste die doch zwischenzeitlich schon mal - die Ausgabe ist kurz genug, um sie abzuschreiben.
     
  11. #9 baracuda, 25.09.2008
    baracuda

    baracuda Mitglied

    Dabei seit:
    01.08.2008
    Beiträge:
    40
    Zustimmungen:
    0
    Also.. das mounten / unmounten vom USB-Stick will mir nicht richtig gelingen.. die anderen, kleinere Ausgaben im Folgenden.

    Code:
    df -h
    
    Dateisystem  Größe  Benutz  Verf Ben%  Eingehängt
    /dev/sda6     6,9G   4,5G     2,1G 69%   /
    udev            248M  116K    248M 1%    /dev
    /dev/sda7     10G    1,5G    8,0G   16%  /home
    
    Code:
    modinfo fglrx nvidia nv radeon
    
    modinfo: could not find module fglrx
    modinfo: could not find module nvidia
    modinfo: could not find module  nv
    
    filename: /lib/modules/2.6.25-16-0.1-default/kernel/drivers/char/drm/radeon.ko
    
    license: GPL and additional rights
    description: ATI Radeon
    author: Gareth Hughes, Keith Whitwell, others.
    srcversion: 22229ED24F75F9356D63EA2
    depends: drm
    supported: yes
    vermagic: 2.6.25.16-0.1-default SMP mod-unload 586
    parm: no_wb: Disable AGP writeback for scratch register
    (int)
    

    Code:
    grep Driver /etc/X11/xorg.conf
    
    Driver "kbd"
    Driver "mouse"
    Driver "synaptics"
    Driver "Intel"
    
    lg
     
Thema:

openSUSE bootet nicht mehr

Die Seite wird geladen...

openSUSE bootet nicht mehr - Ähnliche Themen

  1. OpenSUSE 11.0 bootet nicht mehr

    OpenSUSE 11.0 bootet nicht mehr: Guten Abend, habe mir letztens OpenSUSE 11.0 draufgemacht und wollte heute die ATI Treiber für die ATI RADEON X850XT (agp) installieren, hat...
  2. openSuse 11 + Win XP -> bootet nicht mehr

    openSuse 11 + Win XP -> bootet nicht mehr: Hallo, ich brauche mal bitte Hilfe. Nachdem ich openSuse 11 installiert hab, schaffe ich es nicht mehr Win XP zu booten. Mein System sieht wie...
  3. OpenSuse 10.3 bootet nicht mehr durch - Mountproblem?

    OpenSuse 10.3 bootet nicht mehr durch - Mountproblem?: Moin Forum, mein OpenSuse 10.3 bootet nur noch in die Konsole. Entstanden ist das wohl dadurch, dass es gestern nicht richtig runterfahren...
  4. openSuse 10.2 Bootet nicht

    openSuse 10.2 Bootet nicht: Heute ist mein Linux Tag :hilfe2: Ich habe mir gerade OpenSuse 10.2 auf DVD gebrant,und lege es ins notebook,aber es bootet nicht beim start....
  5. openSuse 10.2 bootet unzuverlässig

    openSuse 10.2 bootet unzuverlässig: hab mir die 10.2er DVD x86 runtergeladen und neu installiert. alles wunderbar geklappt, nur wenn ich mein system hochfahren will gelingt mir das...