openSUSE 10.3 smbfs isdn wlan

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von jmueller, 23.12.2007.

  1. #1 jmueller, 23.12.2007
    jmueller

    jmueller Grünschnabel

    Dabei seit:
    23.12.2007
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo,

    ich habe ein neues Notebook (Fujitsu Siemens S 7110) mit Dual Core CPU.
    Parallel zum Windows Vista gleich openSUSE 10.3 64 Bit draufgebügelt,
    was auch ansich problemlos ging.
    Linux ist nicht neu für mich, allerdings ist das meine erste SuSE 10.3-Installation.
    Und da bereiten mir drei Dinge Probleme:

    1. Der smbfs-Daemon startet nicht:
    "/etc/init.d/smbfs start gab 6 (Programm ist nicht konfiguriert) zurück"
    In /var/log/messages wird nichts dazu eingetragen
    Das Problem habe ich bei meinen ganzen früheren Linux-Installationen
    noch nie gehabt. Was soll man da auch konfigurieren?
    Die anderen notwendigen Dienste (consolekit und network) laufen.

    2. AVM Fritz!Card USB 2.0
    Auf meinem alten Notebook habe ich das laufen (SuSE 9.0).
    Den richtigen Treiber habe ich aus von
    opensuse.foehr-it.de gezogen und
    alles schön mit yast wie bei meinem alten Notbook eingerichtet.
    Auch die beiden LEDs an der USB-FritzCard leuchten,
    was soviel bedeutet, dass (1. LED) USB angeschlossen ist und
    (2. LED) das Ding vom Betriebssystem angesprochen wurde (Treiber geladen).
    Wenn ich allerdings mit kinternet eine Wählverbindung aufbauen will,
    tut sich nichts, außer in /var/log/messages:

    Dec 23 17:59:10 asti120 ifup: ippp0
    Dec 23 17:59:11 asti120 SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2...
    Dec 23 17:59:11 asti120 SuSEfirewall2: batch committing...
    Dec 23 17:59:11 asti120 SuSEfirewall2: Firewall rules successfully set
    Dec 23 17:59:11 asti120 kernel: isdn_ppp_bind: Can't find a (free) connection to the ipppd daemon.

    Die Dienste (isdn network smpppd) laufen.

    Komisch ist auch, dass beim Herunterfahren des ISDN-Subsystems
    er meint, es gäbe nichts herunterzufahren und die beiden LEDs
    an der FritzCard bleiben an.


    3. WLAN
    Bei der Installation wurde das WLAN-System erkannt
    und KNetworkManager zeigt mir die verfügbaren drahtlosen Netzwerke
    auch schön an.
    Wenn ich mich verbinden will, bleibt der NetworkManager bei 28%
    (Status der Aktivierung: Gerätekonfiguration) stehen
    und in /var/log/messages steht:

    Dec 23 18:13:11 asti120 avahi-daemon[3212]: Withdrawing address record for fe80::21b:77ff:fee0:b4de on wlan0.
    Dec 23 18:13:12 asti120 kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    Dec 23 18:13:12 asti120 kernel: NET: Registered protocol family 17
    Dec 23 18:13:14 asti120 avahi-daemon[3212]: Registering new address record for fe80::21b:77ff:fee0:b4de on wlan0.*.

    iwconfig meldet folgendes:

    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE 802.11g ESSID:"XYZ"
    Mode:Managed Frequency:2.452 GHz Access Point: 00:1A:2A:5E:62:88
    Bit Rate:54 Mb/s Tx-Power:15 dBm
    Retry limit:15 RTS thr:off Fragment thr:off
    Encryption key:off
    Power Management:off
    Link Quality=98/100 Signal level=-25 dBm Noise level=-26 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:108 Missed beacon:0

    Nach etwa einer halben Minute erscheint dann die nichts sagende Fehlermeldung
    und in /var/log/messages erscheint:

    Dec 23 18:13:23 asti120 kernel: wlan0: no IPv6 routers present
    Dec 23 18:14:12 asti120 avahi-daemon[3212]: Withdrawing address record for fe80::21b:77ff:fee0:b4de on wlan0.
    Dec 23 18:14:13 asti120 kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    Dec 23 18:14:18 asti120 avahi-daemon[3212]: Registering new address record for fe80::21b:77ff:fee0:b4de on wlan0.*.
    Dec 23 18:14:27 asti120 kernel: wlan0: no IPv6 routers present

    Der Einfachheit halber habe ich die Verschlüsselung ausgestellt.

    Unter Windows Vista geht das WLAN problemlos.
    Mein Router ist "Arcor EasyBox A 300 WLAN"
    mit der neuesten Firmware.
    Ich habe das auch mal mit einem "Targa WR 500 VoIP"
    ausprobiert: gleiches Ergebnis.


    Hat da jemand eine Idee bzgl. meiner Probleme mit openSUSE 10.3?

    Danke im Vorraus!
    Jens
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 23.12.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    smbfs wird offiziell nicht mehr supported, evtl. liegt es daran.

    Stattdessen kann und sollte man cifs nehmen. (Keine Sorge, für deine Win-Clients ändert sich nichts)

    Hmm,

    also aufgrund der Fehlermeldung würde ich ja mal darauf tippen, das die SuseFirewall den Zugriff blockt, hast du das schon geprüft? (geht auch über yast, schalte sie mal zum Testen kurzzeitig ab)

    Da musst du genauer werden:

    - Welche Wlan-Karte?
    - Welcher Chipsatz?
    - Schon mit modinfo geschaut welche Treiber und Version geladen werden?
    - Genauere Infos zum Netzwerk: WPA?
     
  4. #3 jmueller, 24.12.2007
    jmueller

    jmueller Grünschnabel

    Dabei seit:
    23.12.2007
    Beiträge:
    5
    Zustimmungen:
    0
    > smbfs wird offiziell nicht mehr supported, evtl. liegt es daran.

    Nun ja, mein eigentliches Problem ist, dass
    mount -t smbfs ...
    nicht funktioniert.
    smbfs wäre ein unbekanntes Dateisystem.

    > Stattdessen kann und sollte man cifs nehmen. (Keine Sorge, für deine Win-Clients ändert sich nichts)
    Muss man dann "mount -t cifs ..." machen?
    Ich kann es leider erst nach Weihnachten in der Firma ausprobieren.


    > also aufgrund der Fehlermeldung würde ich ja mal darauf tippen, das die SuseFirewall
    > den Zugriff blockt, hast du das schon geprüft? (geht auch über yast, schalte sie mal zum > Testen kurzzeitig ab
    Leider keine Wirkung
    Die letzte Zeile in /var/log/messages scheint aber irgendwie was anderes aussagen
    zu wollen:
    Dec 23 17:59:11 asti120 kernel: isdn_ppp_bind: Can't find a (free) connection to the ipppd daemon.


    WLAN:
    > Da musst du genauer werden:
    > - Welche Wlan-Karte?
    - Welcher Chipsatz?
    Intel PRO/Wireless 3945ABG

    > - Schon mit modinfo geschaut welche Treiber und Version geladen werden?
    localhost:~ # modinfo ipw3945
    filename: /lib/modules/2.6.22.13-0.3-default/weak-updates/ipw3945.ko
    license: GPL
    author: Copyright(c) 2003-2006 Intel Corporation
    version: 1.2.2dmpr
    description: Intel(R) PRO/Wireless 3945 Network Connection driver for Linux
    srcversion: B07700C0F5E01B0DF322E79
    alias: pci:v00008086d00004227sv*sd*bc*sc*i*
    alias: pci:v00008086d00004222sv*sd*bc*sc*i*
    depends: firmware_class,ieee80211
    vermagic: 2.6.22.5-31-default SMP mod_unload
    parm: antenna:select antenna (1=Main, 2=Aux, default 0 [both]) (int)
    parm: disable:manually disable the radio (default 0 [radio on]) (int)
    parm: associate:auto associate when scanning (default 0 off) (int)
    parm: auto_create:auto create adhoc network (default 1 on) (int)
    parm: led:enable led control (default 1 on)
    (int)
    parm: debug:debug output mask (int)
    parm: channel:channel to limit associate to (default 0 [ANY]) (int)
    parm: rtap_iface:create the rtap interface (1 - create, default 0) (int)
    parm: mode:network mode (0=BSS,1=IBSS,2=Monitor) (int)

    > - Genauere Infos zum Netzwerk: WPA?
    Verschlüsselung habe ich ausgeschaltet


    Oder sollten das alle Probleme der 64-Bit Version sein?

    Gruß
    Jens
     
  5. Gast1

    Gast1 Guest

    Nö.

    Aber unter Umständen ein Problem mit der ausgelieferten Version des ipw3945-kmp-Paketes.

    Lese er dies:

    https://bugzilla.novell.com/show_bug.cgi?id=330995

    Für ein passendes kmp-Paket wird man das src.rpm "rebuilden" müssen, ist aber kein Hexenwerk, siehe dazu (beispielhaft):

    http://www.pc-forum24.de/suse-internetkonfiguration/2493-opensuse-10-2-avm.html#post12784
     
  6. #5 supersucker, 24.12.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Genau........:devil:

    Du musst das smbfs Paket erst noch installieren, aber wie schon gesagt, nimm cifs.
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 jmueller, 24.12.2007
    jmueller

    jmueller Grünschnabel

    Dabei seit:
    23.12.2007
    Beiträge:
    5
    Zustimmungen:
    0
    Die Tipps bzgl. smbfs/cifs und wlan klingen vielversprechend.
    Vielen Dank dafür!

    Heute (Heiligabend) Nachmittag beginnt unsere
    Weihnachtszwangsrundreise der Familienbesuche.
    Wenn ich dann nach Weihnachten davon zurück bin,
    gehe ich das Patchen des wlan-Treibers an.

    Gruß
    Jens
     
  9. #7 jmueller, 28.12.2007
    jmueller

    jmueller Grünschnabel

    Dabei seit:
    23.12.2007
    Beiträge:
    5
    Zustimmungen:
    0
    So, die Probleme sind nun gelöst.
    Dazu hatte ich zwischenzeitlich auch mal openSUSE 10.3 32 Bit installiert gehabt.

    Wen es interessiert:

    1. cifs funktioniert als Alternative zu smbfs wunderbar

    2. wlan funktioniert:
    Ich habe den ipw3945 Treiber von
    http://download.opensuse.org/repositories/driver:/wireless:/10.3/openSUSE_10.3_update/
    verwendet, entsprechend den Hinweisen von
    http://en.opensuse.org/HCL/Network_Adapters_(Wireless)

    3. AVM FritzCard USB 2.0 läuft:
    Laut den Thread
    http://www.foehr-it.de/hlp/viewtopic.php?t=66&start=0
    handelt es sich um einen Fehler im if-up-Skript,
    der inzwischen gefixt wurde.
    Also per Online-Update auf Kernel 2.6.22.13-0.3-default aktualisiert
    und den entsprechenden Treiber von opensuse.foehr-it.de installiert,
    und schon geht die ISDN-Einwahl,
    allerdings nur mit openSUSE 10.3 64 Bit.
    Bei der 32-Bit-Version stürzt der Treiber beim Booten ab,
    wenn die USB-FritzCard eingesteckt ist.

    Gruß
    Jens
     
Thema:

openSUSE 10.3 smbfs isdn wlan

Die Seite wird geladen...

openSUSE 10.3 smbfs isdn wlan - Ähnliche Themen

  1. OpenSuse Conference vom 22. bis 26. Juni in Nürnberg

    OpenSuse Conference vom 22. bis 26. Juni in Nürnberg: Zum mittlerweile achten Mal findet die OpenSuse Conference statt. In diesem Jahr wird sie vom 22. bis 26. Juni in Nürnberg abgehalten. Der Call...
  2. OpenSuse Conference vom 22. bis 26. Juni in Nürnberg

    OpenSuse Conference vom 22. bis 26. Juni in Nürnberg: Zum mittlerweile achten Mal findet die OpenSuse Conference statt. In diesem Jahr wird sie vom 22. bis 26. Juni in Nürnberg abgehalten. Der Call...
  3. OpenSuse bietet aktuelles KDE mit LEAP oder Tumbleweed

    OpenSuse bietet aktuelles KDE mit LEAP oder Tumbleweed: OpenSuse bietet zwei neue Images an, die die neuesten KDE-Pakete aus den Git-Repositories enthalten. Die Images basieren auf den Varianten Leap...
  4. Opensuse 13.1 erreicht Evergreen-Phase

    Opensuse 13.1 erreicht Evergreen-Phase: Version 13.1 der Linux-Distribution Opensuse hat jetzt das Ende ihrer regulären Lebensdauer erreicht. Doch im Rahmen des Evergreen-Projektes wird...
  5. Opensuse Leap jetzt in öffentlichen Clouds verfügbar

    Opensuse Leap jetzt in öffentlichen Clouds verfügbar: In den öffentlichen Clouds von Amazon, Google und Microsoft stehen ab sofort virtuelle Maschinen mit Opensuse Leap 42.1 zur Verfügung. Weiterlesen...