Opensuse 10.2 + Nvidia treiber = Schwarzer Bildschrim

Dieses Thema im Forum "Grafik / Video" wurde erstellt von quare, 17.08.2007.

  1. quare

    quare Mitglied

    Dabei seit:
    03.06.2007
    Beiträge:
    41
    Zustimmungen:
    0
    Hi,
    ich hab OpenSuse 10.2 und eine Geforce FX 5200. Opensuse lief die ganze zeit. Dann hab ich mir mal gedacht das ich den Nvidia treiber installiere weil ich die 3D Optionen mal testen wollte und auch ein paar linux spiele (man hat ja sonst den lieben langen tag nix zu tun :brav: )

    Den Treiber habe ich über YOU geladen wie es auch auf der NVIDIA seite vorgeschlagen wird. Ein neustart und wum.... Schwarzer bildschirm.

    Über strg+alt+f1 auf die Konsole gewechselt und dort sax2 -m 0=nv eingeben und mir somit wieder die grafische oberfläche geholt. Nur jetzt komme ich nicht weiter. Bin erst seit ein paar Wochen bei linux dabei und kenne mich nicht so gut aus.

    Ich hab auch ein Image von meinem system gemacht bevor ich den treiber installiert habe. Da ich ja weis das ich nicht sehr erfahren mit linux bin hab ich mir schon gedacht das ich irgend was verkehrt mache ^^.

    Bitte helft mir doch mal ein wenig linux zu verstehen und sax2 auch mit dem nvidia treiber zum laufen zu bringen.

    Danke
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 17.08.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Poste mal die Ausgabe von

    Code:
    egrep "(EE)|(WW)" /var/log/Xorg.0.log
    cat /etc/X11/xorg.conf
     
  4. #3 kartoffel200, 17.08.2007
    Zuletzt bearbeitet: 17.08.2007
    kartoffel200

    kartoffel200 AMD Fanboy Since 2003

    Dabei seit:
    12.03.2007
    Beiträge:
    938
    Zustimmungen:
    0
    Ort:
    L wie localhost
    Öffne mal deine Xorg.conf. Starten ohne Xserver also Konsole. Dann cd /etc/X11/. Dann vi xorg.conf.
    In der dürfte wegen Nvidia der Eintrag "nv" oder "nvidia" stehen. stell diese erst mal zurück auf vesa.
    Damit du da vesa schreiben kannst musst du erst mal x eingeben damit du editieren kannst. Mit esc verlässt du den durch X geschaffenen Edit mode. Speichern kannst du dann mit ":q!"

    Also so im schnelldurchlauf
    cd /etc/X11
    vi xorg.conf
    x (Edit)


    Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    Option "RenderAccel" "true"
    EndSection

    das nach das machen


    Section "Device"
    Identifier "Videocard0"
    Driver "vesa"
    Option "RenderAccel" "true"
    EndSection

    mit
    escape den Edit Mode verlassen
    dann :q! da speichert er die brühe und verlässt sie dann anscließend. Dann reeboten. Und gucken ob wieder Bild ist. einfach "shutdown -r now"
     
  5. #4 schelli2, 17.08.2007
    schelli2

    schelli2 Jungspund

    Dabei seit:
    28.05.2006
    Beiträge:
    12
    Zustimmungen:
    0
    Hallo

    ich habe schon oft die NVIDIA unter Suse installiert, auch bei FX-5200 und eigentlich bei allen nicht-legacy Karten nie Schwierigkeiten gehabt. Es sieht bei Ihnen so aus, als ob die graph. Benutzeroberfläche nach der Installation nicht startet, aber dann müsste doch zumindest ein Text-login sichtbar sein? Ich gehe immer nach der Beschreibung auf der nvidia seite vor:
    http://www.suse.de/~sndirsch/nvidia-installer-HOWTO.html#1

    Nach dem herunterladen des korrekten Treibers 32 oder 64 bit starten Sie:
    sh NVIDIA-Linux-x86-100.xx.xx-pkg1.run
    im Textmodus (init3)
    Dann starten Sie sax2 -r -m 0=nvidia VOR! dem rebooten. Meines Erachtens führt der von Ihnen zitierte Befehl sax2 -m 0=nv wieder zum nicht-3D Treiber.

    Viel Erfolg
     
  6. quare

    quare Mitglied

    Dabei seit:
    03.06.2007
    Beiträge:
    41
    Zustimmungen:
    0
    Hi, erstmal danke für die hilfe.

    wie gesagt, bis zum sax2 -m 0=nv komme ich. Hätte vielleicht noch dazu schreiben sollen das dann auch die grafische oberlfäche wieder da ist. Aber eben wie zuvor ohne 3D unterstützung da ich ja den standart treiber wieder lade.

    Dann kann ich mir ja eigentlich das mit dem Vesa treiber sparen oder?

    Installiert ist der treiber ja auch schon aber eben über Yast. Auf der Nvidia webseite meine ich gelesen zu haben man sollte die beiden installationen nicht vermischen. Also wenn ich schon über YOU die treiber installiert habe dann sollte ich nicht mehr über die .run das ganze machen.

    Bin im moment nicht an meinem rechner deshalb werde ich die xorg.conf später erst posten können.

    Danke für die schnellen antworten!
     
  7. MoFo

    MoFo Tripel-As

    Dabei seit:
    23.06.2007
    Beiträge:
    215
    Zustimmungen:
    0
    Ort:
    Berlin
    Ich empfehle dir wenn du das Nvidia Reposity eingetragen hast folgenes :

    Öffne Yast und spiel die Nvida Treiber nochmal ein.

    Und zwar den x11-video-nvidiaG01 und das entstprechende Kernelmodul
    welchem du ja mit uname -r ja erfährst.

    Also alles wie die Anleitung auf : http://de.opensuse.org/Proprietäre_NVIDIA-Grafiktreiber nur halt die G01.

    Das hat bei mir und 2 anderen Systemen bis jetzt immer funktioniert.

    PS : natürlich den anderen Treiber+Kernelmodul entfernen

    gruss
     
  8. quare

    quare Mitglied

    Dabei seit:
    03.06.2007
    Beiträge:
    41
    Zustimmungen:
    0
    Hi,
    habe bereits das G01 installiert. Aber mit dem läuft das trotzdem nicht...

    Sollte ich mal den legalicy treiber nehmen?
     
  9. MoFo

    MoFo Tripel-As

    Dabei seit:
    23.06.2007
    Beiträge:
    215
    Zustimmungen:
    0
    Ort:
    Berlin
    Hmm schade, bei mir gings halt immer so.

    Ich hatte als erstes den Legacy damit ging gar nix auch kein confen.

    Vieleicht isses ja bei dir umgedreht oder es ist ein Bug :D

    Ansonsten halt den Tipps der Experten hier folgen .
     
  10. #9 Caleb79, 18.08.2007
    Caleb79

    Caleb79 Doppel-As

    Dabei seit:
    15.10.2006
    Beiträge:
    146
    Zustimmungen:
    0
    Hallo,

    ich habe ein ähnliches problem.
    bei startet das teil auch net mehr, nachdem ich es per yum installiere.
    selbst die manuelle installation funktioniert nicht richtig.

    aso, system: fedora core 7
     
  11. quare

    quare Mitglied

    Dabei seit:
    03.06.2007
    Beiträge:
    41
    Zustimmungen:
    0
    Hi, hab das image von meinem Rechner zurückgespielt weil ich sicher gehen wollte das auch alles von Nvidia wieder weg ist. Habe danach die Anleitung zur .run datei befolgt. Soweti auch so gut. Hat dann wie in der Anleitung beschrieben den fehler gebracht das der Kernel nicht passt. Dann hat er neu kompiliert glaub ich und am ende kam dann die meldung das alles gepasst hat. Aber wennn ich dann mit sax -m 0=nvidia starten will habe ich wieder das Problem das der bildschirm schwarz ist und ausgeht weil er kein signal bekommt.

    Wo muss kann ich denn noch drann drehen?

    Graifkkarte: Nvidia Geforce FX 5200
    System: Opensuse 10.2


    pc-florian:/home/fischerf # egrep "(EE)|(WW)" /var/log/Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) The directory "/usr/share/fonts/local" does not exist.
    (WW) The directory "/usr/share/fonts/PEX" does not exist.
    (WW) The directory "/usr/share/fonts/latin2/misc" does not exist.
    (WW) The directory "/usr/share/fonts/latin2/75dpi" does not exist.
    (WW) The directory "/usr/share/fonts/latin2/100dpi" does not exist.
    (WW) The directory "/usr/share/fonts/latin2/Type1" does not exist.
    (WW) The directory "/usr/share/fonts/latin7/75dpi" does not exist.
    (WW) The directory "/usr/share/fonts/baekmuk" does not exist.
    (WW) The directory "/usr/share/fonts/japanese" does not exist.
    (WW) The directory "/usr/share/fonts/kwintv" does not exist.
    (WW) The directory "/usr/share/fonts/CID" does not exist.
    (WW) The directory "/usr/share/fonts/ucs/misc" does not exist.
    (WW) The directory "/usr/share/fonts/ucs/75dpi" does not exist.
    (WW) The directory "/usr/share/fonts/ucs/100dpi" does not exist.
    (WW) The directory "/usr/share/fonts/hellas/misc" does not exist.
    (WW) The directory "/usr/share/fonts/hellas/75dpi" does not exist.
    (WW) The directory "/usr/share/fonts/hellas/100dpi" does not exist.
    (WW) The directory "/usr/share/fonts/hellas/Type1" does not exist.
    (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    (WW) The directory "/usr/share/fonts/xtest" does not exist.
    (II) Loading extension MIT-SCREEN-SAVER
    (WW) NV(0): Option "CalcAlgorithm" is not used
    (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
    pc-florian:/home/fischerf # cat /etc/X11/xorg.conf
    # /.../
    # SaX generated X11 config file
    # Created on: 2007-08-19T19:22:36+0200.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [SaX2] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    FontPath "unix/:7100"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "Module"
    Load "dbe"
    Load "type1"
    Load "freetype"
    Load "extmod"
    Load "glx"
    Load "v4l"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "de"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    Option "XkbVariant" "nodeadkeys"
    EndSection

    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "9"
    Option "Device" "/dev/input/mice"
    Option "Name" "ImExPS/2 Logitech Explorer Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 376 301
    HorizSync 30-83
    Identifier "Monitor[0]"
    ModelName "BENQ FP91V+"
    Option "DPMS"
    VendorName "BNQ"
    VertRefresh 43-76
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1280x1024" 141.82 1280 1376 1512 1744 1024 1025 1028 1070
    Modeline "1280x1024" 130.17 1280 1368 1504 1728 1024 1025 1028 1066
    Modeline "1280x1024" 120.01 1280 1368 1504 1728 1024 1025 1028 1063
    Modeline "1280x1024" 108.88 1280 1360 1496 1712 1024 1025 1028 1060
    Modeline "1152x864" 106.51 1152 1224 1352 1552 864 865 868 903
    Modeline "1152x864" 97.69 1152 1224 1344 1536 864 865 868 900
    Modeline "1152x864" 90.02 1152 1224 1344 1536 864 865 868 897
    Modeline "1152x864" 81.62 1152 1216 1336 1520 864 865 868 895
    Modeline "1024x768" 83.00 1024 1080 1192 1360 768 769 772 803
    Modeline "1024x768" 76.89 1024 1080 1192 1360 768 769 772 800
    Modeline "1024x768" 70.07 1024 1080 1184 1344 768 769 772 798
    Modeline "1024x768" 64.11 1024 1080 1184 1344 768 769 772 795
    Modeline "800x600" 50.32 800 840 928 1056 600 601 604 627
    Modeline "800x600" 45.93 800 840 920 1040 600 601 604 625
    Modeline "800x600" 42.33 800 840 920 1040 600 601 604 623
    Modeline "800x600" 38.22 800 832 912 1024 600 601 604 622
    EndSection


    Section "Device"
    BoardName "GeForce FX 5200 (0x0322)"
    BusID "1:0:0"
    Driver "nv"
    Identifier "Device[0]"
    VendorName "NVidia"
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1152x864" "1024x768" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1152x864" "1024x768" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1152x864" "1024x768" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1152x864" "1024x768" "800x600"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection
     
  12. #11 quare, 20.08.2007
    Zuletzt bearbeitet: 20.08.2007
    quare

    quare Mitglied

    Dabei seit:
    03.06.2007
    Beiträge:
    41
    Zustimmungen:
    0
    Weis keiner eine Lösung?:hilfe2:


    edit:

    also habe das problem nicht gelöst sondern nur ummogelt...

    habe einfach mal die Nvidia Geforce FX 5900xt eingebaut und mit der gings auf anhieb... hatte sie zwar anfangs noch als fx5200 drinn aber selbst damit gings. Einmal Sax2 -r -m 0=nvidia war sie dann auch richtig als 5900 drinn.... kann es daran liegen das ich die fx 5200 mit nur 64 mb speicher habe?? ist das vielleicht zu wenig für den nvidia treiber?
     
  13. blck

    blck Routinier

    Dabei seit:
    15.01.2007
    Beiträge:
    268
    Zustimmungen:
    0
    Also...manchmal ist der name des Treibers nicht nv sondern nvidia also probier mal auf "ebene 2" und gebt ein sax2 -r -m 0=nvidia!

    Vielleicht geht das :D

    Wünsch dir viel erfolg
     
  14. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  15. JayBee

    JayBee Grünschnabel

    Dabei seit:
    27.08.2007
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo quare,

    ich hatte heute ein Problem, das sich genauso wie bei Dir geäußert hat:
    NVidia-Treiber für SUSE 10.2 installiert -> Neustart -> schwarzer Bildschirm statt Anmeldebildschirm.

    Bei mir war nur die Konfiguration etwas anders: NVidia Legacy-Treiber, da ich eine GForce 4 Go im Notebook habe.

    Die Ursache für mein Problem war: Der NVidia-Treiber hat den Desktop auf dem zweiten Monitor dargestellt (also über den VGA-Ausgang des Notebooks statt direkt auf das Display des Notebooks). In dem Fall kannst Du durch Umstecken des Monitors wieder ein Bild bekommen. Diese Einstellung kannst Du dann mit dem Programm

    nvidia-settings

    korrigieren. (nvidia-settings muss als root ausgeführt werden, z.B. mit kdesu nvidia-settings).

    Ich hoffe, das hilft Dir weiter.
    JB
     
  16. quare

    quare Mitglied

    Dabei seit:
    03.06.2007
    Beiträge:
    41
    Zustimmungen:
    0
    Hi, das hatte ich auch schon getestet. Aber daran lag es nicht. Habe mein Problem leider nicht beheben können. Aber habe es umgangen in dem ich eine Geforce FX5900 eingebaut habe. Mit der hat alles auf Anhieb geklappt. Die andere läuft jetzt im Windows rechner.
     
Thema:

Opensuse 10.2 + Nvidia treiber = Schwarzer Bildschrim

Die Seite wird geladen...

Opensuse 10.2 + Nvidia treiber = Schwarzer Bildschrim - Ähnliche Themen

  1. [HowTo] NVidia und 3D unter SuSE/openSUSE

    [HowTo] NVidia und 3D unter SuSE/openSUSE: NVidia und 3D unter SuSE/openSUSE Da dieses Thema immer wieder ein Problem zu sein scheint, hier mal ein kleines HowTo, das auch für Noobs...
  2. openSUSE10.3 & NVIDIA8600GT ?

    openSUSE10.3 & NVIDIA8600GT ?: Hallo Habe gerade von WinXP auf openSUSE10.3 gewechselt, also bin noch Anfänger und habe eigentlich alles ohne fehler installieren können, aber...
  3. OpenSUSE 10.3, 3D-Beschleunigung, NVIDIA Geforce 7600 Go, Problem mit Einrichtung

    OpenSUSE 10.3, 3D-Beschleunigung, NVIDIA Geforce 7600 Go, Problem mit Einrichtung: Hallo, ich bin blutiger Anfänger auf dem Gebiet OpenSUSE und Linux, möchte aber gerne auf das System umsteigen da ich es durchaus ansprechend...
  4. Hilfe für NVIDIA Grafiktreiber für openSUSE 10.2

    Hilfe für NVIDIA Grafiktreiber für openSUSE 10.2: Hallo, Achtung, ich bin extremer Linuxfrischling!!! Ich habe folgendes Problem: Ich habe openSuse von DVD parallel zu Windows installiert....
  5. Pivotfunktion unter OpenSuse10.2 NVIDIA 8800 GTS?? Drehen um 90° Grad??

    Pivotfunktion unter OpenSuse10.2 NVIDIA 8800 GTS?? Drehen um 90° Grad??: Hallo zusammen, was mir gerade auffällt, ich weiß gar nicht wie ich unter o.g. OS u. Grafikkarte das Monitorbild um 90° Grad drehen kann, damit...