openGL 855GM/i810

Dieses Thema im Forum "Grafik / Video" wurde erstellt von Schlaftänzer, 31.05.2006.

  1. #1 Schlaftänzer, 31.05.2006
    Schlaftänzer

    Schlaftänzer Grünschnabel

    Dabei seit:
    29.04.2005
    Beiträge:
    5
    Zustimmungen:
    0
    Moin,

    Habe schon in einem anderen Forum nach Hilfe gesucht, aber leider keine bekommen. Vielleicht klappts hier. Mein Problem ist, daß openGL unter Debian mit der Graka-Karte 855GM und dem Treiber i810 nicht funktioniert.

    glxinfo zeigt mir immer nur "direct rendering no"

    folgende Module wurden geladen:

    dri
    drm
    i810
    agpgart
    intel_agp

    (II) Loading /usr/X11R6/lib/modules/drivers/linux/v4l_drv.o
    (II) LoadModule: "dri"
    (II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
    (II) Module dri: vendor="X.Org Foundation"
    (II) Loading /usr/X11R6/lib/modules/drivers/i810_drv.o
    ABI class: X.Org XInput driver, version 0.4
    ABI class: X.Org XInput driver, version 0.4
    ABI class: XFree86 XInput driver, version 0.3
    (II) v4l driver for Video4Linux
    (II) Synaptics touchpad driver version 0.14.4 (1404)
    (II) Loading sub module "drm"
    (II) LoadModule: "drm"
    (II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
    (II) Module drm: vendor="X.Org Foundation"
    (II) LoadModule: "i810"
    (II) Loading /usr/X11R6/lib/modules/drivers/i810_drv.o
    (II) Module i810: vendor="X.Org Foundation"
    (II) I810: Driver for Intel Integrated Graphics Chipsets: i810, i810-dc100,
    i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G, 915GM

    was mich aber stutzig macht:

    opengl:~# lsmod | grep i810
    i810 21440 0
    drm 70904 1 i810

    warum wird das modul i810 nicht verwendet, sonder nur agpgart.

    opengl:~# lsmod | grep agp
    intel_agp 21212 1
    agpgart 33640 3 drm,intel_agp

    in der Xorg.0.log hab ich das hier noch gefunden. Ich bin mir aber nicht sicher ob das der Fehler sein könnte.

    opengl:~# grep GLcore /var/log/Xorg.0.log
    (WW) Ignoring request to load module GLcore
    (II) Loading sub module "GLcore"
    (II) LoadModule: "GLcore"
    (II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
    Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o": No symbols found
    Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o": No symbols found
    Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o": No symbols found
    (II) Module GLcore: vendor="X.Org Foundation"

    vielleicht könnt ihr euch meinem Problem annehmen und mir ein wenig auf die Sprünge helfen.

    Gruß Jürgen
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 damager, 31.05.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
  4. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Imho bin ich da der gleichen Meinung ... die closed-source Intel treiber bieten erst "3D" ...
     
  5. #4 damager, 01.06.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    und, genau da ist das problem ... weder der rpm-treiber noch der tar-ball lassen sich installieren :(

    werde später evtl mal die fehlermeldungen hier posten.
     
  6. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Poste mal ;)
     
  7. #6 Schlaftänzer, 01.06.2006
    Schlaftänzer

    Schlaftänzer Grünschnabel

    Dabei seit:
    29.04.2005
    Beiträge:
    5
    Zustimmungen:
    0
    ok danke für die Antworten.

    Aber wo finde ich closed source treiber für meine Karte? Bei Intel selbst habe ich nichts gefunden.
     
  8. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Damanger hatte oben den Link gepostet ...

    Tar.gz findest du hier
     
  9. #8 damager, 01.06.2006
    Zuletzt bearbeitet: 01.06.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    hier die fehlermeldung beim kompilieren:
    da fehlt doch irgendwas im makefile bzw ist falsch. es gibt gar keinen pfad mit »/X11R6/SourceForge/Mesa6.2/Mesa/include/GL/gl.h«

    edit:
    irgendwie vergeht mit die lust makefiles zu editieren wenn ich sehe in wievielen files der parameter "MESASRCDIR" falsch ist :-(

     
  10. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Hmmm ... mangels Intel Grafikkarte kann ich das nun nicht direkt testen.
     
  11. #10 Schlaftänzer, 02.06.2006
    Schlaftänzer

    Schlaftänzer Grünschnabel

    Dabei seit:
    29.04.2005
    Beiträge:
    5
    Zustimmungen:
    0
    Bei mir läuft das Makefile auch nicht ohne Fehler durch. Werd mich morgen mal darüber her machen, wenn ich die Welt wieder mit normalen Augen sehe *hundemüde*
     
  12. #11 damager, 02.06.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    @Schlaftänzer:
    mit dem gleichen fehler?
    hmm...evtl. doch mal versuchen die 10.1 mit dem "alten" rpm zu vergewaltigen :sly:
     
  13. #12 Schlaftänzer, 03.06.2006
    Zuletzt bearbeitet: 02.11.2008
    Schlaftänzer

    Schlaftänzer Grünschnabel

    Dabei seit:
    29.04.2005
    Beiträge:
    5
    Zustimmungen:
    0
    Nein bekomme diesen Fehler. Mangels Linuxroutine kann ich mit der Fehlermeldung nicht wirklich viel anfangen.
     
  14. #13 damager, 03.06.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    nein, unter suse habe ich es auch nicht zum laufen bekommen...zumindest nicht aus dem tar-ball. den rpm-test habe ich noch nicht machen. komme wahrscheinlich erst mittwoch dazu...da nur mein dienst-laptop diesen intel-chipsatz hat.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Schlaftänzer, 05.06.2006
    Schlaftänzer

    Schlaftänzer Grünschnabel

    Dabei seit:
    29.04.2005
    Beiträge:
    5
    Zustimmungen:
    0
    bin mal gespannt ob er unter Suse funktioniert.

    Ich meine das mein Kollege ohne dem closed source Treiber openGL am laufen hat. Allerdings unter Gentoo. Leider ist er im Urlaub, aber wenn er wieder kommt hab ich schon ne Aufgabe für ihn ;) :devil:
     
  17. #15 damager, 05.06.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    @Schlaftänzer:
    wenn das tatsächlich so sein soll ... dann MUSS er uns dran teilhaben lassen :]
    wegen suse sag ich dann nochmal bescheid.
     
Thema:

openGL 855GM/i810

Die Seite wird geladen...

openGL 855GM/i810 - Ähnliche Themen

  1. Mesa 11.0 bringt OpenGL 4.1

    Mesa 11.0 bringt OpenGL 4.1: Die Entwickler der freien 3D-Grafikbibliothek Mesa haben die Version 11.0 veröffentlicht. Diese vorläufig noch experimentelle Version hebt die...
  2. Khronos: Fortschritte bei Vulkan und Erweiterungen für openGL und OpenGL ES

    Khronos: Fortschritte bei Vulkan und Erweiterungen für openGL und OpenGL ES: Die Khronos Group, ein Branchenkonsortium zum Entwickeln von Grafik- und Parallelberechnungs-Standards, hat die Spezifikation OpenGL ES in Version...
  3. OpenGL-Nachfolger Vulkan angekündigt

    OpenGL-Nachfolger Vulkan angekündigt: Die Khronos Group hat den Nachfolger der Standardschnittstelle für 3D-Grafik enthüllt. Die kommende Spezifikation trägt den Namen Vulkan und steht...
  4. Khronos kündigt Next-Gen-Version von OpenGL an

    Khronos kündigt Next-Gen-Version von OpenGL an: Die Khronos Group, das Inustriekonsortium hinter dem Standard für die plattform- und programmiersprachenunabhängige 3D-Grafik-Entwicklung, hat...
  5. Neuer Treiber von AMD unterstützt OpenGL 4.4

    Neuer Treiber von AMD unterstützt OpenGL 4.4: AMD hat eine neue Version seiner proprietären ATI-Treiber veröffentlicht, die die Unterstützung für OpenGL erheblich erweitern. Zudem korrigiert...