NX lässt mich nich rein

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von Nemesis, 23.05.2008.

  1. #1 Nemesis, 23.05.2008
    Zuletzt bearbeitet: 26.05.2008
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    hi,
    mein nx will mich nicht reinlassen, als fehler wirft es mir aus:
    Code:
    NX> 203 NXSSH running with pid: 13797
    NX> 285 Enabling check on switch command
    NX> 285 Enabling skip of SSH config files
    NX> 285 Setting the preferred NX options
    NX> 200 Connected to address: XX.XXX.XX.XXX on port: 22
    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    HELLO NXSERVER - Version 3.0.0-61 - LFE
    NX> 105 Hello NXCLIENT - Version 3.0.0
    NX> 134 Accepted protocol: 3.0.0
    NX> 105 Set shell_mode: shell
    NX> 105 Set auth_mode: password
    NX> 105 Login 
    NX> 101 User: nemesis
    NX> 102 Password: ***********
    NX> 103 Welcome to: localhost user: nemesis
    NX> 105 Listsession --user="nemesis" --status="suspended\054running" --geometry="1280x1024x24+render" --type="unix-gnome" 
    NX> 127 Available sessions: 
    
    Display Type             Session ID                       Options  Depth Screen         Status      Session Name
    ------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------
    
    NX> 148 Server capacity: not reached for user: nemesis
    NX> 105 Start session with: --link="adsl" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --session="nemesis-svr" --type="unix-gnome" --geometry="800x600+240+192" --client="linux" --keyboard="pc102\057de" --screeninfo="800x600x24+render" 
    NX> 502 ERROR: Public key authentication failed
    NX> 502 ERROR: NX server was unable to login as user: nemesis
    NX> 502 ERROR: Please check that the account is enabled to login,
    NX> 502 ERROR: the user's home directory, the directory ~/.ssh
    NX> 502 ERROR: and the file ~/.ssh/authorized_keys2 have correct
    NX> 502 ERROR: permissions setting according to the StrictModes
    NX> 502 ERROR: of your SSHD configuration.
    NX> 999 Bye.
    über ssh kann ich mich einloggen:
    Code:
    :~$ ssh -i .ssh/default.id_dsa.key nx@XX.xxx.XX.xxx
    HELLO NXSERVER - Version 3.0.0-61 - LFE
    NX> 105 
    
    wenn ich mich mit nemesis statt nx über ssh einloggen möchte bringt er auch:
    Code:
    Permission denied (publickey)
    den key habe ich erzeugt mittels:
    Code:
    /usr/NX/scripts/setup/nxserver --keygen
    und habe dann den dadurch erzeugten /usr/NX/home/nx/.ssh/default.id_dsa.pub nach /usr/NX/home/nx/.ssh/authorized_keys
    und mittels /usr/NX/share/keys/default.id_dsa.key sollte ich mich da doch nun einloggen können, oder ?

    die rechte der files:
    Code:
    -rw-r--r-- 1 nemesis nemesis  402 2008-05-23 16:28 authorized_keys
    -rw-r--r-- 1 nx      root     668 2008-05-23 19:16 authorized_keys2
    -rw-r--r-- 1 nemesis nemesis  668 2008-05-23 16:42 xn.id_dsa.key
    thx!

    edit:
    noch mehr infos:
    Code:
    /usr/NX/bin/nxserver --usercheck nemesis
    NX> 900 Verifying public key authentication for NX user: nemesis.
    NX> 900 Adding public key for user: nemesis to the authorized keys file.
    NX> 900 Verifying public key authentication for NX user: nemesis.
    NX> 500 ERROR: Public key authentication failed
    NX> 500 WARNING: NX server was unable to login as user: nemesis
    NX> 500 WARNING: Please check that the account is enabled to login.
    NX> 500 WARNING: Also check that user's home directory, the directory
    NX> 500 WARNING: ~/.ssh and the file ~/.ssh/authorized_keys2 have
    NX> 500 WARNING: correct permissions according to the StrictModes of
    NX> 500 WARNING: your SSHD configuration
    NX> 999 Bye.

    edit:
    also, wenn ich nur die authorized_keys datei die nx erstellt in die sshd_config eintrage, dann funktioniert es, nur leider kann ich mich dann nichtmehr mit meinem ssh-schlüssel einloggen. wenn ich die schlüssel aus beiden dateien in eine packe, dann kann ich mich wieder nicht mit nx einloggen.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

NX lässt mich nich rein

Die Seite wird geladen...

NX lässt mich nich rein - Ähnliche Themen

  1. Michael Löffler verlässt Novell

    Michael Löffler verlässt Novell: Der langjährige Novell-Angestellte und Vorsitzende des OpenSuse-Boards, Michael Löffler, nimmt zum Jahresende seinen Hut. Das gab Löffler in...
  2. ub-jabber-server lässt mich nicht rein

    ub-jabber-server lässt mich nicht rein: hi, kann das sein, dass sich am ub-jabberserver was geändert hat die letzten tage? min gaim (2.0.1) lässt mich, mit der aussage ich seie nicht...
  3. ubuntu: Gnome lässt mich nicht rein

    ubuntu: Gnome lässt mich nicht rein: Hallo, ich habe Probleme mich bei Gnome im gdm einzuloggen. Heute installierte ich im Gnome aktuelle Sicherheits- und sonstige Empfehlungen,...
  4. KDE-3.5.5 kdesktop_lock lässt mich nicht mehr raus

    KDE-3.5.5 kdesktop_lock lässt mich nicht mehr raus: Hi Seit ich nun KDE-3.5.5 verwende fällt mir folgendes auf: Sperre ich die Arbeitsfläche (kdesktop_lock) kann ich diese Sperre nicht mehr...
  5. samba lässt mich nicht rein

    samba lässt mich nicht rein: Hi, ich habe samba 3.0.10-1ubuntu3 unter ubuntu auf einem notebook laufen. mein samba konfiguriere ich via swat. ich habe folgendes...