NVidia-Treiber sucht nach linux/config.h

Dieses Thema im Forum "Grafik / Video" wurde erstellt von gropiuskalle, 07.10.2007.

  1. #1 gropiuskalle, 07.10.2007
    Zuletzt bearbeitet: 07.10.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Ich versuche gerade, für meine olle NVidia RIVA TNT2 Model 64/Model 64 Pro die 3D-Beschleunigung einzurichten. Bislang funktionierte es mit exakt diesem Treiber ('NVIDIA-Linux-x86-1.0-7184-pkg1.run') immer tadellos:

    Code:
    su
    init 3
    sh ~/NVIDIA-Linux-x86-1.0-7184-pkg1.run -q
    sax2 -r -m 0=nvidia
    init 5
    ...und fertig. Leider bricht das Ganze bei mir nach dem dritten Befehl mit dem lapidarem Hinweis 'Unable to build the NVIDIA kernel module.' ab. /var/log/nvidia-installer.log scheint auch den Fehler anzugeben:

    Code:
    error: linux/config.h: No such file or directory
    Gefunden habe ich immerhin den Ordner /usr/include/linux, wo ich ein 'touch config.h' ausführte. Beim nächsten Versuch blieb die Meldung leider die gleiche.

    Im Anhang liegt die komplette log.

    Edit:

    Code:
    test -e include/linux/autoconf.h -a -e include/config/auto.conf || (		\
       	echo;								\
       	echo "  ERROR: Kernel configuration is invalid.";		\
       	echo "         include/linux/autoconf.h or include/config/auto.conf are missing.";	\
    Ein 'touch autoconf.h' im selben Verzeichnis brachte auch nix...
     

    Anhänge:

  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Gast1

    Gast1 Guest

  4. #3 gropiuskalle, 08.10.2007
    Zuletzt bearbeitet: 08.10.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Danke für die Hilfestellung - leider klappt es nicht so wie erhofft und ich stehe ein wenig auf dem Schlauch, weil der link etwas spärliche Informationen darüber liefert, was denn nach der Installation des Treibers zu geschehen hat. Wenn ich direkt danach den X-Server beende, finde ich mich auf der Konsole wieder. 'startx' ergibt ein

    Code:
    Fatal server error:
    no screens found
    Mit 'sax2' bzw. 'sax2 -r' erhalte ich zwar meine GUI wieder, aber keine 3D-Unterstützung. 'nvidia-settings' teilt mir mit, ich solle 'nvidia-xconfig' ausführen, was ich dann auch mache, jedoch geht das Spiel dann wieder von vorne los.

    Watt nu?
     
  5. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    glx und dri auskommentiert ?
    andere auflösungen farbtiefen getestet ?
     
  6. #5 supersucker, 08.10.2007
    Zuletzt bearbeitet: 08.10.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    @doc

    Die Fehlermeldung hat definitiv __nichts__ damit zu tun.

    @kalle

    Ich hatte mal genau das gleiche Problem in einem anderen Kontext.

    IMHO solltest du die config.h auch nicht "touchen", sondern genau das hier

    machen.
     
  7. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    diese fehlermeldung:
    Fatal server error:
    no screens found

    kann verdammt viele ursachen haben
     
  8. #7 gropiuskalle, 08.10.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    In diesem Fall gehe ich trotzdem erstmal supersuckers Hinweis nach, den Hinweis auf die simple Auskommentierung der entsprechenden Segmente habe ich beim googeln nämlich auch schon als Alternative zu meinen Versuchen äh... ergoogelt, aber dann kam mir RAIN_MAKERS link gwissermaßen dazwischen.

    @supersucker, noch mal sicherheitshalber nachgefragt, der Tipp mit dem Auskommentieren bezieht sich doch vermutlich auf meinen alten Treiber bzw. dem entsprechendem Installerskript ('NVIDIA-Linux-x86-1.0-7184-pkg1.run') oder? Oder soll ich die per YaST installierten Treiber deinstallieren und das ganze in NVIDIA-Linux-x86-71.86.01-pkg1.run auskommentieren und dann wie Eingangs erwähnt ('init 3' und so weiter) installieren?
     
  9. Zedar

    Zedar Conquer All

    Dabei seit:
    26.02.2007
    Beiträge:
    207
    Zustimmungen:
    0
    Ort:
    Gemünden
    Ich hatte das Problem auch, da haben gepatchte Treiber von NVidia geholfen.

    Leider kann ich derzeit nicht den Link geben, weil ich nicht zuhause bin.

    Ich denke wenn du die Zeilen auskommentieren willst, musst du den Treiber de- und reinstallieren.

    Was sagt denn der Xserver log?

    Gruß

    Zedar
     
  10. #9 gropiuskalle, 08.10.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Okay, ich versuch das einfach mal mit beiden und fange mit dem neuen an.

    Welche Datei meinst Du damit genau?
     
  11. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    /var/log/Xorg.0.log
     
  12. #11 gropiuskalle, 08.10.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Hier ist sie:
     

    Anhänge:

  13. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    in deiner xorg.conf

    ersetze mal die zeile:

    Driver "nv"

    mit

    Driver "nvidia"
     
  14. Zedar

    Zedar Conquer All

    Dabei seit:
    26.02.2007
    Beiträge:
    207
    Zustimmungen:
    0
    Ort:
    Gemünden
    Sorry, ich sitz grad an einem XP-Rechner und kann deine Xorg.0.log nicht richtig ansehen.

    Hat das mit dem Neuinstallieren geklappt?
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 gropiuskalle, 08.10.2007
    Zuletzt bearbeitet: 08.10.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Ich sitz hier gerade zwischen so allerlei Lösungsansätzen, Deine kommt gleich noch dran, fall es nicht hinhaut... :)

    Welche Zeile soll das sein?

    [hier stand eine falsche Datei]

    Edit: Argh, das ist die Uhrzeit, Du meintest die /etc/X11/xorg.conf. Melde mich gleich nochmal :) ...
     
  17. #15 doc, 08.10.2007
    Zuletzt bearbeitet: 08.10.2007
    doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    nein in deiner xorg.conf

    in /etc/X11

    ps. wenn der server dann nich startet, vorher noch ein modprobe nvidia. wenns immer noch nich geht noch mal das log von dem fehlversuch, weil dein log von eben war von einer erfolgreich gestarteten xsession aber du lädst da nur den nv treiber, der unterstützt kein 3d
     
Thema:

NVidia-Treiber sucht nach linux/config.h

Die Seite wird geladen...

NVidia-Treiber sucht nach linux/config.h - Ähnliche Themen

  1. Nvidia-Treiber mit Unterstützung für Optimus

    Nvidia-Treiber mit Unterstützung für Optimus: Der als Beta bezeichnete proprietäre Linux-Treiber 319.12 von Nvidia bietet erstmals rudimentäre Unterstützung für Optimus. Weiterlesen...
  2. nvidia-Treiber: Virtuelle Terminals bleiben schwarz

    nvidia-Treiber: Virtuelle Terminals bleiben schwarz: Hallo allerseits. (Oh man, seit vier Jahren das erste Mal wieder hier, echt spannend, sich selbst als Vierzehnjährigen zu erleben ;D) Aber nun zu...
  3. NVIDIA-Treiber instabil mit neuem Kernel

    NVIDIA-Treiber instabil mit neuem Kernel: HALLO Seit ich am 14.Oct meinen Kernel von 2.6.26 auf 2.6.27 aktualisiert habe, stürzt der X-Server einige Minuten nach dem Start wieder ab....
  4. nVidia-Treiber-Installation auf Kernel 2.6.25

    nVidia-Treiber-Installation auf Kernel 2.6.25: Ich habe mir eben für Debian testing den aktuellen Kernel (2.6.25) kompiliert. Dann habe ich mit diesem Kernel gebootet und wollte meinen...
  5. Neuer Nvidia-Treiber Version: 169.12

    Neuer Nvidia-Treiber Version: 169.12: Am 26. Februar ist der neue Nvidia-Treiber rausgekommen: Changelog: * Improved power management support with GeForce 8 GPUs. *...