Nt_status_logon_failure

Dieses Thema im Forum "Samba" wurde erstellt von kabel, 25.06.2008.

  1. kabel

    kabel Grünschnabel

    Dabei seit:
    25.06.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo Community,

    seit längerer Zeit habe ich mich jetzt auf einem Server mit Samba rumgeschlagen, ich wollte es alleine hinkrigen, leider bin ich grad etwas verzweifelt und glaube das ich besser hier mal frage wo ich weiter suchen soll.:hilfe2:
    Der Samba Server steht in einem Nezwerk mit 3 andern Windows XP Rechnern. Der Server ist ein Debian Server.

    Zuerst mal meine smb.conf: http://rafb.net/p/CHg0hV26.html

    So dann hab ich noch folgende Tests gemacht:

    ctm:/home/samba# smbclient -L server -N
    Anonymous login successful
    Domain=[CTM-NETWORK] OS=[Unix] Server=[Samba 3.0.24]

    Sharename Type Comment
    --------- ---- -------
    IPC$ IPC IPC Service (Samba Server)
    Anonymous login successful
    Domain=[CTM-NETWORK] OS=[Unix] Server=[Samba 3.0.24]

    Server Comment
    --------- -------
    CTM Samba Server

    Workgroup Master
    --------- -------
    CTM-NETWORK CTM


    ctm:/home/samba# testparm -s
    Load smb config files from /etc/samba/smb.conf
    Processing section "[homes]"
    Loaded services file OK.
    Server role: ROLE_STANDALONE
    [global]
    workgroup = CTM-NETWORK
    server string = Samba Server
    log file = /usr/local/samba/var/log.%m
    max log size = 50
    dns proxy = No

    [homes]
    comment = Home Directories
    write list = kabel
    read only = No
    create mask = 0755
    browseable = No

    ctm:/home/samba# nmblookup -B 192.168.1.110 __SAMBA__
    querying __SAMBA__ on 192.168.1.110
    192.168.1.110 __SAMBA__<00>


    ctm:/home/samba# nmblookup -B 192.168.1.110 "*"
    querying * on 192.168.1.110
    192.168.1.110 *<00>



    ctm:/home/samba# nmblookup -d 2 '*'
    added interface ip=192.168.1.110 bcast=192.168.1.255 nmask=255.255.255.0
    querying * on 192.168.1.255
    Got a positive name query response from 192.168.1.110 ( 192.168.1.110 )
    192.168.1.110 *<00>

    smbclient //server/kabel
    Password:
    session setup failed: NT_STATUS_LOGON_FAILURE


    So, ich weiss echt nicht weiter, und würde mich echt über Ratschläge freuen.

    Falls noch irgendwelche Infos benötigt werden bitte nachfragen, dann hab ich nur vergessen sie niederzuschreiben.
    smbpasswd -a kabel wurde auch schon durchgefürt.

    Mit Freundlichen Grüssen,

    Kabel
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 NoXqs, 25.06.2008
    Zuletzt bearbeitet: 25.06.2008
    NoXqs

    NoXqs Routinier

    Dabei seit:
    07.05.2007
    Beiträge:
    420
    Zustimmungen:
    0
    Ort:
    Bremen
    Erstmal:
    ändern in

    Code:
    [homes]
            comment = Home Directories
     	browsable = no
     	writable = yes
    
    und der user 'kabel' ist auch ein regulärer Benutzer im Linux-System?

    Manchmal hilft auch ein Blick in die smbd.log.
    Kannst du die Ausgabe des entsprechenden Hosts mal posten?
     
  4. kabel

    kabel Grünschnabel

    Dabei seit:
    25.06.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo,

    Erstmals danke für die (schnelle) Antwort, ich habe das nun geändert, leider hat sich das Problem nicht dadurch gelöst.
    Hier gibs die smbd.log des Servers: http://rafb.net/p/Lyphp734.html

    Sieht jetzt nicht so gut aus :S
    Ich hatte vorhin nach der Fehlermeldung gegooglt, und ich habe gelesen dass die Fehlermeldung normal sein sollte, jedoch bin ich mittlerweile nicht mehr so überzeugt, vielleicht wisst ihr mehr.

    Mit freundlichen Grüssen,
    Kabel
     
  5. NoXqs

    NoXqs Routinier

    Dabei seit:
    07.05.2007
    Beiträge:
    420
    Zustimmungen:
    0
    Ort:
    Bremen
    aus der log:

    Code:
    [2008/06/25 13:39:36, 0] param/loadparm.c:map_parameter(2698)
      Unknown parameter encountered: "read prediction"
    
    In deiner geposteten smb.conf findet sich dieser Parameter nicht.
    Der smbd liest nicht die von dir angegebene smb.conf ein, wie es aussieht.
    Da würde ich mal forschen.
    Allerdings ist merkwürdig, dass testparm das nicht auch ausgibt.
     
  6. kabel

    kabel Grünschnabel

    Dabei seit:
    25.06.2008
    Beiträge:
    4
    Zustimmungen:
    0
    hi,

    Ja, da hast du recht, mein Fehler sry.
    Ich hab heute sehr viel rumexperimentiert, mit verschiedenen smb.conf files, das aus dem log wird wohl noch ein Rest von einer andern Config sein.

    Ab hier: müsste es passen:
    Copyright Andrew Tridgell and the Samba Team 1992-2006
    [2008/06/25 14:04:03, 0] smbd/server.c:main(847)
    Allerdings steht da nicht mehr viel :S

    Was könnte ich denn noch probieren um mögliche Fehler auszuschliessen?

    Mit freundlichen Grüssen,
    Kabel
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. NoXqs

    NoXqs Routinier

    Dabei seit:
    07.05.2007
    Beiträge:
    420
    Zustimmungen:
    0
    Ort:
    Bremen
    Du könntest den
    Code:
    log level = 3
    
    setzen.
    Dann wird samba sehr gesprächig und in den logfiles findet sich eine ganze menge mehr.
    Außerdem hast du den Output von smbd.log gepostet.
    Das ist zwar schön wenn ich mir den Startvorgang des smb-servers angucken will, aber die Verbindungen werden gem. deiner smb.conf jeweils in einer eigenen log-datei geschrieben.

    Also schaue dir die log-datei an, die für den Rechner ist, der versucht die Verbindung aufzubauen.
     
  9. kabel

    kabel Grünschnabel

    Dabei seit:
    25.06.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo nochmals,

    ich bedanke mich nochmals. Danke für die Hilfe, ich hatte in letzter Zeit nicht soviel Zeit mich um die Sache zu kümmern, jedoch habe ich glaube ich das Problem gefunden, so dumm es auch klingt, die Rechte der config file waren zu streng gesetzt :S

    mit freundlichen Grüßen,
    Kabel
     
Thema:

Nt_status_logon_failure