nfs-mount problem

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Linuxneuling, 12.07.2004.

  1. #1 Linuxneuling, 12.07.2004
    Linuxneuling

    Linuxneuling Tripel-As

    Dabei seit:
    09.02.2004
    Beiträge:
    249
    Zustimmungen:
    0
    Möchte ein Verzeichnis der FTP Server (s218750c) zu Server (s218750b) mounten, wo die Daten gesichert werden. Wenn ich über Server ein Verzeichnis /home/ftpusers/ mounte, dann sehe ich auf Server ganz andere Benuzer und Gruppen der Dateien. Wie kann ich das Verzeichnis so mounten, damit diese auch auf Lokalen Server richtig dargestellt werden?

    Wenn ich auf FTP Server den rcnfsserver restarte kommen folgende Meldungen:
    exportfs: s218750b has non-inet addr
    exportfs: s218750b has non-inet addr
    exportfs: No host name given with /home/ftpusers (rw), suggest *(rw) to avoid warning
    exportfs: /etc/exports [2]: No 'sync' or 'async' option specified for export ":/home/ftpusers".
    Assuming default behaviour ('sync').
    NOTE: this default has changed from previous versions

    Was bedeutet es, besonders has non-inet addr??
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 shellmaster, 12.07.2004
    shellmaster

    shellmaster Doppel-As

    Dabei seit:
    21.08.2003
    Beiträge:
    122
    Zustimmungen:
    0
    soweit ich das verstanden habe, stimmen die benutzer (uid+gid) nicht überein. also wenn du dateien auf den andern rechner überträgts haben die plötzlich ne andere uid, also gehören einem anderen benutzer. so richtig?
    das problem ist dass der benutzer auf deinem rechner z.b die uid 502 hat, auf dem andern rechner hat aber ein anderer benutzer uid 502. also werden die benutzer vertauscht.
    du musst dann dafür sorgen, dass die benutzerkennug auf allen rechnern harmonisieren. ich würde NIS dafür benutzen, kannste bei suse mit yast einrichten, glaub ich...
    gruss
     
  4. #3 damager, 12.07.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    stehen diese server in der /etc/hosts (auf beiden server'n)?
    wenn "nein" ... eintragen :]
     
  5. hopfe

    hopfe Haudegen

    Dabei seit:
    01.04.2003
    Beiträge:
    733
    Zustimmungen:
    0
    Ort:
    Aachen
    Oder den richtigen lokalen DN-Server, in deiner /etc/resolv.conf verwenden.
     
  6. #5 Linuxneuling, 12.07.2004
    Linuxneuling

    Linuxneuling Tripel-As

    Dabei seit:
    09.02.2004
    Beiträge:
    249
    Zustimmungen:
    0
    Zitat von Linuxneuling
    exportfs: s218750b has non-inet addr
    exportfs: s218750b has non-inet addr
    Was bedeutet es, besonders has non-inet addr??

    stehen diese server in der /etc/hosts (auf beiden server'n)?
    wenn "nein" ... eintragen

    habe erst eingetragen und es kommt trotzdem noch immer, obwohl ich auch ein DNS Server auf Windows Server habe??

    Ich will NIS nicht verwenden. Ich werde bei mount ein Benutzer, der auf beide Systeme existiert anhängen. Nur die Frage ist, welches mount ist besser smbmount oder doch mount ? Auf beide Server existieren SAMBA.
     
  7. #6 damager, 12.07.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    imho benutzt mount gleich smbmount sobald als typ "smb" angegeben wurden.
    dürfte also egal sein ...

    was die fehlermeldungen angeht:
    kann z.b nslookup "s218750b " auflösen?
    steht dieser windoff dns-server auch bei dir in der /etc/reslov.conf?
     
  8. #7 Linuxneuling, 12.07.2004
    Linuxneuling

    Linuxneuling Tripel-As

    Dabei seit:
    09.02.2004
    Beiträge:
    249
    Zustimmungen:
    0
    nmblookup s218750b
    querying s218750b on 10.45.94.255
    10.45.94.12 s218750b<00>

    Ja, der Win DNS Server ist im resolv.conf eingetragen.
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 damager, 12.07.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    hmmm...das ist ja der samba-lookup.
    was sagt aber der nslookup?
     
  11. #9 Linuxneuling, 19.07.2004
    Linuxneuling

    Linuxneuling Tripel-As

    Dabei seit:
    09.02.2004
    Beiträge:
    249
    Zustimmungen:
    0
    noch eine Frage zu mount:

    Hab mal wo gelesen, wenn man das Dateisystem von Windows irgendwie falsch mountet, kann diese defekt werden. Also wie mounte ich richtig mit option smbfs nfs oder gar ntfs? Ist das wirklich ein Unterschied, wenn ich ntfs oder smbfs mounte??
     
Thema:

nfs-mount problem

Die Seite wird geladen...

nfs-mount problem - Ähnliche Themen

  1. keine rechte bei NFS-mount

    keine rechte bei NFS-mount: Hallo zusammen, Ich hoffe mal ich bin hier richtig... also ich habe unter einem fedora 8 rechner (IP: 192.168.1.6) das verzeichnis...
  2. Virtualboxproblem

    Virtualboxproblem: Hallo Folgnedes Problem: Ich kann ohne Probleme In Debian-Sid, 64Bit und virtualbox-dkms Unixoide installieren, wenn es sich um eine...
  3. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  4. Problem bei apt-get upgrade (Kali 2.0)

    Problem bei apt-get upgrade (Kali 2.0): Hi, seit paar Tagen habe ich einige Probs. Dachte es sei mal an der Zeit für ein Update und nun tauchen da einige Fehler auf: Es müssen noch 0 B...
  5. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...