NetworkManager soll WLAN beim Booten Starten

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von Asturio, 22.01.2010.

  1. #1 Asturio, 22.01.2010
    Zuletzt bearbeitet: 22.01.2010
    Asturio

    Asturio Asturio Kee

    Dabei seit:
    16.02.2006
    Beiträge:
    34
    Zustimmungen:
    0
    Hallo zusammen,

    ich habe zu diesem Thema gesucht und weder hier noch bei Google etwas gefunden. Und zwar: Ich habe bei mir einen Ubuntu Rechner 9.10, wo der NetworkManager läuft. Wenn ich mich einlogge, dann wird mit Gnome der nm-applet mit gestartet und der NetworkManager erkennt die Netze und Verbindet sich mit der richtigen.

    Was ich nun will, ist dass der Rechner sofort nach dem Boot sich mit dem Netz verbindet, ohne dass ein Benutzer sich anmelden muss. Ich habe schon versucht mit dem nm-applet die Verbindung als "für alle Benutzer verfügbar" zu markieren, aber das hilft nicht. Ich habe erst Netz in dem Rechner, wenn ich mich in Gnome anmelde (nm-applet).

    Hat jemand eine Idee?

    Grüße,

    Asturio
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Hier noch einige Logs, die eventuell helfen:

    /var/logs/daemon.log:
    Jan 22 14:12:46 aragorn NetworkManager: SCPlugin-Ifupdown: devices added (path: /sys/devices/pci0000:00/0000:00:1d.7/usb1/1-4/1-4:1.0/net/wlan0, iface: wlan0)
    Jan 22 14:12:46 aragorn NetworkManager: SCPlugin-Ifupdown: device added (path: /sys/devices/pci0000:00/0000:00:1d.7/usb1/1-4/1-4:1.0/net/wlan0, iface: wlan0): no ifupdown configuration found.
    ...
    Jan 22 14:12:46 aragorn NetworkManager: <info> (wlan0): driver supports SSID scans (scan_capa 0x01).
    Jan 22 14:12:46 aragorn NetworkManager: <info> (wlan0): new 802.11 WiFi device (driver: 'rt73usb')
    Jan 22 14:12:46 aragorn NetworkManager: <info> (wlan0): exported as /org/freedesktop/NetworkManager/Devices/1
    Jan 22 14:12:46 aragorn NetworkManager: <info> (wlan0): now managed
    Jan 22 14:12:46 aragorn NetworkManager: <info> (wlan0): device state change: 1 -> 2 (reason 2)
    Jan 22 14:12:46 aragorn NetworkManager: <info> (wlan0): bringing up device.
    Jan 22 14:12:46 aragorn NetworkManager: <info> (wlan0): preparing device.
    Jan 22 14:12:46 aragorn NetworkManager: <info> (wlan0): deactivating device (reason: 2).
    Jan 22 14:12:46 aragorn NetworkManager: supplicant_interface_acquire: assertion `mgr_state == NM_SUPPLICANT_MANAGER_STATE_IDLE' failed
    Jan 22 14:12:46 aragorn NetworkManager: <info> Trying to start the supplicant...
    Jan 22 14:12:46 aragorn NetworkManager: <info> (wlan0): supplicant manager state: down -> idle
    Jan 22 14:12:46 aragorn NetworkManager: <info> (wlan0): device state change: 2 -> 3 (reason 0)
    Jan 22 14:12:47 aragorn NetworkManager: <info> (wlan0): supplicant interface state: starting -> ready

    Bis hier war nur der Boot dran... jetzt nachdem ich mich eingeloggt habe:
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) starting connection 'Auto karameikos'
    Jan 22 14:13:39 aragorn NetworkManager: <info> (wlan0): device state change: 3 -> 4 (reason 0)
    Jan 22 14:13:39 aragorn NetworkManager: <info> Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
    Jan 22 14:13:39 aragorn NetworkManager: <info> (wlan0): device state change: 4 -> 5 (reason 0)
    Jan 22 14:13:39 aragorn NetworkManager: <info> Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0/wireless): access point 'Auto karameikos' has security, but secrets are required.
    Jan 22 14:13:39 aragorn NetworkManager: <info> (wlan0): device state change: 5 -> 6 (reason 0)
    Jan 22 14:13:39 aragorn NetworkManager: <info> Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
    Jan 22 14:13:39 aragorn NetworkManager: <info> (wlan0): device state change: 6 -> 4 (reason 0)
    Jan 22 14:13:39 aragorn NetworkManager: <info> Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
    Jan 22 14:13:39 aragorn NetworkManager: <info> (wlan0): device state change: 4 -> 5 (reason 0)
    Jan 22 14:13:39 aragorn NetworkManager: <info> Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0/wireless): connection 'Auto karameikos' has security, and secrets exist. No new secrets needed.
    Jan 22 14:13:39 aragorn NetworkManager: <info> Config: added 'ssid' value 'karameikos'
    Jan 22 14:13:39 aragorn NetworkManager: <info> Config: added 'scan_ssid' value '1'
    Jan 22 14:13:39 aragorn NetworkManager: <info> Config: added 'key_mgmt' value 'WPA-PSK'
    Jan 22 14:13:39 aragorn NetworkManager: <info> Config: added 'psk' value '<omitted>'
    Jan 22 14:13:39 aragorn NetworkManager: nm_setting_802_1x_get_pkcs11_engine_path: assertion `NM_IS_SETTING_802_1X (setting)' failed
    Jan 22 14:13:39 aragorn NetworkManager: nm_setting_802_1x_get_pkcs11_module_path: assertion `NM_IS_SETTING_802_1X (setting)' failed
    Jan 22 14:13:39 aragorn NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
    Jan 22 14:13:39 aragorn NetworkManager: <info> Config: set interface ap_scan to 1
    Jan 22 14:13:39 aragorn NetworkManager: <info> (wlan0): supplicant connection state: scanning -> disconnected
    Jan 22 14:13:44 aragorn NetworkManager: <info> (wlan0): supplicant connection state: disconnected -> scanning
    Jan 22 14:13:46 aragorn wpa_supplicant[1109]: CTRL-EVENT-SCAN-RESULTS
    Jan 22 14:13:46 aragorn wpa_supplicant[1109]: Trying to associate with xx:xx:xx:xx:xx:xx (SSID='karameikos' freq=2442 MHz)
    Jan 22 14:13:46 aragorn NetworkManager: <info> (wlan0): supplicant connection state: scanning -> associating
    Jan 22 14:13:47 aragorn wpa_supplicant[1109]: Association request to the driver failed
    Jan 22 14:13:47 aragorn NetworkManager: <info> (wlan0): supplicant connection state: associating -> 4-way handshake
    Jan 22 14:13:47 aragorn wpa_supplicant[1109]: Associated with xx:xx:xx:xx:xx:xx
    Jan 22 14:13:47 aragorn NetworkManager: <info> (wlan0): supplicant connection state: 4-way handshake -> associated
    Jan 22 14:13:48 aragorn NetworkManager: <info> (wlan0): supplicant connection state: associated -> 4-way handshake
    Jan 22 14:13:48 aragorn wpa_supplicant[1109]: WPA: Key negotiation completed with xx:xx:xx:xx:xx:xx [PTK=CCMP GTK=TKIP]
    Jan 22 14:13:48 aragorn wpa_supplicant[1109]: CTRL-EVENT-CONNECTED - Connection to xx:xx:xx:xx:xx:xx completed (auth) [id=0 id_str=]
    Jan 22 14:13:48 aragorn NetworkManager: <info> (wlan0): supplicant connection state: 4-way handshake -> group handshake
    ...
    Jan 22 14:13:54 aragorn NetworkManager: <info> Activation (wlan0) successful, device activated.
    Jan 22 14:13:54 aragorn NetworkManager: <info> Activation (wlan0) Stage 5 of 5 (IP Configure Commit) complete
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 saeckereier, 22.01.2010
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Du könntest auf wpa_supplicant umsteigen und den Networkmanager killen..
     
  4. Gast1

    Gast1 Guest

    Prinzipiell richtig, aber etwas mißverständlich formuliert (da NWM natürlich auch wpa_supplicant verwendet, wie so ziemlich jedes andere Frontend für diesen Zweck).

    NWM ist für diese Aufgabe nicht designed worden (auch wenn es vielleicht mit etwas dubiosem Gefummel doch gehen könnte), einfacher/logischer wäre es auf eine alternative Methode umzusteigen, z.B. die "klassische" Methode über die Netzwerk-"ifup/ifdown"-Scripte (das meinte mein Vorposter wohl auch damit) oder wenns Klickibunti sein soll, dann kann das AFAIK auch WICD.
     
  5. #4 Asturio, 22.01.2010
    Zuletzt bearbeitet: 22.01.2010
    Asturio

    Asturio Asturio Kee

    Dabei seit:
    16.02.2006
    Beiträge:
    34
    Zustimmungen:
    0
    Hi,

    Ganz die Debian-Way? Geht das einfach so? Über /etc/network/interfaces und Co?

    Noch eine Frage: Wie kriege ich die Tuxe eingeschaltet? Ich meine die Pingüine hier im Forum unterhalb des Namen des Posters.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Tja, wäre schön, wenn es mit NWM gehen würde. Aber sonst habe ich keine Angst vor der Kommandozeile und Konfigurationsdateien :-). Ich verstehe aber nicht, wieso es nicht geht, wenn es eigentlich laut Konzept gehen soll, oder?
     
  6. #5 marcellus, 22.01.2010
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Natürlich, es gibt 100 000 Tutorials dazu

    Mehr posten

    Die Netzwerkverbindungen werden von einem grafischen tool verwaltet, nix grafik nix grafisches tool. Nein networkmanager kann das nicht, das ist auch einer der Gründe, wieso sehr viele Leute die klassische Version verwenden.

    Wenn du dir das sparen willst stell auto login für gdm ein und gib "gnome-screensaver-command -l" in den autostart von gnome. Dann meldet er sich halt von selbst an, ist aber imho nicht sehr sauber.
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 saeckereier, 22.01.2010
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Naja, 1. weiss ich das, 2. brauchts der Threadersteller nicht zu wissen und 3. ist die Kernaussage Networkmanager killen und durch nur wpa_supplicant ersetzen. Also ganz Radio Eriwan. Also im Prinzip geb ich dir recht, aber eigentlich war das wenig missverständlich :-) Ich hab aber auch erst überlegt, ob ich es anders schreibe. Tatsächlich überlege ich das Ding bei mir auch abzuschaffen, ich änder eh selten das Netz und ein neues ist auch schnell eingetragen..

    Ansonsten haben die anderen schon alles gesagt. Such dir ein gutes Tutorial und dann sollte es so schwer nicht sein. Zu Beginn kannst du den NetworkManager auch einfach erstmal in der Kommandozeile abschiessen (bzw. beenden) Dafür gibt es meist ein init-Skript, ansonsten hilft aber auch ps -ef mit anschliessendem Kill. Dann kannst du beim laufenden PC versuchen erstmal die wpa_supplicant.conf zu erstellen und damit die Verbindung hinzukriegen. Wenns nicht klappt neustarten, wenn's klappt geht's damit weiter, dass beim Systemstart automatisch zu machen.
     
  9. #7 Asturio, 23.01.2010
    Zuletzt bearbeitet: 23.01.2010
    Asturio

    Asturio Asturio Kee

    Dabei seit:
    16.02.2006
    Beiträge:
    34
    Zustimmungen:
    0
    Problem gelöst. NetworkManager startet netz vor login

    Hallo,

    ich wollte noch ein letztes Ding ausprobieren, bevor ich auf ipupdown zurück gehe, und den Networkmanager kille, und siehe da, es geht.

    Das entscheidende war, denke ich, dass ich in der /etc/NetworkManager/nm-system-settings.conf den Eintrag
    Code:
    [ifupdown]
    managed=false
    
    durch
    Code:
    [ifupdown]
    managed=true
    
    ersetzt habe. Dann nur noch den NetworkManager daemon neu gestartet, und das WLAN geht hoch, ohne dass sich einer grafisch einloggen muss.

    Ich denke es ist wichtig zu erwähnen, dass /etc/network/interfaces nur 2 Zeilen enthält, und diese für "lo" sind. Also praktisch leer.

    Im NetworkManager habe ich dann in der gewünschten Verbindung das Häckchen "Automatisch verbinden" und "Für alle Benutzer verfügbar" angeklickt. Es war aber schon so, als ich die Frage gestellt habe. Also nur das "managed" Ding hat gefehlt. Für jede so konfigurierte Verbindung landet eine Konfigurationsdatei in /etc/NetworkManager/system-connections.

    Bin happy :bounce:.

    Grüße,

    Asturio

    PS - Kann ich irgendwie die Threads als "gelöst" markieren?
     
Thema:

NetworkManager soll WLAN beim Booten Starten

Die Seite wird geladen...

NetworkManager soll WLAN beim Booten Starten - Ähnliche Themen

  1. NetworkManager 1.2 veröffentlicht

    NetworkManager 1.2 veröffentlicht: Der jetzt veröffentlichte NetworkManager 1.2 verbessert den Schutz der Privatsphäre und die Zusammenarbeit mit anderen Werkzeugen. Weiterlesen...
  2. Vorschau auf NetworkManager 1.2

    Vorschau auf NetworkManager 1.2: Was die kommende Version 1.2 von NetworkManager bringen wird, zeigt die jetzt veröffentlichte erste Betaversion. Sie erhöht unter anderem den...
  3. NetworkManager erreicht Version 1.0

    NetworkManager erreicht Version 1.0: NetworkManager, ein Programm zum Verwalten der Netzwerkverbindungen eines Linux-Desktops, wurde nach über 10 Jahren Arbeit in der Version 1.0...
  4. o2 Surf Stick konfigurieren mit umtsmon und NetworkManager

    o2 Surf Stick konfigurieren mit umtsmon und NetworkManager: Hallo, ich hatte mir neulich den o2-Surf Stick für mein Notebook mit openSUSE 11.4 zugelegt. Prinzipiell konnte ich keine Verbindung über das...
  5. networkmanager-frontend für windowmaker

    networkmanager-frontend für windowmaker: Hallo allezusammen, ich habe einen älteren Laptop (ca. 5 Jahre) mit frisch installiertem opensuse 11.0 und funktionierenden Treibern; soweit...