netbeans-5.5

Dieses Thema im Forum "Gentoo" wurde erstellt von Alexander, 15.02.2007.

  1. #1 Alexander, 15.02.2007
    Alexander

    Alexander InfoAssi

    Dabei seit:
    28.03.2004
    Beiträge:
    192
    Zustimmungen:
    0
    Schönen guten morgen ; =)

    Ich habe da ein kleines Problem.

    Ich möchte gerne Netbeans installieren. Leider wurde mir mit emerge nur die Version 3.x ich hätte aber lieber gerne die 5.x.
    Daraufhin bin ich in das Verzeichniss /usr/portage/dev-util/netbeans gegangen und fand dort ein ebuild von netbeans 5.x.
    Dieses wollte ich mit "ebuild netbeans5.x merge" installieren. naja dummerweise kamen dort andauernd irgendwelche melden das etwas fehle. so habe ich versucht diese von "hand" zu installieren. Problem ist das beispielsweise ein Packet bsf gefordert ist welches ein Java 1.3 oder 1.4 forder. Ich habe 1.5 installiert. Für bsf gibt es ebenfalls ein ebuild welches man so hinzufügen könnte. Das zieht sich offenbar durch die gesamte installation hindurch.

    Habt ihr eine gute Idee wie ich an netbeans 5.x herankomme ohne solche Klimmzüge zu machen?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 15.02.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Was siehst du denn wenn du

    Code:
    emerge --search netbeans
    eingibst?

    Du siehst dann schon auch die 5-er, aber die ist maskiert bei dir oder?
     
  4. #3 Alexander, 15.02.2007
    Alexander

    Alexander InfoAssi

    Dabei seit:
    28.03.2004
    Beiträge:
    192
    Zustimmungen:
    0

    Das ist genau das Problem.. ich sehe nur die Version 3.5.1. Auch nichts maskiertes.
     
  5. #4 kissen, 15.02.2007
    Zuletzt von einem Moderator bearbeitet: 15.02.2007
    kissen

    kissen Guest

    Hi Alexander,

    auf http://gentoo-portage.com hat es eine neuere Version.

    Einfach von hier die gewuenschte Version herunterladen, das ebuild in
    Code:
    /usr/portage/dev-util/netbeans/
    kopieren (oder eben dein portage Verzeichnis) und mit
    Code:
    ebuild /usr/portage/dev-util/netbeants/netbeans-version.ebuild install 
    installieren. Dann laeuft meines Wissens nach die Installation wie bei emerge ab.

    Gruss,

    kissen
     
  6. nikaya

    nikaya Guest

    netbeans-5.5-r4 ist im Testing-Tree und nicht Stable,siehe hier:
    http://packages.gentoo.org/search/?sstring=netbeans.Testing-Pakete sind unter Stable nicht verfügbar,auch wenn die Ebuilds vorhanden sind.
    Mach mal ein
    Code:
    echo "dev-util/netbeans" >> /etc/portage/package.keywords
    oder entsprechend die Datei "/etc/portage/package.keywords" mit einem Editor öffnen und dort "dev-util/netbeans" (ohne Anführungszeichen) eintragen.Dann müßte netbeans in der aktuellen (Testing)-Version installierbar sein.
    ACHTUNG:Es kann sein dass dieses Paket Abhängigkeiten hat die ebenfalls im Testing-Tree sind,Portage meckert dann rum.Diese dann einfach nach oben genannter Methode auch in die package.keywords eintragen.
     
  7. #6 Alexander, 16.02.2007
    Alexander

    Alexander InfoAssi

    Dabei seit:
    28.03.2004
    Beiträge:
    192
    Zustimmungen:
    0
    Die Idee ist nicht schlecht.. nun ist das nächste Problem da ; (


    Das packet /dev/java/ant-core wird durch /dev/java/ant-tasks blockiert.
    Interessanterweise ist keines von beidem installiertO_o
     
  8. #7 Hello World, 16.02.2007
    Hello World

    Hello World Routinier

    Dabei seit:
    22.11.2006
    Beiträge:
    324
    Zustimmungen:
    0
    Ähm, wieso verwendest Du nicht einfach den Installer? Dann installierst Du das ganze halt nach /opt/netbeans und wenn Du mal keine Lust mehr drauf hast, löschst Du den Ordner und fertig. Übrig bleiben dann höchstens ein paar Symlinks. Das ist ja nicht Windows mit seiner unüberschaubaren Softwareverwaltung...
     
  9. #8 Alexander, 16.02.2007
    Alexander

    Alexander InfoAssi

    Dabei seit:
    28.03.2004
    Beiträge:
    192
    Zustimmungen:
    0
    Die Idee hatte ich auch schon, aber der funkioniert nicht : (

    Meinst den hier oder? :

    http://www.netbeans.info/downloads/index.php
     
  10. #9 Mµ*e^13.5_?¿, 16.02.2007
    Mµ*e^13.5_?¿

    Mµ*e^13.5_?¿ Routinier

    Dabei seit:
    21.02.2006
    Beiträge:
    453
    Zustimmungen:
    0
    _Was_ funktioniert denn da nicht?
     
  11. #10 Alexander, 16.02.2007
    Alexander

    Alexander InfoAssi

    Dabei seit:
    28.03.2004
    Beiträge:
    192
    Zustimmungen:
    0
    Code:
    #[H#[2J
    
    
    
    
    
    
              Initializing InstallShield Wizard........
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 404: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 404: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 404: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 404: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 404: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 404: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 404: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 382: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 382: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 382: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 382: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 382: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 382: [: : integer expression expected
    ./netbeans-5_5-linux.bin: line 189: bc: command not found
    ./netbeans-5_5-linux.bin: line 382: [: : integer expression expected
    
    #[H#[2J
    
     
  12. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  13. #11 Mµ*e^13.5_?¿, 16.02.2007
    Mµ*e^13.5_?¿

    Mµ*e^13.5_?¿ Routinier

    Dabei seit:
    21.02.2006
    Beiträge:
    453
    Zustimmungen:
    0
    Also solltest du mal bc installieren.
     
  14. #12 Alexander, 16.02.2007
    Alexander

    Alexander InfoAssi

    Dabei seit:
    28.03.2004
    Beiträge:
    192
    Zustimmungen:
    0
    War viel zu einfach das das gut gehen kann *grins*


    ok danke^^
     
Thema:

netbeans-5.5