ndiswrapper unter Suse 10.0 funkt. nicht

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von franzi12, 09.08.2006.

  1. #1 franzi12, 09.08.2006
    franzi12

    franzi12 ndiswrapper_fan:-(

    Dabei seit:
    01.03.2006
    Beiträge:
    12
    Zustimmungen:
    0
    Hallo,
    Versuche derzeit mit ndiswrapper mein Siemens Gigabit USB Stick 108 (WLAN) zum laufen zu bringen.
    Ndiswrapper installation klappte, aber es gab beim prüfen der installation mit dmesg folgendes Ergebnis, was m.E. nicht so sein sollte im Blick auf ndiswrapper (den Rest habe ich rausgeschnitten - falls nötig poste ich ihn noch):
    ---------------------------
    ndiswrapper: module not supported by Novell, setting U taint flag.
    ndiswrapper version 1.2 loaded (preempt=no,smp=no)
    ndiswrapper (import:245): unknown symbol: ntoskrnl.exe:ZwOpenKey
    ndiswrapper (import:245): unknown symbol: ntoskrnl.exe:ZwQueryValueKey
    ndiswrapper (import:245): unknown symbol: ntoskrnl.exe:ZwCreateFile
    ndiswrapper (import:245): unknown symbol: ntoskrnl.exe:ZwQueryInformationFile
    ndiswrapper (import:245): unknown symbol: ntoskrnl.exe:ZwReadFile
    ndiswrapper (load_sys_files:520): unable to prepare driver 'net5523'
    Unable to handle kernel NULL pointer dereference at virtual address 00000040
    printing eip:
    f8cc7650
    *pde = 00000000
    Oops: 0000 [#1]
    Modules linked in: ndiswrapper nls_iso8859_1 nls_cp437 joydev sg st sd_mod sr_mod hfsplus vfat fat subfs speedstep_lib freq_table ipv6 usbhid usblp snd_pcm_oss snd_mixer_oss snd_seq_midi snd_emu10k1_synth snd_emux_synth snd_seq_virmidi snd_seq_midi_event snd_seq_midi_emul snd_seq ohci1394 ieee1394 snd_emu10k1 snd_rawmidi snd_seq_device snd_ac97_codec snd_pcm snd_timer snd_ac97_bus snd_page_alloc snd_util_mem snd_hwdep snd soundcore generic edd button battery ac sata_nv libata scsi_mod shpchp pci_hotplug i2c_nforce2 i2c_core ehci_hcd ohci_hcd usbcore nvidia_agp agpgart parport_pc lp parport nls_utf8 ntfs dm_mod reiserfs ide_floppy ide_cd cdrom fan thermal processor amd74xx ide_disk ide_core
    CPU: 0
    EIP: 0060:[<f8cc7650>] Tainted: G U VLI
    EFLAGS: 00010246 (2.6.13-15-default)
    EIP is at unload_ndis_driver+0x50/0xb0 [ndiswrapper]
    eax: 00000034 ebx: f6f915c0 ecx: 00000001 edx: 00000000
    esi: e7e40c0c edi: 00000000 ebp: f6f915c0 esp: e25f3f34
    ds: 007b es: 007b ss: 0068
    Process loadndisdriver (pid: 6455, threadinfo=e25f2000 task=f15df590)
    Stack: f6f915c0 f9201000 e7e40f08 e25f2000 f8cc7a61 00040004 f8cd8393 e7e40c0c
    00000000 f9201000 b7d8e008 f8cc81b4 f8cc8110 f8cc8110 f8cc8110 efa08ce0
    c016995e b7d8e008 efa08ce0 00000000 c0169a6f fffffff7 fffffff7 fffffff7
    Call Trace:
    [<f8cc7a61>] load_ndis_driver+0xf1/0x1f0 [ndiswrapper]
    [<f8cc81b4>] wrapper_ioctl+0xa4/0xb0 [ndiswrapper]
    [<f8cc8110>] wrapper_ioctl+0x0/0xb0 [ndiswrapper]
    [<f8cc8110>] wrapper_ioctl+0x0/0xb0 [ndiswrapper]
    [<f8cc8110>] wrapper_ioctl+0x0/0xb0 [ndiswrapper]
    [<c016995e>] do_ioctl+0x4e/0x60
    [<c0169a6f>] vfs_ioctl+0x4f/0x1c0
    [<c0169c17>] sys_ioctl+0x37/0x70
    [<c0102d1b>] sysenter_past_esp+0x54/0x79
    Code: c7 8b 96 90 01 00 00 47 83 c3 38 39 fa 77 e3 8b be 74 02 00 00 85 ff 7f 3f 8b 86 78 02 00 00 85 c0 74 05 e8 f3 d0 47 c7 8b 45 04 <8b> 58 0c 53 e8 67 5f 00 00 8d 45 1c 50 e8 be c8 00 00 8b 45 18
    <3>ndiswrapper (ndiswrapper_load_driver:93): loadndiswrapper failed (11); check system log for messages from 'loadndisdriver'
    usbcore: registered new driver ndiswrapper
    ------------------------------------------------------
    Nun meine Frage: Wie bekomme ich den ndiswrapper korrekt zum laufen?
    iwconfig bringt naemlich danach ausgeführt keine Ergebnisse.
    Danke für einen Hinweis
    Andreas
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. blacky

    blacky Doppel-As

    Dabei seit:
    25.07.2006
    Beiträge:
    132
    Zustimmungen:
    0
    Wie?

    Hallo,
    mal ne Frage wie hast du das gemacht? Man muss normalerweise einfach nur als root ndiswrapper -i [pfad zur inf Datei] eingeben! Danach ein autostart definieren z.b in der boot.local einfach [modprobe ndiswrapper] reinschreiben. Das sollte es normalerweise sein.
    Gruß Florian
     
Thema:

ndiswrapper unter Suse 10.0 funkt. nicht

Die Seite wird geladen...

ndiswrapper unter Suse 10.0 funkt. nicht - Ähnliche Themen

  1. Wlan mit Ndiswrapper unter Suse10.3 wird nicht gestartet

    Wlan mit Ndiswrapper unter Suse10.3 wird nicht gestartet: Hallo alle Zusammen, Ich habe an meinem Laptop meine WLAN-USB-Stick zum laufen gebracht. Jetzt kommt nun mein Problem. Wenn ich Suse starte...
  2. Wlan mit Ndiswrapper unter opensuse10.2

    Wlan mit Ndiswrapper unter opensuse10.2: Hallo allerseits, ich habe ein kleines Problem mit wlan unter suse, ich erzähl euch mal die Vorgeschichte: Ndiswrapper wurde installiert (ok)...
  3. Ndiswrapper unter suse Linux 9.1 einrichten

    Ndiswrapper unter suse Linux 9.1 einrichten: Hi! Kann mir jemand sagen wo ich ein ausführliches tutorial finde, wie ich die neueste Version von diesem Tool unter sus 9.1 einrichte? Ich...
  4. wlan mit ndiswrapper und wpa unter debian

    wlan mit ndiswrapper und wpa unter debian: hallo zusammen!!! ich habe ein anliegen und zwar versuche ich seit einiger Zeit ein wlan unter debian einzurichten. Ich habe den Fritz avm usb...
  5. WLan mit Ndiswrapper unter Suse 10.1

    WLan mit Ndiswrapper unter Suse 10.1: Alt