Ndiswrapper und Sinus 154 WLAN USB Stick

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von Qwert-Zuiopü, 28.04.2007.

  1. #1 Qwert-Zuiopü, 28.04.2007
    Qwert-Zuiopü

    Qwert-Zuiopü Mitglied

    Dabei seit:
    27.04.2007
    Beiträge:
    25
    Zustimmungen:
    0
    Hallo,

    ich hab da ein kleines Problemchen mit meinem Suse 10.0 und nem Sinus 154 WLAN USB Stick.

    Ich habe die Treiber mit Ndiswrapper installiert und der Befehl ndiswrapper -l bringt folgende Ausgabe:

    Code:
    linux:/home # ndiswrapper -l
    prisma02 : driver installed
            device (0915:2000) present
    laden kann ich das ndiswrapper Modul auch

    dmesg zeigt folgendes:

    Code:
    ndiswrapper version 1.42 loaded (smp=no)
    usb 1-1.1: reset full speed USB device using uhci_hcd and address 3
    ndiswrapper: driver prisma02 (T-Com,05/20/2004, 3.00.18.0002) loaded
    wlan0: ethernet device 00:03:c9:a9:4c:e7 using NDIS driver: prisma02, version: 0x30012, NDIS version: 0x501, vendor: 'Sinus 154 stick', 0915:2000.F.conf
    wlan0: encryption modes supported: WEP; TKIP with WPA; AES/CCMP with WPA
    usbcore: registered new driver ndiswrapper
    Nur wenn ich dann den Wlan Stick mit Yast konfiguriert habe, wird er bei dem Befehl ifconfig nicht, bzw erst dann angezeigt wenn ich ifconfig wlan0 up ausführe.

    und unter iwconfig wird folgendes Angezeigt:

    Code:
    linux:/home # iwconfig
    eth0      no wireless extensions.
    
    lo        no wireless extensions.
    
    sit0      no wireless extensions.
    
    [COLOR="Red"]wlan0     no wireless extensions[/COLOR].
    Wenn ich das Netzwerk neu starte erhalte ich eine Fehlermeldung:

    Code:
    linux:/home # rcnetwork restart
    Shutting down network interfaces:
        eth0      device: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 0c)
        eth0      configuration: eth-id-00:03:47:8b:cd:af                 done
        wlan0                                                             done
    Shutting down service network  .  .  .  .  .  .  .  .  .  .  .  .  .  done
    Hint: you may set mandatory devices in /etc/sysconfig/network/config
    Setting up network interfaces:
        lo
        lo        IP address: 127.0.0.1/8                                 done
        eth0      device: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 0c)
        eth0      configuration: eth-id-00:03:47:8b:cd:af
        eth0      IP address: 192.168.2.10/24                             done
        wlan0
        wlan0     warning: using NO encryption
    [COLOR="Red"]ifup-wireless: command 'iwconfig wlan0 mode Managed' returned
    ifup-wireless:  Error for wireless request "Set Mode" (8B06) :
    ifup-wireless:     SET failed on device wlan0 ; Invalid argument.
    ifup-wireless: command 'iwconfig wlan0 nick linux' returned
    ifup-wireless:  Error for wireless request "Set Nickname" (8B1C) :
    ifup-wireless:     SET failed on device wlan0 ; Invalid argument.
    ifup-wireless: command 'iwconfig wlan0 key off' returned
    ifup-wireless:  Error for wireless request "Set Encode" (8B2A) :
    ifup-wireless:     SET failed on device wlan0 ; Invalid argument.
    ifup-wireless: command 'iwconfig wlan0 essid WLAN' returned
    ifup-wireless:  Error for wireless request "Set ESSID" (8B1A) :
    ifup-wireless:     SET failed on device wlan0 ; Invalid argument.     done[/COLOR]
        modem0
        modem0    Startmode is 'manual'                                   skipped
    Setting up service network  .  .  .  .  .  .  .  .  .  .  .  .  .  .  done
    SuSEfirewall2: Warning: ip6tables does not support state matching. Extended IPv6 support disabled.
    SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
    SuSEfirewall2: Warning: FW_ALLOW_INCOMING_HIGHPORTS_UDP is deprecated and will likely be removed in the future.
    SuSEfirewall2: Warning: If you think it should be kept please report your use case at
    SuSEfirewall2: Warning: http://forge.novell.com/modules/xfmod/project/?susefirewall2
    SuSEfirewall2: batch committing...
    SuSEfirewall2: Firewall rules successfully set
    Ich weiß einfach nicht wie ich den Stick zum laufen bekommen kann.

    Für jede Hilfe wäre ich sehr dankbar.

    Gruß

    Qwert-Zuiopü
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 ew_wolf, 29.04.2007
    ew_wolf

    ew_wolf Tripel-As

    Dabei seit:
    02.06.2006
    Beiträge:
    157
    Zustimmungen:
    0
    Hast du die SSID des WLANs angegben, mit dem du dich verbinden möchtest?
    Hast du eine Verschlüsselung am Accesspoint aktiviert?
    Hast du den Schlüssel und vor allem die Art der Verschlüsselung unter linux angeben?
    Ist das Moudl "ndiswrapper" überhaupt geladen?
     
  4. #3 Qwert-Zuiopü, 29.04.2007
    Qwert-Zuiopü

    Qwert-Zuiopü Mitglied

    Dabei seit:
    27.04.2007
    Beiträge:
    25
    Zustimmungen:
    0
    Hallo ew_wolf!

    Ja, habe unter Yast die SSID des Wlans angegeben.

    Ich habe es mit und ohne Verschlüsslung am Accesspoint ausprobiert und habe dann auch die Verschlüsselung in Linux aktiviert.

    Vergabe der IP für den Wlan Stick läuft mit DHCP - habe aber auch schon ohne probiert.

    Modul ndiswrapper ist geladen siehe hier:

    Code:
    linux:/home/rhodan # lsmod | grep ndiswrapper
    ndiswrapper           192276  0
    usbcore               119808  4 usbhid,uhci_hcd,ndiswrapper
    
    Gruß

    Qwert-Zuiopü
     
  5. #4 ew_wolf, 29.04.2007
    ew_wolf

    ew_wolf Tripel-As

    Dabei seit:
    02.06.2006
    Beiträge:
    157
    Zustimmungen:
    0
    Nun, dann fählt mir im Moment nichts anderes ein.
    Vielleich solltest du das Modul deinstallieren und neu Installieren.
    Vergesse nicht mit dem Befehl "ndiswrapper -i <Pfad zum passenden Windowstreiber>" dem Modul mitzuteile, welchen Treiber es benutzen sollte.

    Sorry, das ich dir da nicht weiterhelfen kann. Bei mir funktioniert die WLAN-Verbindung mit ndwiswrapper am FRITZ-USB-WLAN-Adapter und beim USB-WLAN-Adapter von Belkin.
    Wirst das bestimmt schon im Forum geselesen haben.
     
  6. #5 Qwert-Zuiopü, 30.04.2007
    Qwert-Zuiopü

    Qwert-Zuiopü Mitglied

    Dabei seit:
    27.04.2007
    Beiträge:
    25
    Zustimmungen:
    0
    Hallo wolf!

    habe es hinbekommen. Habe mit dem Befehlt ifup gespielt und mittels "ifup wlan0 config" konnte ich den Stick aktivieren. Bin jetzt grade mit WLAN online - nur die Verschlüsselung klappt noch nicht so ganz......hätte ich es nicht hinbekommen, hätte ich mir auch nen anderen Stick zugelegt.

    Komischerweise wird mein Stick aber nicht im kwifimanager angezeigt......seltsam.

    Nadann. Danke für die Vorschläge.

    Qwert-Zuiopü
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 ganymed, 30.04.2007
    ganymed

    ganymed bluefish

    Dabei seit:
    14.05.2006
    Beiträge:
    52
    Zustimmungen:
    0
    http://www.unixboard.de/vb3/showthread.php?t=21969
    da hatte ich mit dem stick auch schon probleme.
    mittlerweile führe ich bei jedem start dieses script aus:
    Code:
    #!/bin/sh
    iwconfig wlan0 essid ******
    iwconfig wlan0 ap *******************
    iwconfig wlan0 key restricted *************
    ifconfig  wlan0 192.168.2.100
    route add default gateway 192.168.2.1
    echo nameserver 192.168.2.1 >> /etc/resolv.conf
    ich weiß mir immer selbst ne ip zu, anstatt auf dhcp zu vertrauen.
    was ich sagen will ist nur, dass du die verschlüsselung am besten über die konsole einstellst.
     
  9. #7 Knatterton, 01.05.2007
    Knatterton

    Knatterton Grünschnabel

    Dabei seit:
    01.05.2007
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo, ich nutze seit kurzen Kubuntu, kenne mich mit Linux noch gar nicht aus.
    Habe das Problem, dass mein knetworkmanager zwar mein wlannetz findet, ich aber nur einen WEP-Schlüssel eingeben kann, obwohl dieses Netzwerk WPA-geschützt ist. Dann hab ich geforscht und bin auf das Wiki mit Ndiswrapper gestoßen.

    Habe alles soweit gemacht, die Dinge geblacklistet, den Treiber mit ndiswrapper installiert, den ndiswrapper automatisch starten lassen (echo ndiswrapper | sudo tee -a /etc/modules) (Hoffe, das war richtig so) und dann in der interfacesdatei alle zeilen bis auf die ersten zwei mit nem # vorne dran versehen. Dann bin ich wieder in den knetworkmanager und alles ist beim alten (erzeigt mir auch den globespanvir... treiber an). Was mach ich falsch?

    Hier noch einige Angaben: Habe versucht, nach Anleitung den wpa_supplicant zu konfigurieren: Das sind meine gesamten Veränderungen und Angaben:

    iwconfig ergibt folgendes:



    lo no wireless extensions

    eth0 no wireless extensions

    wmaster0 IEEE 802.11g Frequency:2.412 GHz
    RTS thr:off Fragment thr=2346 B

    wlan0 IEEE 802.11g ESSID:"Toxic_Avenger"
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    RTS thr:off Fragment thr=2346 B
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0



    und nun die Dateien in denen ich was geändert habe (ndiswrapper und wpa_supplicant):

    so sieht die Datei blacklist-sinus aus:



    blacklist prism2_usb
    blacklist islsm
    blacklist islsm_pci
    blacklist islsm_usb



    das ist die wpa_supplicant.conf:



    ctrl_interface=/var/run/wpa_supplicant
    eapol_version=1
    ap_scan=2
    network={
    ssid="Toxic_Avenger"
    scan_ssid=1
    proto=WPA
    key_mgmt=WPA-PSK
    pairwise=TKIP
    group=TKIP
    psk="EB5A7166........84AA38E2EC"
    }



    das die Datei interfaces:



    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet dhcp

    auto eth1
    iface eth1 inet dhcp

    auto eth2
    iface eth2 inet dhcp

    auto ath0
    iface ath0 inet dhcp

    auto wlan0
    iface wlan0 inet dhcp
    wpa-driver wext
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf



    und so sieht die modules aus:



    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.

    fuse
    lp
    ndiswrapper



    wie muss ich jetzt weiter verfahren, um mit meinem WLAN-Stick ins Netz gehen zu können?
    Danke
     
Thema:

Ndiswrapper und Sinus 154 WLAN USB Stick

Die Seite wird geladen...

Ndiswrapper und Sinus 154 WLAN USB Stick - Ähnliche Themen

  1. ndiswrapper + T-Sinus 154 Data (Accton Technoligy Corp)

    ndiswrapper + T-Sinus 154 Data (Accton Technoligy Corp): Guten Abend, entschuldigt das ich 2mal hintereinander einen Thread zum selben Thema aufmache...aber: Ich habe den ndiswrapper(KubuntuDVD -->...
  2. Sinus154stick und ndiswrapper

    Sinus154stick und ndiswrapper: sers, bin neu hier wollt jetz mal fragen, wie´s weiter geht oder was ich machen kann. Also: ich will die treiber per ndiswrapper installieren...
  3. WLAN SInus 154 usb mit Linux 10.1, was ist ndiswrapper

    WLAN SInus 154 usb mit Linux 10.1, was ist ndiswrapper: Hi zusammen. Ich bin Linux-Neuling und möchte gerne mit WLAN ins Internet. Habe bereits rausgefunden, dass ich über irgend so einen...
  4. Ubuntu 9.10 ndiswrapper compile problem

    Ubuntu 9.10 ndiswrapper compile problem: Nunja, nachdem ndiswrapper (von apt-get installiert) probleme macht, weil das module nicht gefunden wird, dachte ich mir, kompilierst du es eben...
  5. LinuxMint wg111v3 ndiswrapper Probleme

    LinuxMint wg111v3 ndiswrapper Probleme: Hallo, wollte mal nach einiger Zeit wieder versuchen Wlan unter Linux aktiviert zu kriegen. Als Distribution habe ich diesmal LinuxMint gewählt...