Ndiswrapper invalid driver

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von hood, 08.06.2007.

  1. hood

    hood Robin von Locksley

    Dabei seit:
    19.02.2007
    Beiträge:
    67
    Zustimmungen:
    0
    Hallo,

    hab seit vorgestern debian auf meinem rechner laufen und bin bisher recht zufrieden, nur ndiswrapper bekomme ich nicht zum laufen.
    habe einen devolo usb stick, der auf diesem rechner ohne probleme unter mepis 6.5 lief. jetzt habe ich debian 4.0 xfce, aber nachdem ich die .inf datei installiert habe, kommt immer folgende meldung:

    Code:
    # ndiswrapper -l 
    installed drivers: 
    dvl2084 invalid driver! 
    beim installieren ist mir folgende meldung aufgefallen:

    Code:
    WARNING: This kernel seems to use 4K stack size option (CONFIG_4KSTACKS); many Windows drivers will not work with this option enabled. Disable CONFIG_4KSTAC KS option, recompile and install kernel
    aber in /usr/src/linux/.config ist keine "CONFIG_4KSTACKS" eingetragen.

    der befehl
    Code:
    # cat /usr/src/linux/.config | grep "CONFIG_4KSTACKS"
    zeigt zumindest, dass es keinen eintrag gibt.
    hängt das problem jetzt mit dem kernel zusammen oder etwa doch nicht?

    ndiswrapper ist anscheinend ein echt leidiges thema. bin jetzt seit gestern mit ndiswrapper beschäftigt und habs versucht alleine zu lösen, aber schaffe es leider nicht. ich hoffe ihr könnt mir hierbei helfen.

    gruß
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 mali, 08.06.2007
    Zuletzt bearbeitet: 08.06.2007
    mali

    mali noob @ linux

    Dabei seit:
    22.12.2006
    Beiträge:
    306
    Zustimmungen:
    0
    Ort:
    Leverkusen
    Code:
    dvl2084 invalid driver!
    Bist du dir sicher, dass du die richtige INF-File installiert hast???

    Bei mir siehts so aus:
    Code:
    malinux linux # cat .config | grep CONFIG_4KSTAC
    # CONFIG_4KSTACKS is not set
     
  4. hood

    hood Robin von Locksley

    Dabei seit:
    19.02.2007
    Beiträge:
    67
    Zustimmungen:
    0
    davon gehe ich aus. diese .inf datei läuft auf meinem anderen rechner mit mepis 6.5 ohne probleme, und auch der stick. auch auf diesem (an dem ich jetzt sitze) rechner ging es unter mepis ohne probleme.
     
  5. blck

    blck Routinier

    Dabei seit:
    15.01.2007
    Beiträge:
    268
    Zustimmungen:
    0
    Soweit ich das verstehe, geht es um eine ndiswrapper Version!
    Vllt. solltes du mal eine andere Ndiswrapper Version versuchen oder dir mal ne andere .inf Datei raussuchen.

    Gruß Blck
     
  6. hood

    hood Robin von Locksley

    Dabei seit:
    19.02.2007
    Beiträge:
    67
    Zustimmungen:
    0
    Ist vielleicht eine idee mit der anderen ndiswrapper version. werd ich jetzt mal versuchen. die jetzige war die 1.46

    wo ich eine andere und passende .inf datei herbekommen könnte, wüßte ich jetzt nicht. hast du da eine idee?
     
  7. blck

    blck Routinier

    Dabei seit:
    15.01.2007
    Beiträge:
    268
    Zustimmungen:
    0
    Ich denke mal, das du dir mal den Original WinXP Treiber von der Herstellerseite deines WLAN-Gerätes laden solltest, oder den Treiber den du, falls du WinXP benutzt, in Windows findest.

    P.S. Kann sein das ich es überlesen hab, aber welches Gerät verwendest du?

    Gruß Blck
     
  8. hood

    hood Robin von Locksley

    Dabei seit:
    19.02.2007
    Beiträge:
    67
    Zustimmungen:
    0
    ich benutze den original treiber. der läuft ja auch, außer eben unter debian 4.0.
    habe einen devolo usb stick.
     
  9. mali

    mali noob @ linux

    Dabei seit:
    22.12.2006
    Beiträge:
    306
    Zustimmungen:
    0
    Ort:
    Leverkusen
    Zieh dir mal den aktuellsten Treiber von der Hersteller HP und dann mit
    Code:
    cabextract bla-treiber.exe
    die einzelnen Files extrahieren und die inf. installieren
     
  10. #9 LinuxRulerSuSE, 08.06.2007
    LinuxRulerSuSE

    LinuxRulerSuSE Doppel-As

    Dabei seit:
    08.12.2006
    Beiträge:
    110
    Zustimmungen:
    0
    Ort:
    Meerbusch
    Vieleicht falsche ndiswrapper kernel driver installiert ???
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. hood

    hood Robin von Locksley

    Dabei seit:
    19.02.2007
    Beiträge:
    67
    Zustimmungen:
    0
    hallo,

    also, hat sich geklärt! hab die 1.44er version (anstatt 1.46) genommen und es klappt prima. danke für den tip.
    hätte nicht gedacht dass es da so große differenzen zwischen den versionen gibt.


    vielen dank an alle und gruß

    hood
     
  13. blck

    blck Routinier

    Dabei seit:
    15.01.2007
    Beiträge:
    268
    Zustimmungen:
    0
    Freut mich.:D
     
Thema:

Ndiswrapper invalid driver

Die Seite wird geladen...

Ndiswrapper invalid driver - Ähnliche Themen

  1. Ubuntu 9.10 ndiswrapper compile problem

    Ubuntu 9.10 ndiswrapper compile problem: Nunja, nachdem ndiswrapper (von apt-get installiert) probleme macht, weil das module nicht gefunden wird, dachte ich mir, kompilierst du es eben...
  2. LinuxMint wg111v3 ndiswrapper Probleme

    LinuxMint wg111v3 ndiswrapper Probleme: Hallo, wollte mal nach einiger Zeit wieder versuchen Wlan unter Linux aktiviert zu kriegen. Als Distribution habe ich diesmal LinuxMint gewählt...
  3. Installation von ndiswrapper schlägt fehl. [+allgemeine Frage]

    Installation von ndiswrapper schlägt fehl. [+allgemeine Frage]: Problem bereits behoben! So liebe User, der andere Thread ging irgendwie unter, und so richtig helfen konnte man mir auch nicht.... Ich habe ein...
  4. openSUSE und ndiswrapper. Der 1. Bug?

    openSUSE und ndiswrapper. Der 1. Bug?: Nun habe ich voller vorfreude bei mir 11.1 drauf gemacht, aber was muss ich sehen, der ndiswrapper schein nicht mehr zu funktionieren. Habe...
  5. WLAN mit Ubuntu 8.10 und Ndiswrapper

    WLAN mit Ubuntu 8.10 und Ndiswrapper: [gelöst]WLAN mit Ubuntu 8.10 und Ndiswrapper Hallo und guten Abend (Nacht :-P) zusammen, ich habe ein Problem beim Herstellen einer Verbindung...