Nach Update xserver kaputt

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von AlexN, 02.11.2006.

  1. AlexN

    AlexN Jungspund

    Dabei seit:
    11.09.2006
    Beiträge:
    22
    Zustimmungen:
    0
    Hallo,

    Ich habe heute irgendwie meinen xserver abgeschossen und weiss nichtmal wie.

    Ich nutze Debian Sarge.
    Die letzten Tage hatte ich Probleme mit Kopete und habe das Paket daraufhin per apt-get deinstalliert und dann nochmal installiert. (apt-get install ergab immer, das neueste Paket sei installiert, war es aber nicht, daher die Einzelschritte)
    Danach hab ich ein dist-upgrade gemacht und mich schon gewundert, wieso er 600 packages zieht.

    Nach dem nächsten Neustart, kam ich schon gar nicht mehr zum login.
    Mir wurde ein Error-Log angezeigt, wo folgendes drin stand.

    could not open default font 'fixed'

    Ungläubig hab ich dann nochmal versucht gdm zu starten und bekam eine Meldung, dass gdm bereits läuft. Bei alt-f7 fand ich tatsächlich etwas Oberfläche, aber dort war nur eine Nachricht, dass xserver disabled ist und ich solle gdm neu starten, wenn die Konfiguration stimmt. Dort tat sich auch ncihts, wenn ich Enter gedrückt habe.
    Danach hab ich den gdm per kill gestoppt. Hab das Paket xfonts-base per reinstall geholt und gdm versucht zu starten.
    Dort kam dann "fatal IO error 104" und weiter nichts.

    Ich habe bereits etwas gegoogled und fand dort unter anderem den Tip mit xfonts-base und reinstall. Half nicht.
    Weiterhin hiess es, man solle schauen, ob der xfs läuft.
    Mit ps -A|grep xfs kommt gar nichts.
    Falls nichts da steht, solle man xfs -daemon aufrufen. In dem Fall erscheint: xfs: command not found.

    Ich habe danach xfs per apt-get geholt, die Installation lief fehlerfrei. Reboot und keine Verbesserung der Situation. xfs erscheint aber immerhin schonmal in der Prozessliste.

    Hilfe ?(
    Ich bin kein Fachmann und mehr als googlen und brav jeden Mist probieren, kann ich leider nicht.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 02.11.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Was für eine Fehlermeldung kommt denn wenn du

    Code:
    startx
    aufrufst?
     
  4. AlexN

    AlexN Jungspund

    Dabei seit:
    11.09.2006
    Beiträge:
    22
    Zustimmungen:
    0
    Neben ein paar Zeilen, die nicht als Fehler gekennzeichnet sind (und die es auch leider teilweise oben rausscrollt), erscheint:
    --
    The XKEYBOARD keymap compiler (xkbcomp) reports:
    Error: No Symbols named "de" in the include file "de"

    Exiting
    Abandoning symbols file default "default"

    Errors from xkbcomp are not fatal to the Xserver.


    Fatal Server Error:
    Could not open default font 'fixed'
    --
     
  5. #4 Goodspeed, 02.11.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Vielleicht solltest Du erstmal herausfinden, was es mit den 600 Paketen auf sich hat ... ich glaub, soviele Security-Updates gabe es nicht in letzter Zeit ...

    Hast Du möglicherweise in der sources.list was geändert?
     
  6. AlexN

    AlexN Jungspund

    Dabei seit:
    11.09.2006
    Beiträge:
    22
    Zustimmungen:
    0
    Ich habe bewusst nichts geändert. Ich wüsste nichtmal wie.

    Das einzige, was mich gewundert hat, war dass beim "apt-get remove kopete" bei den zu entfernenden Paketen "kde kdenetwork kopete" stand. Ich hab mir dabei aber nichts gedacht, weil ich kopete danach sowieso wieder installieren wollte. Was bei der Installation widerum dann an Paketen alles dabei war, weiss ich aber nicht mehr genau.
    Bei dem dist-upgrade danach kam dann dieser Haufen Packages rein.

    Normal mach ich das dist-upgrade so alle 2-3 Wochen. Keine Ahnung, was das heute soll.
     
  7. #6 Nemesis, 02.11.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    schonmal "apt-get install x-window-system-core" probiert?
     
  8. AlexN

    AlexN Jungspund

    Dabei seit:
    11.09.2006
    Beiträge:
    22
    Zustimmungen:
    0
    Soeben gemacht:

    apt-get install --reinstall x-window-system-core xorg xfs gdm xfonts-base

    Ergebnis: nix
     
  9. #8 Goodspeed, 02.11.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Wie sieht denn Deine /etc/apt/sources.list aus?
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. AlexN

    AlexN Jungspund

    Dabei seit:
    11.09.2006
    Beiträge:
    22
    Zustimmungen:
    0
    Die gibts schon nicht mehr. Bin an der Neuinstallation.
    Sowas wollte ich sowieso mal gemacht haben. Nur schade, dass es meinen Arbeitsrechner getroffen hat und keine Testkiste.

    Trotzdem danke an alle.
     
  12. #10 kbdcalls, 02.11.2006
    kbdcalls

    kbdcalls Master of Universe

    Dabei seit:
    16.10.2006
    Beiträge:
    518
    Zustimmungen:
    0
    Ne neuinstallation wäre unnötig gewesen.

    Code:
    apt-get install --reinstall xfonts-base xfonts-base-transcoded  xfonts-75dpi-transcoded xfonts-75dpi xfonts-100dpi xfonts-100dpi-transcoded[/code
    
    Hätte ausgereicht. 
    
    Wegen sowas installiert man nicht neu, oder sind wir bei Windows :frage:
     
Thema:

Nach Update xserver kaputt

Die Seite wird geladen...

Nach Update xserver kaputt - Ähnliche Themen

  1. Nicht erkannte Zeichen nach Update

    Nicht erkannte Zeichen nach Update: Hi, nachdem ich mein Kali Linux geupdated habe, ist mir aufgefallen dass viele Zeichen auf verschiedenen Nutzeroberflächen nur fehlerhaft...
  2. Nach Update debian 8 ist der Zugriff auf samba4 nicht möglich

    Nach Update debian 8 ist der Zugriff auf samba4 nicht möglich: Gerade habe ich debian mit dem Befehl "apt-get ugrade" aktualisiert. Es gab zahlreiche neue Daten unteranderen samba files. Nach neuem Start kann...
  3. Autehtifizierung gegen Password Server nach Update SAMBA 3.6.6

    Autehtifizierung gegen Password Server nach Update SAMBA 3.6.6: Hi... ich bekomme einfach den "Dreh" nicht an meine Recherche/Suche nach einer Lösung: Ein Samba 3.5.6 (läßt sich leider z.Z. nicht updaten) läuft...
  4. Starkes Ruckeln und Grafikfehler nach Update auf MBP Retina

    Starkes Ruckeln und Grafikfehler nach Update auf MBP Retina: [Gelöst] Starkes Ruckeln und Grafikfehler nach Update auf MBP Retina Moin! Hab heute ein Update von Apple auf meinem 13" MBP Retina installiert...
  5. Xubuntu-Update scheiterte-13.04 nach 13.10 frostet ein.

    Xubuntu-Update scheiterte-13.04 nach 13.10 frostet ein.: Es kam ein Popup wollen Sie updaten 13.04 nach 13.10. gemacht 3 Stunden update dann am Ende ging was schief. Nun frostet das neue Xubuntu ein was...