mysql-server startet nicht

Dieses Thema im Forum "Anwendungen" wurde erstellt von Woosh, 02.11.2006.

  1. Woosh

    Woosh Eroberer

    Dabei seit:
    10.05.2006
    Beiträge:
    71
    Zustimmungen:
    0
    hi leute,

    ich wollte hier grade den mysql-server starten... als superuser... hier ein ausschnitt:

    Code:
    noname:/home/f3ar # mysqladmin -u root password test
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'
    
    könnt ihr mir zufällig sagen, was da fehlt?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 02.11.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Äh,

    du versuchst hier nicht den Server zu starten, sondern dich zu ihm zu verbinden........:)

    Starte ihn erstmal mit

    Code:
    /etc/init.d/mysql start
     
  4. Woosh

    Woosh Eroberer

    Dabei seit:
    10.05.2006
    Beiträge:
    71
    Zustimmungen:
    0
    das ging trotzdem nich... hier jetz mal alles, was er ausgegeben hat:

    Code:
    noname:/home/f3ar # /etc/init.d/mysql start
    Starting service MySQL                                                done
    noname:/home/f3ar # mysqladmin -u root password sus
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'
    noname:/home/f3ar #
    
     
  5. #4 lordlamer, 02.11.2006
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    steht doch da!

    du hast keinen zugriff. solltest vielleicht mal das passwort richtig setzen ;)
     
  6. Woosh

    Woosh Eroberer

    Dabei seit:
    10.05.2006
    Beiträge:
    71
    Zustimmungen:
    0
    lol... DAS IST JA DAS KOMISCHE hihi... es ist mit sicherheit das richtige passwort!!!

    edit... oder sry... wie meintest du das jetz genau mit "passwort richtig setzen"?
     
  7. #6 supersucker, 02.11.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ja,

    also wie dein username und passwort ist musst du schon selber wissen.

    Klappt denn

    Code:
    mysql --host=localhost --database=test --user=dein_user --password=dein_pass
    ?
     
  8. #7 lordlamer, 02.11.2006
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    (using password: NO)

    heisst du hast die falschen parameter mitgegeben und solltest mal in die doku schauen
     
  9. Woosh

    Woosh Eroberer

    Dabei seit:
    10.05.2006
    Beiträge:
    71
    Zustimmungen:
    0
    hihi... nein... da kommt wieder der schmarrn mit "access denied..."! fiiiiiix... aber das pw stimmt GANZ SICHER!!! damit logg ich mich doch schon die ganze zeit ein!!!
     
  10. #9 lordlamer, 02.11.2006
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    hast du es gemacht so wie supersucker es gesagt hat?

    zeig mal den aufruf und die meldung
     
  11. Woosh

    Woosh Eroberer

    Dabei seit:
    10.05.2006
    Beiträge:
    71
    Zustimmungen:
    0
    Code:
    noname:/home/f3ar # mysql --host=localhost --database=test --user=su --password=sus
    ERROR 1045 (28000): Access denied for user 'su'@'localhost' (using password: YES)
    

    und das pw stimmt.. glaub mir ;-)
     
  12. #11 lordlamer, 02.11.2006
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    der benutzer heisst "su" und das passwort "sus" ???
     
  13. #12 supersucker, 02.11.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    1. Hast du für den User root ein pw eingerichtet? Das ist nämlich initial leer, also probier mal

    Code:
    mysql --host=localhost --database=test user=root
    Klappt das nicht dann:

    2. Starte mal den mysql-server mit der Option

    Code:
    --skip-grant-tables 
    verbinden, user und pw einrichten, fertig.

    3. Tu uns und dir den Gefallen und lies das mysql-manual.
     
  14. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Ohje ohje, hier gibt's ja tolle Tips. ;)
    Code:
    noname:/home/f3ar # mysqladmin -u root password test
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'
    
    Die Meldung sagt doch schon alles. Offenbar ist für root ein Passwort gesetzt. Du musst also
    Code:
    mysqladmin -u root -p password 'test'
    
    verwenden, damit du das alte Passwort angeben kannst. Wenn du '-p' nicht verwendest, geht er davon aus, dass du dich ohne Passwort einloggen willst. Ausserdem gehört das neue Passwort in Hochkommata.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. Woosh

    Woosh Eroberer

    Dabei seit:
    10.05.2006
    Beiträge:
    71
    Zustimmungen:
    0
    Code:
    noname:/home/f3ar # mysql --host=localhost --database=test user=root
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    noname:/home/f3ar # mysql --skip-grant-tables
    mysql: unknown option '--skip-grant-tables'
    noname:/home/f3ar #
    
    geht ned... oder hab ich schon wieder was falsch gemacht? LOL
     
  17. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Siehe mein letzter Beitrag. Dein root-User hat offenbar schon ein Passwort, also musst du ihm das auch angeben, sonst kannst du dich auf dem MySQL-Server nicht einloggen.
     
Thema:

mysql-server startet nicht

Die Seite wird geladen...

mysql-server startet nicht - Ähnliche Themen

  1. MySQL-Server lässt sich nicht installieren

    MySQL-Server lässt sich nicht installieren: Hi, ich hab hier Pobleme mit MySQL ... ich krieg den Server nicht installiert: # apt-get install mysql-server-5.1 Paketlisten werden gelesen......
  2. dpkg-reconfigure mysql-server-5.0 | Passwort setzten

    dpkg-reconfigure mysql-server-5.0 | Passwort setzten: Hallo, nachdem ich schon 2 tage rumfrage und suche und keine Lösung habe schau ich mal hier. Suche hat im Forum auch nichts ergeben. Möchte gern...
  3. 2 Versionen von MySQL-Server und phpMyAdmin verwendet's "falsche"

    2 Versionen von MySQL-Server und phpMyAdmin verwendet's "falsche": Hallo zusammen, auf meiner Maschine läuft openSUSE 10.3. Laut YaST und phpinfo() läuft auf meinem System MySQL 5.0.45-22. Wenn ich über die...
  4. MySQL-Server 5.0 auf O.Suse 10.0

    MySQL-Server 5.0 auf O.Suse 10.0: Hallo, ihr da draußen, also ich habe einen Root. Auf diesem ist OpenSuSe 10.0. Von Vornherein war da Mysql 4.1 drauf, Nun möchte ich da 5.0...
  5. Keine Verbindung zu MySQL-Server

    Keine Verbindung zu MySQL-Server: Hallo, ich habe seit kurzem einen vServer gemietet und soweit auch alles eingerichtet, sodass alles erstmal lief. Hab dann gestern ein...