mysql-admin installieren klappt nicht wegen glibc

Dieses Thema im Forum "Linux OS" wurde erstellt von supersucker, 26.10.2005.

  1. #1 supersucker, 26.10.2005
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    hallo,

    bin gerade am verzweifeln das mysql-controlcenter (mysqlcc) zu installieren (FC4),

    ein

    Code:
    rpm -i mysql-administrator-1.1.4-1.i586.rpm
    ergibt:

    Code:
    Fehler: Failed dependencies:
            libatkmm-1.6.so.1 is needed by mysql-administrator-1.1.4-1.%{targos}.i586
            libgdkmm-2.4.so.1 is needed by mysql-administrator-1.1.4-1.%{targos}.i586
            libgtkmm-2.4.so.1 is needed by mysql-administrator-1.1.4-1.%{targos}.i586
            libpangomm-1.4.so.1 is needed by mysql-administrator-1.1.4-1.%{targos}.i586
    
    hab mir also gtkmm24-2.8.0-1,i386.rpm gezogen:

    Code:
    rpm -i gtkmm24-2.8.0-1.i386.rpm
    ergibt:
    Code:
    Fehler: Failed dependencies:
            libcairo.so.2 is needed by gtkmm24-2.8.0-1.i386
            libpangocairo-1.0.so.0 is needed by gtkmm24-2.8.0-1.i386
    also hab ich cairo-1.0.2-2.i386.rpm gezogen:
    Code:
    rpm -i cairo-1.0.2-2.i386.rpm
    
    ergibt:

    Code:
    Fehler: Failed dependencies:
            libc.so.6(GLIBC_2.4) is needed by cairo-1.0.2-2.i386
    
    super! hab dann glibc-2.3.5-10.i386.rpm gezogen, das enthält laut rpmseek die libc.so.6:
    Code:
    rpm -i glibc-2.3.5-10.i386.rpm
    
    ergibt (natürlich):

    Code:
    Fehler: Failed dependencies:
            glibc-common = 2.3.5-10 is needed by glibc-2.3.5-10.i386
    
    ok, hab also dann zu guter letzt ein:

    Code:
    rpm -i glibc-common-2.3.5-10.i386.rpm
    gemacht mit folgendem ergebnis:

    Code:
    
            package glibc-common-2.3.5-10.3 (which is newer than glibc-common-2.3.5-10) is already installed
            file /usr/bin/gencat from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/bin/getconf from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/bin/getent from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/bin/iconv from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/bin/lddlibc4 from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/bin/locale from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/bin/localedef from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/bin/rpcgen from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/bin/sprof from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/bin/tzselect from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/libexec/pt_chown from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/sbin/build-locale-archive from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/sbin/rpcinfo from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/sbin/zdump from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/sbin/zic from install of glibc-common-2.3.5-10 conflicts with file from package glibc-common-2.3.5-10.3
    
    die zeile

    Code:
            package glibc-common-2.3.5-10.3 (which is newer than glibc-common-2.3.5-10) is already installed
    
    find ich besonders amüsant......WTF???
    ich hab also ne neuere version schon auf dem system, aber mit der geht es nicht oder wie? ich kann ja auch nicht mal eben so glib deinstallieren und genau die 2.3.5-10 installieren...

    ich versteh überhaupt nix mehr gerade......bin mit meinem linuxlatein am ende........

    kann mir jemand sagen, wie das löse bzw. was ich tun muss?

    danke im voraus für alle tips.........
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 simplex, 26.10.2005
    simplex

    simplex [Versuchstier]

    Dabei seit:
    08.10.2004
    Beiträge:
    245
    Zustimmungen:
    0
    Ort:
    Hessen, nähe Limburg
    korrigiert mich, wenn ich jetzt was blödes schreibe..

    also, solch einen fehler hatte ich auch schon mal. liegt daran, dass die versionen nicht übereinstimmen....deine ist wohl neuer, als die mit der mal gearbeitet worden ist...
    es gibt soweit ich weiß einen befehl bzw. eine option, der/die diese überprüfung deativiert...musste mal in der hilfe nachschauen..

    gruss
    micha
     
  4. #3 supersucker, 26.10.2005
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    hmm, ja

    auszug aus rpm-manpage:
    hab also

    Code:
    rpm -F --oldpackage glibc-common-2.3.5-10.i386.rpm
    
    gemacht, das ist auch ohne fehlermeldung durchgelaufen,
    mache ich jetzt aber wieder ein:

    Code:
    rpm -i glibc-2.3.5-10.i386.rpm
    
    erhalte ich:

    Code:
    Fehler: Failed dependencies:
            glibc-common = 2.3.5-10 is needed by glibc-2.3.5-10.i386
    
    und ich bin wieder da wo ich angefange hab, das ist zum .....

    hat denn schon mal jemand so ein problem gehabt?
    muss ich noch irgendwas machen damit das alte package gelinkt wird?

    ein

    Code:
    ldconfig
    hat nicht geholfen, und das beste ist, mache ich ein

    Code:
    rpm -qa | grep glibc-common
    
    krieg ich als ausgabe:

    aha, warum ist dann der rpm update befehl vorher ohne fehlermeldung durchgelaufen?

    und warum steht bei meiner versuchten cairo-installation (siehe erster post)
    Code:
    Fehler: Failed dependencies:
            libc.so.6(GLIBC_2.4) is needed by cairo-1.0.2-2.i386
    glibc_2.4? die gibt es doch gar nicht, die aktuelle version ist doch die 2.3.5 oder?

    wäre für tips wie ich das zum laufen kriege sehr dankbar.........
     
  5. #4 supersucker, 28.10.2005
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    nicht das ich den thread jetzt hochpushen möchte, aber hat keiner von euch jemals so einen bizarren fehler gehabt?

    also ich meine das das system einem sagt man hat ein neueres packet als man bräuchte und dann beim installieren genau mit der meldung abbricht das man eben gerade nicht das ältere paket hat...........ich finde dieses verhalten durchaus bizarr, aber was noch schlimmer ist, ist das ich überhaupt keine ahnung hab wie das wieder hinbiege.............kann ich das system irgendwie explizit anweisen das ältere packet zu installieren und zu verlinken?

    wenn jemand mal ein ähnliches problem hatte bitte posten wie der workaround aussieht, danke..........
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

mysql-admin installieren klappt nicht wegen glibc

Die Seite wird geladen...

mysql-admin installieren klappt nicht wegen glibc - Ähnliche Themen

  1. Packages installieren

    Packages installieren: Hallo Forum, ich kämpfe mich weiter in Solaris rein. Nun aber eine Frage zur Package Installation. Während ich an unserem Solaris 11 Server...
  2. Artikel: I2P unter Ubuntu auf dem Raspberry Pi 2 installieren

    Artikel: I2P unter Ubuntu auf dem Raspberry Pi 2 installieren: Das »Invisible Internet Project« (I2P) ist ein Overlay-Netz, welches einen hohen Grad an Anonymisierung bietet. Aufgrund seines geringen...
  3. Probleme beim installieren

    Probleme beim installieren: Moin! Ich habe mir vor ein paar Wochen einen Hyrican Intel® i5, 8192MB DDR3-RAM, 1TB Speicher + 120GB SSD,GF GTX750Ti »Military 4610 PC gekauft....
  4. Solaris 10 von USB Stick aus installieren

    Solaris 10 von USB Stick aus installieren: Hallo! Leider finde ich nichts brauchbares im Netz, deshalb melde ich mich hier. Habe einen Rechner, auf den ich Solaris 10 installieren...
  5. Redhat 7 bootloader auf Partition installieren

    Redhat 7 bootloader auf Partition installieren: Hallo zusammen, ich habe ein System das seinen bootloader (grub) im MBR liegen hat auf sda1 installiert. Nun möchte ich ein RHEL7 drunter...