Mplayer funzt net! Help!

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von BuLLDoGGe, 22.01.2007.

  1. #1 BuLLDoGGe, 22.01.2007
    BuLLDoGGe

    BuLLDoGGe Grünschnabel

    Dabei seit:
    22.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Hi Leute
    ich hab seit 2 Tagen Suse 10.1 auf meinem Rechner installiert und will eigentlich soweit wie möglich von Windoof weg.

    Doch leider hab ich arge Probleme mit Videos. Nur ein bruchteil läuft, der Rest bricht mit Fehlern ab. Als Player will ich den Mplayer nehmen. Installiert hab ich ihn mit hilfe von Packman.links2linux und auch den W32Codec.

    Aber er spielt trotzdem nix ab. Hab gelesen das er in der Share nen ordner mit W32Codec erstellen sollte, aber der ist nicht vorhanden. Vermute mal es liegt daran.

    Also Leute bitte helft mir...sonst muss ich wohl oder übel wieder auf Windoof wechseln...:hilfe2: :hilfe2: :hilfe2:

    Als beispiel eine der Fehlermeldungen:
    Fatal Error
    Mplayer interrupted by signal 6 in module unknown

    Gruß von einem frustierten....
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Start mal mplayer aus der Konsole heraus mit der Option '-v' und was immer Du abspielen willst, also z.B.
    mplayer -v video.avi

    Das ergibt eine Menge Meldungen, die Du am besten alle mal hierher schickst.
     
  4. #3 BuLLDoGGe, 22.01.2007
    BuLLDoGGe

    BuLLDoGGe Grünschnabel

    Dabei seit:
    22.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    MPlayer 1.0rc1-SUSE Linux 10.1 (i686)-Packman-4.1.0 (C) 2000-2006 MPlayer Team
    CPU: AMD Athlon(tm) XP (Family: 6, Model: 6, Stepping: 2)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
    Compiled with runtime CPU detection.
    get_path('codecs.conf') -> '/home/Josef/.mplayer/codecs.conf'
    Reading /home/Josef/.mplayer/codecs.conf: Can't open '/home/Josef/.mplayer/codecs.conf': No such file or directory
    Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
    Using built-in default codecs.conf.
    CommandLine: '-v' 'video.avi'
    init_freetype
    get_path('font/font.desc') -> '/home/Josef/.mplayer/font/font.desc'
    font: can't open file: /home/Josef/.mplayer/font/font.desc
    font: can't open file: /usr/share/mplayer/font/font.desc
    Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
    Using nanosleep() timing
    get_path('input.conf') -> '/home/Josef/.mplayer/input.conf'
    Can't open input config file /home/Josef/.mplayer/input.conf: No such file or directory
    Parsing input config file /etc/mplayer/input.conf
    Input config file /etc/mplayer/input.conf parsed: 67 binds
    Opening joystick device /dev/input/js0
    Can't open joystick device /dev/input/js0: No such file or directory
    Can't init input joystick
    Setting up LIRC support...
    mplayer: could not connect to socket
    mplayer: Connection refused
    Failed to open LIRC support. You will not be able to use your remote control.
    get_path('video.avi.conf') -> '/home/Josef/.mplayer/video.avi.conf'

    Playing video.avi.
    get_path('sub/') -> '/home/Josef/.mplayer/sub/'
    File not found: 'video.avi'
    Failed to open video.avi.

    vo: x11 uninit called but X11 not inited..

    Exiting... (End of file)

    Hier...vll kannst du was damit anfangen...ich jedenfalls net.:D
     
  5. z00k

    z00k I love my slack! Do u?

    Dabei seit:
    24.01.2005
    Beiträge:
    302
    Zustimmungen:
    0
    Ort:
    earth.getLocation("z00k");
    l0l

    ehm naja du solltest schon ne file nehmen die auch existiert :D

    also ersetze video.avi mit einer deiner video files (evtl mit path)


    gReetZ
     
  6. #5 BuLLDoGGe, 22.01.2007
    BuLLDoGGe

    BuLLDoGGe Grünschnabel

    Dabei seit:
    22.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Ähm glaubst ich bin net ganz helle oder was?

    DAS WAR EINS MEINER VIDEO FILES!!! Habs einfach umbenannt weil mir der Titel zu lang zum schreiben war...X( ?(
     
  7. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Nun, mplayer kann die Datei zumindest nicht lesen. Oeffne doch nochmal eine Konsole, gehe in das Verzeichnis, wo Deine Video-Datei liegt und fuehre 'ls -la' aus (Du kannst auch ein neues Verzeichnis anlegen, die Datei dort reinschieben und dann 'ls -la' ausfuehren).
    Hast Du fuer die Datei, die Du angucken moechtest, Leserechte? Dann fuehre danach nochmal 'mplayer -v dateiname.avi' aus, und schick uns jeweils die Ausgabe mit Prompt.
     
  8. #7 BuLLDoGGe, 22.01.2007
    BuLLDoGGe

    BuLLDoGGe Grünschnabel

    Dabei seit:
    22.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Josef@U-96:~> ls-la
    bash: ls-la: command not found

    Josef@U-96:~> mplayer -v video.avi
    MPlayer 1.0rc1-SUSE Linux 10.1 (i686)-Packman-4.1.0 (C) 2000-2006 MPlayer Team
    CPU: AMD Athlon(tm) XP (Family: 6, Model: 6, Stepping: 2)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
    Compiled with runtime CPU detection.
    get_path('codecs.conf') -> '/home/Josef/.mplayer/codecs.conf'
    Reading /home/Josef/.mplayer/codecs.conf: Can't open '/home/Josef/.mplayer/codecs.conf': No such file or directory
    Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
    Using built-in default codecs.conf.
    CommandLine: '-v' 'video.avi'
    init_freetype
    get_path('font/font.desc') -> '/home/Josef/.mplayer/font/font.desc'
    font: can't open file: /home/Josef/.mplayer/font/font.desc
    font: can't open file: /usr/share/mplayer/font/font.desc
    Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
    Using nanosleep() timing
    get_path('input.conf') -> '/home/Josef/.mplayer/input.conf'
    Can't open input config file /home/Josef/.mplayer/input.conf: No such file or directory
    Parsing input config file /etc/mplayer/input.conf
    Input config file /etc/mplayer/input.conf parsed: 67 binds
    Opening joystick device /dev/input/js0
    Can't open joystick device /dev/input/js0: No such file or directory
    Can't init input joystick
    Setting up LIRC support...
    mplayer: could not connect to socket
    mplayer: Connection refused
    Failed to open LIRC support. You will not be able to use your remote control.
    get_path('video.avi.conf') -> '/home/Josef/.mplayer/video.avi.conf'

    Playing video.avi.
    get_path('sub/') -> '/home/Josef/.mplayer/sub/'
    File not found: 'video.avi'
    Failed to open video.avi.

    vo: x11 uninit called but X11 not inited..

    Exiting... (End of file)


    Also la-la kennt er garnicht.
    Hab den Mplayer nochmal de und dann installiert. Jetzt geht ein teil der Videos, aber nicht alle. Auch das File wo er die Meldung ausspuckt geht im KDE aber nicht in der Konsole.
    Langsam aber sicher geb ich auf...;(
    Und im Inet find auch auch nix gescheides als Hilfe...

    Also eins muss ich sagen Linux ist noch lange nicht so weit Windows den Rang abzulaufen, wenn schon so einfache Programme ärger machen...
     
  9. #8 supersucker, 22.01.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Das will auch keiner.

    Linux ist eine Alternative zu Windows und kein Ersatz.

    Es heisst

    Code:
    ls -la
    Zwischen ls und -la muss ein Leerzeichen sein.
     
  10. #9 BuLLDoGGe, 22.01.2007
    BuLLDoGGe

    BuLLDoGGe Grünschnabel

    Dabei seit:
    22.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Ich denk mal es geht um die Zeile...

    -r-xr-xr-x 1 Josef users 435763200 2006-12-27 08:50 Video.avi

    Na gut kann man sehn wie man will...aber es ist wie es ist...so ists auch keine Alternative...
    Ich seh leider meine Befürchtungen bestätigt, dass man von Windows einfach nicht loskommt selbst wenn man blos Videos schaun will (auf dem Rechner versteht sich).
    Und für Einsteiger wie mich die Seit Dos-Zeiten nur noch mit Windows zu tun haben siehts einfach zu düster aus...
     
  11. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    mach doch mal


    Code:
    sudo chmod 777 deinedatei.avi
     
  12. #11 supersucker, 22.01.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Nein,

    das ist Unsinn.

    Warum liest du nicht z.B. mal das anfängerfreundliche und kurz gehaltene online-Handbuch von Suse (Zeitaufwand ca. 2h) ? Da werden 99% deiner Fragen schon geklärt.

    Zur Sache:

    Installier dir z.B. mal den vlc-Player über Yast, der bringt eigentlich schon alle benötigten Codecs mit.
    Und wie du dir über Yast oder smart die win32-codecs installierst findest du ebenfalls im online-manual.
     
  13. z00k

    z00k I love my slack! Do u?

    Dabei seit:
    24.01.2005
    Beiträge:
    302
    Zustimmungen:
    0
    Ort:
    earth.getLocation("z00k");
    tja du hast doch die falsche file angegeben

    linux unterscheidet im gegensatz zu windows in Gross- und Kleinschreibung...

    Code:
    mplayer Video.avi
    wird funktionieren...


    gReetZ
     
  14. #13 BuLLDoGGe, 22.01.2007
    BuLLDoGGe

    BuLLDoGGe Grünschnabel

    Dabei seit:
    22.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Also jetzt scheinen fast alle zu laufen und meine Nerven sind langsam am ende.

    Hab mich auch auf der OpenSuse Homepage umgesehn...und Docu-technisch für mich nix brauchbares gefunden. Die verweisen eigentlich nur auf Packman...

    Das Linux zwischen Groß und Klein unterscheidet wusste ich bisher noch net. Gut wieder was gelernt.

    Was der Befehl "sudo chmod 777 deinedatei.avi" macht ist mir relativ scheierhaft weil er scheinbar geht da keine Fehlermeldung kommt, aber was er macht und ob er was macht???

    Ach ja bei der Installation des VLC-Players war Linux garnicht begeister weil irgend eine Version net Verfügbar oder nicht Improtierbar war...nach Igorieren des ganzen lief die Installation schon, aber VLC-Player ist keiner in Sicht auf meinem Rechner...

    Der Umstieg ist einfach krass von Windows wo man praktisch alles machen konnte ohne irgendwelche Probleme, hast im Gegensatz bei Linux schon fast ne paranoide Sicherheit...da geht ohne Root fast nix...ich kann ja net mal nen Ordner in meinem UserOrdner erstellen...und da sollte ich ja wohl Schreibrechte haben.
    Am liebsten würd ich nur noch unter root arbeiten...
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    der chmod befehl vergibt die rechte an die benutzer, 777 heist das alle nutzer lesen schreiben und ändern dürfen, das is aber normal das der nichts ausgibt
     
  17. #15 gropiuskalle, 22.01.2007
    Zuletzt bearbeitet: 22.01.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Der Tipp war eh Quatsch. Mit 'chmod' werden Zugriffsrechte geändert, bezüglich des Videofiles war das aber wohl überflüssig. Keinesfalls solltest Du hier gepostete Befehle einfach übernehmen, ohne Dich wenigstens mit 'man Programmname' darüber zu informieren, was diese Befehle bewirken.

    Wenn YaST Abhängigkeiten anmahnt, so solltest Du dies schon ernst nehmen, ansonsten kann es sehr schnell Probleme geben - am besten deinstallierst Du den halben VLC erstmal und reinstallierst ihn dann, wenn alle Abhängigkeiten erfüllt werden können.

    Also dass Du in Deinem user-Bereich keinen Ordner anlegen kannst, ist allerdings nicht Standard, darüber ärgerst Du Dich also zu recht - warum dies so ist, weiß ich nicht, aber anpassen können wirst Du es in jedem Fall.

    - Konsole öffnen

    - Mit dem root-Konqueror Dein /home/username-Ordner rechtsklicken und auf 'Eigenschaften' gehen

    - Dort den Reiter 'Berechtigungen' wählen

    - Dort Nachschauen, wie die Rechte gesetzt sind, ggf. auf 'Dein username' & 'users' setzen (bei 'Benutzer' / 'Gruppe')

    - Das Häkchen bei 'Änderungen auf alle Unterordner und ihre Inhalte anwenden' setzen, damit die Rechte rekursiv verändert werden können.

    - Auf 'OK' klicken

    Das ganze geht auf der Konsole wesentlich fixer mit den Befehlen 'chmod' und 'chown', aber eh ich Dir irgendwelche Kommandos um die Ohren haue...

    Ansonsten: hey, wir alle hatten einen schweren Einstieg, aber das liegt nicht daran, dass Linux nun wesentlich komplexer wäre als andere OSs - es ist allein eine Frage des Wissens, mehr nicht. Ich bekomme ein frischinstalliertes Kubuntu oder SuSE mittlerweile innerhalb von vielleicht 'ner halben Stunde multimediatauglich, einfach deshalb, weil ich nach etlichen Installationen alle benötigten Pakete, codecs etc. buchstäblich im Schlaf herunterbeten könnte. Bei Dir vermute ich z.B. fehlende Paketquellen, also schreib doch mal, was in YaST alles an Quellen drin ist.

    Edit: Mir fällt gerade ein, dass man heute ja nicht mehr davon ausgehen kann, dass SuSE-user automatisch KDE als Desktop-Enviroment haben. Meine Konqueror-Lösung setzt voraus, dass Du KDE und nicht Gnome hast (geht unter Gnome aber auch, nur weiß ich nicht, wie).

    Noch ein Edit: Und komm nicht auf die Idee, auf diese Art alle Bereiche Deines Linux' für Dich als user Zugreifbar zu machen. Die Unterteilung in user / root ist einer der wesentlichen Gründe, weshalb Linux ein verhältnismäßig sicheres System ist!
     
Thema:

Mplayer funzt net! Help!

Die Seite wird geladen...

Mplayer funzt net! Help! - Ähnliche Themen

  1. MPlayer 1.3 veröffentlicht

    MPlayer 1.3 veröffentlicht: Die Entwickler des freien Medien-Players MPlayer haben nicht einmal einen Monat nach MPlayer 1.2.1 eine neue Hauptversion der Anwendung...
  2. MPlayer 1.2 freigegeben

    MPlayer 1.2 freigegeben: Über drei Jahre nach der Freigabe der stabilen Hauptversion 1.1 haben die Entwickler des freien Multimedia-Players MPlayer die Anwendung in einer...
  3. SMPlayer 15.9 unterstützt mpv

    SMPlayer 15.9 unterstützt mpv: SMPlayer, eines der bekanntesten Frontends für den Mplayer, ist in einer neuen Version veröffentlicht worden. Zu den zahlreichen Neuerungen der...
  4. Mplayer-Fork »mpv«: Version 0.5 veröffentlicht

    Mplayer-Fork »mpv«: Version 0.5 veröffentlicht: Knapp ein Jahr nach der initialen Gründung des alternativen Players »mpv« kann das Projekt auf diverse Veröffentlichungen und zahlreiche...
  5. MPlayer: Neuer Fork, neuer Schwung?

    MPlayer: Neuer Fork, neuer Schwung?: Eine Gruppe von Entwicklern hat mit mpv einen neuen Fork von mplayer2 gestartet, der das Beste aus MPlayer und mplayer2 mit weiteren...