Mount-Problem mit NTFS

Dieses Thema im Forum "Laufwerke / Speichermedien" wurde erstellt von Schwedeii, 19.09.2006.

  1. #1 Schwedeii, 19.09.2006
    Schwedeii

    Schwedeii Tripel-As

    Dabei seit:
    09.01.2006
    Beiträge:
    208
    Zustimmungen:
    0
    So, Leute, ich hab hier ein grösseres Problem.
    Ich hab mir ein Knoppix als Debian fest auf die Platte installiert.
    Ich will wegen eines Images das NTFS beschreibbar mounten, krieg das aber nicht hin. Wenn ich Knoppix von CD oder USB-Stick starte, gibt es keine Probleme, das NTFS bescheibbar zu mounten, aber unter der Festplatteninstallation geht das plötzlich nicht mehr. Ich habe folgendes vor:
    NTFS automatisch mounten, Image automatisch mounten.
    Mounte ich das NTFS unter der Debian-like, dann geht dies nach wie vor nur als root und nur dieser hat Schreib und lese-Rechte. für alle anderen ist das tabu.
    Ich hab auch die bekannten parameter in der fstab (auto, users) eingestellt, sowie den mount-point auf chmod 777 gestellt, nichts. Das mounten geht nach wie vor nur mit Hand, und wenn das System gemountet ist, steht es auf 700 und schaltet automatisch auf den User und group root um.
    weiss da jemand weiter?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Wenn du deine NTFS-Partition noch unter Windows nutzen willst, solltest du Schreibzugriffe unter Linux auf NTFS moeglichst vermeiden. Weiterhin lies mal 'man fstab' und 'man mount', dann wirst du feststellen, dass user, chmod usw. als Mount-Optionen fuer NTFS nicht unterstuetzt werden.
     
  4. #3 Schwedeii, 20.09.2006
    Zuletzt bearbeitet: 20.09.2006
    Schwedeii

    Schwedeii Tripel-As

    Dabei seit:
    09.01.2006
    Beiträge:
    208
    Zustimmungen:
    0
    Hmm, das hab ich grad gemacht, aber Hinweise auf das angesprochene hab ich da nicht gefunden. Nun gut, dann weiss ich jedenfalls, dass es damit nicht geht, was mir aber nicht weiter hilft, da ich immer noch nicht so, wie ich will, mounten kann.
    Nun, das ist 'ne längere Geschichte. Kurz gesagt, ja, ab und zu, (wenn auch selten) werd ich das XP schon mal hochfahren müssen, es sei denn, transcode ist endlich soweit. (ich will meine Video-avi's, die Kamera macht nun mal kein anderes Format, in VCD oder SVCD oder auf DVD bringen). Ausserdem kann ich das XP nicht runterbraten, auf dem Lappie ist noch Garantie, und eine Install-CD war auch nicht bei. Ausserdem geht eine andere XP-Scheibe auch nicht. (findet kein Medium).
    Also will ich ein 10GB Image anlegen, auf das ich während des stationären Betriebes (OS auf USB-Platte)als Home-Folder zugreife und für unterwegs von Knoppix vom USB-Stick die Daten für den Home-Ordner immer noch zur Verfügung stehen habe, ohne den Rechner umkonfigurieren zu müssen.
     
  5. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Hast du die Option 'rw' fuer die Partition in der fstab gesetzt? Wie sieht der fstab-Eintrag ueberhaupt aus? Wenn du nicht willst, dass alle Dateien automatisch root gehoeren, die auf der NTFS-Partition liegen, musst du 'uid' und 'gid' auf die deines Normalusers setzen und 'umask' verwenden um die Default-Berechtigungen festzulegen.
     
  6. #5 Schwedeii, 22.09.2006
    Schwedeii

    Schwedeii Tripel-As

    Dabei seit:
    09.01.2006
    Beiträge:
    208
    Zustimmungen:
    0
    Das ist der entsprechende Eintrag. Funzt einfach nicht...
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
  9. #7 Schwedeii, 23.09.2006
    Schwedeii

    Schwedeii Tripel-As

    Dabei seit:
    09.01.2006
    Beiträge:
    208
    Zustimmungen:
    0
    Ich denke mal doch, als root kann ich ja lesen und schreiben. nur als user nicht und keine Einstellung hat gefunzt. Auch das auto-mounten klappt nicht.
     
Thema:

Mount-Problem mit NTFS

Die Seite wird geladen...

Mount-Problem mit NTFS - Ähnliche Themen

  1. Mount-Problem mit verschlüsselter DVD: ioctl: LOOP_SET_STATUS: Invalid argument

    Mount-Problem mit verschlüsselter DVD: ioctl: LOOP_SET_STATUS: Invalid argument: Hallo, ich versuche gerade unter Ubuntu Edgy Eft eine verschlüsselte DVD zu brennen. Leider scheitert das aber schon an der Verschlüsselung....
  2. Parted Magic 2013_06_15 passt Größe von defekten NTFS-Partitionen an

    Parted Magic 2013_06_15 passt Größe von defekten NTFS-Partitionen an: Die Entwickler der im Wesentlichen auf GNU Parted basierenden freien Live-Distribution zum Bearbeiten von Partitionen aller Art habe ihre...
  3. hat sich an der Syntax von ntfs-3g was geändert ?

    hat sich an der Syntax von ntfs-3g was geändert ?: Hallo Hat sich an d er syntax von ntfs-3g was geändert ? ein mounten per ntfs-3gschlägt fehl ---------- root@nathan64:/home/joerg# mount...
  4. Platzverbrauch ext4 vs ntfs

    Platzverbrauch ext4 vs ntfs: Hallo, ich habe u.a. 2 SATA II 1TB Festplatten (baugleich) mit fast identischen Dateien. Auf der ntfs Platte liegen ein paar Dateien mehr( c.a....
  5. Unlöschbares Verzeichnis von NTFS-Partition löschen

    Unlöschbares Verzeichnis von NTFS-Partition löschen: Hallo! Ich habe eine NTFS-formatierte externe Festplatte, die ich über ntfs-3g nutze. Unter Anderem zur Datensicherung per backintime. Dort...