mod_mono und asp.net 3.5

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von Nemesis, 23.07.2009.

  1. #1 Nemesis, 23.07.2009
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    hi,
    ich möchte gerne über meinen apache auch asp.net 3.5 seiten zur verfügung stellen. dies soll mit mod_mono funktionieren ... mit 2.0 ... mir bringt er den fehler:
    Code:
    Unrecognized attribute. (/www/WEB/Web.config line 4)
    
    Description: HTTP 500. Error processing request.
    
    Stack Trace:
    
    System.Configuration.ConfigurationException: Unrecognized attribute. (/www/WEB/Web.config line 4)
      at System.Configuration.ConfigurationData.ThrowException (System.String text, System.Xml.XmlTextReader reader) [0x00000] 
      at System.Configuration.ConfigurationData.ReadSectionGroup (System.Xml.XmlTextReader reader, System.String configSection) [0x00000] 
      at System.Configuration.ConfigurationData.ReadSections (System.Xml.XmlTextReader reader, System.String configSection) [0x00000] 
      at System.Configuration.ConfigurationData.ReadConfigFile (System.Xml.XmlTextReader reader) [0x00000] 
      at System.Configuration.ConfigurationData.Load (System.String fileName) [0x00000] 
    was steht in zeile 4:
    Code:
    <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
    also ich denk mal, dass er da an dem 3.5 hängt.

    jemand ne idee ?

    thx!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 hagbard celine, 24.07.2009
    hagbard celine

    hagbard celine Routinier

    Dabei seit:
    02.06.2005
    Beiträge:
    251
    Zustimmungen:
    0
    Ort:
    Chemnitz
    ich denke auch dass es an der Versionierung liegt. Methoden aus .NET3.5 werden von mono noch nicht abgedeckt. Ich bin zwar kein Webentwikler, aber ich hatte auch Probleme C#-Projekte mit .NET3.5 nach mono zu portieren. Versuch mal nur mit .NET2.0 zu arbeiten, bis mono nachgezogen hat.
     
Thema:

mod_mono und asp.net 3.5