Merkwürdiges Verhalten der Alt Taste (xorg)

Dieses Thema im Forum "Linux OS" wurde erstellt von Lord Kefir, 19.01.2005.

  1. #1 Lord Kefir, 19.01.2005
    Lord Kefir

    Lord Kefir König

    Dabei seit:
    10.06.2004
    Beiträge:
    944
    Zustimmungen:
    0
    So, vielleicht sollte man doch mal ein allgemeines Forum für den X-Server aufmachen. Ich weiß jetzt nämlich gar nicht wo ich dieses topic posten soll - es hat mit keinem wm zu tun und Basiskonfiguration ist es auch nicht... aber egal.

    Ich bastel mir gerade ein minimales Slackwaresystem zusammen und habe als einzigen Editor vi installiert. Das Problem ist, wenn ich z.B. ein xterm unter X starte (unabhängig vom wm), spuckt meine Alt-Taste nur kurioses Zeug aus (alt-a wird z.B. zu à). Dementsprechend ist es natürlich unmöglich, vi richtig zu bedienen.

    Mein xorg.conf ist einwandfrei konfiguriert. Daran kann es nicht also nicht liegen. Mein Lösungsansatz besteht also darin, die .Xmodmap zu modifizieren. Der Keycode für die Alt-Taste ist 64 (habe ich mit xce überprüft). Aber ich habe immer noch nicht rausgefunden, was ich das genau in de .Xmodmap eintragen muss.

    Oder hat jemand vielleicht eine andere Idee, wo das Problem sonst noch liegen könnte?!


    Mfg, Lord Kefir
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. codc

    codc /dev/null

    Dabei seit:
    12.01.2004
    Beiträge:
    607
    Zustimmungen:
    0
    Ähh blöde Frage - wo steht die Datei. Hab die komplette Festplatte abgesucht und gibt es bei mir nicht. Trotz Xorg.
     
  4. #3 Lord Kefir, 19.01.2005
    Lord Kefir

    Lord Kefir König

    Dabei seit:
    10.06.2004
    Beiträge:
    944
    Zustimmungen:
    0
    So weit ich weiß, kann man die eine eigene einfach im Homedirectory anlegen. Die systemweite müsste (glaub' ich) unter /etc/X11/xinit oder ähnlich liegen. Da war sie bei mir auch nicht - musste sie erst anlegen.

    Ich hab' mal Knoppix reingeschmissen, da gab es auch nirgendwo eine .Xmodmap und trotzdem läuft der Server einwandfrei. Ich habe auch die Kofiguration für die Tastatur übernommen - bringt läuft auch nichts. Komisch ist das.

    Bevor jemand auf die Idee kommt: die Tastatur ist in Ordnung. Sie funktioniert jedenfalls in den virtuellen Terminals.

    Langsam drehe ich durch. Ich google schon den halben Tag rum und habe immer noch nichts gefunden. Vielleicht werde ich heute Abend mal probeweiser xfree86 installieren - obwohl ich das eigentlich gar nicht will :(

    Mfg, Lord Kefir
     
  5. #4 Atomara, 19.01.2005
    Atomara

    Atomara Debrandeter User

    Dabei seit:
    06.03.2004
    Beiträge:
    1.255
    Zustimmungen:
    0
    Ort:
    Deutschland , Nrw , Münsterland
    ich kenne das problem ,ich habe danach wieder den xfree installiert
     
  6. #5 codc, 19.01.2005
    Zuletzt bearbeitet: 19.01.2005
    codc

    codc /dev/null

    Dabei seit:
    12.01.2004
    Beiträge:
    607
    Zustimmungen:
    0
    Ok gefunden /etc/X11/Xmodmap

    wenn ich das recht verstehe was da drinsteht wird die nur ausgelesen wenn

    # Option "XkbDisable" in xorg.conf auskommentiert wird.

     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 Lord Kefir, 19.01.2005
    Lord Kefir

    Lord Kefir König

    Dabei seit:
    10.06.2004
    Beiträge:
    944
    Zustimmungen:
    0
    Danke, genau das wollte ich hören :( Na super...

    Ich habe heute echt den ganzen Tag gegoogelt und war in irgendwelchen irc-channels unterwegs. Woran kann das denn liegen? So bekannt ist das Problem anscheinend nicht.

    Hab' jetzt erst einmal alles entfernt, was auch nur im Ansatz was mit X zu tun hatte. Werde die nächste Zeit wohl mit meiner Konsole verbringen... die hat mich wenigstens noch gerne ;)

    Mfg, Lord Kefir
     
  9. #7 Lord Kefir, 20.01.2005
    Lord Kefir

    Lord Kefir König

    Dabei seit:
    10.06.2004
    Beiträge:
    944
    Zustimmungen:
    0
    Also, ich muss noch mal mit meinem Problem stören.

    Ich habe gestern probeweise mal mein Slackware durch Vectorlinux ersetzt und hatte immer noch dasselbe Problem: egal welchen wm ich benutze, ich kann im xterm nicht meine Alt-Taste benutzen. Ich hab' auch noch aterm ausprobiert - damit konnte ich den vi gar nicht bedienen.

    Dann habe ich Knoppix reingeschmissen - da hatte ich dieselben Probs. Allerdings habe ich gemerkt, dass es mit dem rxvt besser lief. Die KDE-Konsole lief (auch unter fluxbox) problemlos.

    Jetzt habe ich wieder Slack drauf und habe vorhin rxvt kompiliert - mit der Option -disable-delete-key funktioniert alles einigermaßen. Allerdings funzen die 'Pos1'- und die 'Ende'-Taste nicht.

    Ich hatte das Problem jetzt unter drei verschiedenen Distris - mal mit xorg mal mit xfree86. Meine Tastatur ist einwandfrei. Mir kann jetzt keiner erzählen, dass ich der einzige bin, der das Problem hat. Da muss es doch eine Lösung geben.

    Wenn einer von euch fluxbox unter xorg benutzt und in seinem Terminalemulator problemlos den vi bedienen kann, mal bitte bescheid sagen.


    Mfg, Lord Kefir
     
Thema:

Merkwürdiges Verhalten der Alt Taste (xorg)

Die Seite wird geladen...

Merkwürdiges Verhalten der Alt Taste (xorg) - Ähnliche Themen

  1. Ubuntu in Virtual Box: merkwürdiges Fensterverhalten

    Ubuntu in Virtual Box: merkwürdiges Fensterverhalten: Es betrifft Ubuntu 11.10 und Mint 12 als Gast. Host ist OpenSuse 12.1 Wenn ich ein Fenster verschiebe und anschließend irgendwo hin klicke,...
  2. Merkwürdiges Verhalten bei Umschalten auf statische IP

    Merkwürdiges Verhalten bei Umschalten auf statische IP: Hi, ich habe folgendes Problem: Ich arbeite zu Hause mit DHCP und im Büro mit statitsche IP. Ich benutze das nm-applet 0.6.6 um zwischen diesen...
  3. Merkwürdiges Verhalten

    Merkwürdiges Verhalten: hi, ich bin mir nicht sicher ob ich das hier richtig poste, aber ich weiss nicht genau was für ein Problem hier vorliegt, da ich den Fehler nicht...
  4. Merkwürdiges Verhalten von sudo

    Merkwürdiges Verhalten von sudo: Hallo, ich wollte mir vorhin die Arbeit etwas leichter machen und habe sudo und die sudo Erweiterung für vim emerged. Mit visudo habe ich...
  5. Dualboot: Merkwürdiges Verhalten

    Dualboot: Merkwürdiges Verhalten: Hallo liebe Linux-Spezialisten, ich habe gestern open suse 9.3 auf meinem XP Rechner installiert. Lief alles wunderbar: 1. Partition auf der 2....