Mein read liest nur max. 4096 Zeichen ein

Dieses Thema im Forum "Shell-Skripte" wurde erstellt von Programmer78, 09.02.2015.

  1. #1 Programmer78, 09.02.2015
    Programmer78

    Programmer78 Foren As

    Dabei seit:
    28.11.2007
    Beiträge:
    92
    Zustimmungen:
    1
    Code:
    #! /bin/bash
    printf "Translator\n\nBitte geben Sie den zu übersetzenden Text ein! Engl->Deutsch\n\n\n"
    read uebersetzen
    #mit Shift Einfügen wird ein Text mit 4200 Zeichen eingefügt
    
    echo $uebersetzen
    
    uebersetzungsroutine() {
    }
    #uebersetzungsroutine
    
    
    #angezeigt werden nur Zeichen 4097-4200
    auf ein cat <<EOF wollte ich im Skript verzichten, da man ja das EndofFile dann bekanntgeben muss.

    Hat jemand Lösungsvorschläge, die längere Texte entgegennehmen, nur mit ENTER am Ende und aus StdIn?

    Vielleicht gibts ja ein cat <<'ENTER' oder ein cat <<'strg + s'

    Danke
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. marce

    marce Kaiser

    Dabei seit:
    01.08.2007
    Beiträge:
    1.053
    Zustimmungen:
    8
    hier tut's wie es soll.

    -> mehr Infos.
     
  4. #3 Gast123, 10.02.2015
    Gast123

    Gast123 Guest

    Man, man, man,
    Code:
    man
    oder besser gesagt
    Code:
    man read
    hätte dir sicher auch weitergeholfen.
    Und dir wäre aufgefallen: Hey, read lässt sich mit dem Parameter -d beutzen.
    Und dann kann man noch sowas wie EOF finden.
    Und schwupps, hat man ein Multiline-read, dass auf [Ctrl]+[D] terminiert. :)
     
  5. #4 Programmer78, 10.02.2015
    Programmer78

    Programmer78 Foren As

    Dabei seit:
    28.11.2007
    Beiträge:
    92
    Zustimmungen:
    1
    Danke für die Info. Irgendwie ist meine Manualseite nicht vollständig. Ich werde mal die Manualseiten im Internet betrachten.


    man read

     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Mein read liest nur max. 4096 Zeichen ein

Die Seite wird geladen...

Mein read liest nur max. 4096 Zeichen ein - Ähnliche Themen

  1. Mein PC-BSD 7 News Thread noch nicht erschienen

    Mein PC-BSD 7 News Thread noch nicht erschienen: Ich habe vor 4 oder 5 Tagen einen Thread im News-Bereich über die Veröffentlichung von PC-BSD 7 geschrieben. Er steht immer noch nicht im News...
  2. mein Thread

    mein Thread: wo is denn mein thread hin, den ich vor einer Stunde erstellt habe???das is ja echt das letzte...hier werden andere Leute dumm angemacht und...
  3. Wie mach meinen SD Cardreader mit Debian bekannt?

    Wie mach meinen SD Cardreader mit Debian bekannt?: Hab an meinem Notebook einen SD-Cardreader. Wie mach ich den denn mit Debian Etch bekannt. Gibt es bestimmte Treiber oder Pakete die Laden muss....
  4. Mein Netzwerk-Thread

    Mein Netzwerk-Thread: Hallo liebe Unix/Linux Gemeinde, vorweg: bitte schlagt mich nicht für diesen Thread :brav: ich habe jedoch absolut keinen Plan von Netzwerken...
  5. Bekomme auf meinen neuen rechner kein(!) Linux zum laufen...[THREAD GETRENNT]

    Bekomme auf meinen neuen rechner kein(!) Linux zum laufen...[THREAD GETRENNT]: Hi, bin etwas frustirert, habe mir vor etwa 1-2 monaten nen neuen rechner gekauft, solangsam packt es mich und ich möchte auf ihm wieder lionux...