mediawiki install problem

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von knuffi, 26.05.2007.

  1. knuffi

    knuffi Mitglied

    Dabei seit:
    09.11.2006
    Beiträge:
    29
    Zustimmungen:
    0
    Ort:
    Rostock
    Hallo,

    ich bin hier langsam am Verzweifeln. Ich versuche die aktuelle mediawiki zu Installieren, scheitere aber schon gleich zu Beginn.

    Es erscheint folgende Meldung:

    Laut phpinfo ist:

    Die Rechte von /var/lib/php5 sind:

    System ist Debian 3.1
    PHP 5.2.x
    Apache 2.0.54
    Confixx 3.2.1

    Ich hoffe es kann mir einer von euch sagen, o hier der Hund Begraben liegt. :)

    LG.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 26.05.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Der Webserver kann nicht in ein Verzeichnis schreiben, das ihm nicht gehört. World-Writeable ist übrigens immer eine schlechte Idee bei Servern. Das erleichtert die Einschleusung von Schadprogrammen.
     
  4. knuffi

    knuffi Mitglied

    Dabei seit:
    09.11.2006
    Beiträge:
    29
    Zustimmungen:
    0
    Ort:
    Rostock
    Hallo,

    es ändert sich aber auch leider nichts, wenn ich dem Webserver die Rechte gebe. Dann sieht es so aus:

    Was meinst du damit?

    Am chmod habe ich nämlich nichts geändert. Das ist noch Standart nach der installation von PHP5.

    LG.
     
  5. #4 serverzeit.de, 26.05.2007
    serverzeit.de

    serverzeit.de Netzwerkarchäologe

    Dabei seit:
    24.05.2007
    Beiträge:
    227
    Zustimmungen:
    0
    Du solltest im temporären Verzeichnis /tmp einen Unterordner für php anlegen. Dieses sollte dann nur für den www-user schreibbar sein, bei dir wohl www-data. Die Befehle dazu:

    mkdir /tmp/php
    chown www-data:www-data /tmp/php
    chmod 700 www-data:www-data

    Dann natürlich den Pfad in der php.ini anpassen. Nach einem apachectl restart und apachectl graceful sollten sie Änderungen gespeichert sein. Das sollte funktionieren.
     
  6. #5 bitmuncher, 26.05.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Meiner Erfahrung nach, muß auch die Gruppe Lese- und Schreibrechte haben. ein 'chmod 700 ...' wird daher vermutlich nicht reichen. Daran hakt es nämlich auch beim aktuellen Verzeichnis. Die Gruppe hat keine Lese-Rechte.

    Mit dem world-writable meine ich, daß die Rechte nicht 'drwx-wx-wt' sondern 'drwxrwx---' sein sollten.
     
  7. #6 knuffi, 26.05.2007
    Zuletzt bearbeitet: 26.05.2007
    knuffi

    knuffi Mitglied

    Dabei seit:
    09.11.2006
    Beiträge:
    29
    Zustimmungen:
    0
    Ort:
    Rostock
    Hallo,


    Danke schonmal für die Hilfe.

    Habe es jetzt so geändert. Gebracht hat es leider nichts. :hilfe2:

    Ausgabe von phpinfo:

    Die Berechtigungen sehen nun so aus:

    LG
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Hallo,

    Wie ändere ich dass das richtig ist?

    OK. Bin davon ausgegangen, dass nach der install mittels apt-get auch die korrekten Rechte gesetzt sind.

    LG.
     
  8. #7 bitmuncher, 26.05.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Lies die Manpage zu chmod, da wird dir ganz genau erklärt, wie man Rechte ändert. Und schau dir mal http://www.linuxfibel.de/access.htm an. Ich hoffe nur, daß dieser Server nicht über das WWW verfügbar sein wird, sondern nur im abgeschlossenen LAN. Bist du überhaupt sicher, daß www-data der richtige User ist. Hast du da mal in der Apache-Konfiguration nachgeschaut?
     
  9. #8 serverzeit.de, 27.05.2007
    serverzeit.de

    serverzeit.de Netzwerkarchäologe

    Dabei seit:
    24.05.2007
    Beiträge:
    227
    Zustimmungen:
    0
    @bitmuncher: Ich kam bisher immer mit 700 aus, aber gut, vielleicht hatte ich auch nur Glück bisher ;-)
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. knuffi

    knuffi Mitglied

    Dabei seit:
    09.11.2006
    Beiträge:
    29
    Zustimmungen:
    0
    Ort:
    Rostock
    Hallo,

    ich leider nicht. Komme einfach nicht weiter. :hilfe2:

    LG.
     
  12. #10 serverzeit.de, 27.05.2007
    serverzeit.de

    serverzeit.de Netzwerkarchäologe

    Dabei seit:
    24.05.2007
    Beiträge:
    227
    Zustimmungen:
    0
    Hast du in der httpd.conf nachgesehen welche Apache-User konfiguriert ist?
     
Thema:

mediawiki install problem

Die Seite wird geladen...

mediawiki install problem - Ähnliche Themen

  1. Installationsproblem mit mediawiki

    Installationsproblem mit mediawiki: Möglich, dass dies hier nicht das richtige Forum für Wikiprobleme ist, aber ich will es trotzdem versuchen. Ich habe mir ein in php geschriebenes...
  2. mediawiki redirect funktioniert nicht mehr richtig

    mediawiki redirect funktioniert nicht mehr richtig: hallo an alle, leider funktioniert meine mediawiki-installation nicht mehr. beim redirect von https://www.host.de/wiki/index.php auf...
  3. Mediawiki

    Mediawiki: Hallo ich habe vor einige Artikel im wikipedia zus chreiben, hab aber keine Lust die Artikel immer onlne zu erarbeiten. Ich suche also...
  4. mediawiki

    mediawiki: Vielleicht ein bisschen Offtopic, aber einen besseren Platz habe ich nicht gefunden: Hat jemand Erfahrung mit dem mediawiki (www.mediawiki.org)...
  5. mediawiki einrichten

    mediawiki einrichten: Moin. Kann mir jemand weiterhelfen ? Ich suche die Option dass bei mediawiki nur registrierte User einen Artikel schreiben und verändern...