[MDK 10.1] kein X beim Booten

Dieses Thema im Forum "KDE" wurde erstellt von Ratatosk, 04.01.2005.

  1. #1 Ratatosk, 04.01.2005
    Ratatosk

    Ratatosk /dev/null

    Dabei seit:
    15.12.2004
    Beiträge:
    76
    Zustimmungen:
    0
    Ort:
    Berlin
    Moin!

    So, nachdem ich mich fast totgegoogelt hab und auch in den FAQs nix wirklich brauchbares gefunden habe mach ichs jetz halt so...

    Seit ich ne neue ISDN-Karte installiert habe bzw. dafür per rpmdrake Software installiert hab (hylafax und sowas) will KDE nimmer beim booten starten. Stattdessen gibts ne Standard-Loginshell, mit startx arbeitet das Teil nach dem Login wieder einwandfrei. Shutdown per KDE-Abmelden-Knopf geht auch nich mehr, der schickt mich lediglich zurück auf die Shell.

    Joah, an sich ja nich das Mörderproblem, bin halt nur ne elendig faule Socke und hätte gern meine Klicki-Bunti-Oberfläche beim Booten und des angenehmere Shutdownen zurück ;)
    Was tun?

    In der inittab steht id:5:initdefault:, sollte also beim Start auch X anwerfen. Falls noch wat an *.conf oder *.log für zur Fehlerbehebung jebraucht wird büdde schreien...

    Gruß & schomma Dank
    Oli
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 manthano, 04.01.2005
    manthano

    manthano Tripel-As

    Dabei seit:
    22.11.2004
    Beiträge:
    175
    Zustimmungen:
    0
    Ort:
    Berlin
    Bist du sicher, dass 5 bei dir das Standard-Runlevel für X ist? Bei Slackware ist's nämlich 4. Ansonsten könntest du auch einfach ein Initskript nur mit einem 'startx' schreiben und es im Runlevel 5 starten lassen. Die Sache mit dem Herunterfahren könntest du ebenfalls mit einem Skript (mit suid-Bit) lösen, das du über's KDE-Menü aufrufen kannst.
     
  4. #3 Ratatosk, 04.01.2005
    Ratatosk

    Ratatosk /dev/null

    Dabei seit:
    15.12.2004
    Beiträge:
    76
    Zustimmungen:
    0
    Ort:
    Berlin
    ui, des ging aber fix :)

    Jep:
    Code:
    # Default runlevel. The runlevels used by Mandrakelinux are:
    #   0 - halt (Do NOT set initdefault to this)
    #   1 - Single user mode
    #   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
    #   3 - Full multiuser mode
    #   4 - unused
    [b]#   5 - X11[/b]
    #   6 - reboot (Do NOT set initdefault to this)
    Öhm, bin n00b: Einfach ins /etc/rc5.d rein?

    Hm, wäre auch ne Idee.

    Hatte ebenn ochmal in dem Kontextmenu von dem Abmeldenknopf gegruschtelt und nen Haken bei "Nach Abmeldung von KDE > Rechner ausschalten" gemacht, ohne Ergebniss; nur ne Warnung ist mir da aufgefallen (in der Shell):

    Code:
    (WW) NV(0): Failed to set up write-combining range (0xd0000000,0x2000000)
    SetClientVersion: 0 8
    waiting for X Server to shut down...
    Böhmische Dörfer...

    Besten Dank!

    Gruß, Oli
     
  5. #4 redlabour, 04.01.2005
    redlabour

    redlabour -

    Dabei seit:
    23.05.2003
    Beiträge:
    4.353
    Zustimmungen:
    0
    Ort:
    Wuppertal, NRW
  6. Xanti

    Xanti Mouse Organist

    Dabei seit:
    05.09.2004
    Beiträge:
    1.855
    Zustimmungen:
    0
    Komisch, bei mir steht

    Code:
    #   9 - Makes you feel high
    in der inittab. Fühl mich aber trotzdem nicht besser ;)

    Spass beiseite. Was Du zitiert hast, ist eine Beschreibung der Runlevel in Deiner inittab, zu erkennen an dem "#" am Zeilenanfang. Damit werden Kommentare gekennzeichnet, welche von Deinem Linuxsystem ignoriert werden.

    Wichtig ist, dass als initdefault 5 eingetragen ist. Bei SuSE sieht das so aus:

    Code:
    id:5:initdefault:
    Gruss, Phorus
     
  7. #6 Ratatosk, 04.01.2005
    Ratatosk

    Ratatosk /dev/null

    Dabei seit:
    15.12.2004
    Beiträge:
    76
    Zustimmungen:
    0
    Ort:
    Berlin
    Hallo zusammen!
    Hm, nen Hardwareproblem schliesse ich einfach mal aus, wie gesagt, mit startx läuft dann ja alles wie geschmiert und bis dato hat die GraKa/der Treiber nie wirklich Probleme gemacht. Ne Kategorie "X.org/XFree" habsch net gefunden (wäre vieleicht ne Idee so eine einzurichten, für Probs die nich am KDE, Gnome oder andren Windowmanagern sondern am XServer liegen (könnten)), also dacht ich diese hier wäre so mit am passendsten...

    Auch nich schlecht, fliecht der denne wech, der Rechner, oder zeicht der denne nur noch so komische Blätter als Hintergrundbild an? ;)

    Aber auch Spaß beiseite:
    Jep, steht da so, eine Zeile weiter, schaut bei MDK genauso aus. Wollte nur des Forum nich mit der kompletten inittab verschandeln, hätte die Zeile vieleicht noch mitquoten sollen...

    Gruß, Oli
     
  8. #7 Lord Kefir, 04.01.2005
    Lord Kefir

    Lord Kefir König

    Dabei seit:
    10.06.2004
    Beiträge:
    944
    Zustimmungen:
    0
    Komisch, dass "start x" funzt... poste doch mal dein rc5.d-Script (oder wie das auch immer bei dir heißt).

    Mfg, Lord Kefir
     
  9. #8 Ratatosk, 04.01.2005
    Ratatosk

    Ratatosk /dev/null

    Dabei seit:
    15.12.2004
    Beiträge:
    76
    Zustimmungen:
    0
    Ort:
    Berlin
    Hallo Lord Kefir,
    welches davon? /etc/rc.d/rc5.d ist bei mir nen verzeichnis mit symlinks auf insgesamt 34 Skripte in /etc/rc.d/init.d/

    Code:
    K59dund@           S11portmap@         S40atd@             S92lisa@
    K59hidd@           S12syslog@          S55ntpd@            S95kheader@
    K59pand@           S13partmon@         S55sshd@            S97hylafax-server@
    S01hotplug@        S14nfslock@         S56rawdevices@      S99local@
    S01udev@           S15cups@            S56xinetd@
    S05harddrake@      S17alsa@            S60nfs@
    S08ipvsadm@        S18sound@           S75keytable@
    S10eftd@           S20xfs@             S85numlock@
    S10network@        S24messagebus@      S90crond@
    S11mysql@          S25netfs@           S91smb@
    Gruß, Oli
     
  10. Xanti

    Xanti Mouse Organist

    Dabei seit:
    05.09.2004
    Beiträge:
    1.855
    Zustimmungen:
    0
    Steht in der inittab irgendetwas über xdm? Wenn ja, bitte posten.
     
  11. #10 Ratatosk, 04.01.2005
    Ratatosk

    Ratatosk /dev/null

    Dabei seit:
    15.12.2004
    Beiträge:
    76
    Zustimmungen:
    0
    Ort:
    Berlin
    nope, kein xdm, inittab hängt als kopie im anhang.

    mfg oli
     

    Anhänge:

  12. #11 manthano, 04.01.2005
    manthano

    manthano Tripel-As

    Dabei seit:
    22.11.2004
    Beiträge:
    175
    Zustimmungen:
    0
    Ort:
    Berlin
    Was mich ein bisschen wundert sind folgende Zeilen:
    Eigentlich wird damit die Datei /etc/rc.d/rc aufgerufen und die Zahl als Parameter übergeben - aber diese Datei existiert zumindest bei mir nicht (falls es sie bei dir gibt, brauchst du gar nicht weiterzulesen).

    Guck mal, ob Dateien wie "rc4", "rc.4", etc. im Verzeichnis /etc/rc.d existieren. Die Zeilen in der inittab-Datei dann einfach entsprechend ändern (auf alle Fälle die Leerzeichen wegnehmen).
     
  13. #12 Ratatosk, 04.01.2005
    Ratatosk

    Ratatosk /dev/null

    Dabei seit:
    15.12.2004
    Beiträge:
    76
    Zustimmungen:
    0
    Ort:
    Berlin
    Gibts, ist ein Shellskript, siehe Anhang. Scheint als würde das den Runlevel "manuell" setzen wenn der in der inittab nicht oder fehlerhaft gesetzt ist.

    Dateien nicht, aber Verzeichnisse; rc0.d bis rc6.d.

    Gruß, Oli
     

    Anhänge:

    • rc.txt
      Dateigröße:
      3,6 KB
      Aufrufe:
      2
  14. #13 manthano, 05.01.2005
    manthano

    manthano Tripel-As

    Dabei seit:
    22.11.2004
    Beiträge:
    175
    Zustimmungen:
    0
    Ort:
    Berlin
    Dann würd ich einfach ein Skript mit 'startx' in /etc/rc.d/rc5.d speichern, ausführbar machen (chmod u+x <datei>) und dann müsste X beim nächsten Neustart automatisch starten.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Ratatosk, 05.01.2005
    Ratatosk

    Ratatosk /dev/null

    Dabei seit:
    15.12.2004
    Beiträge:
    76
    Zustimmungen:
    0
    Ort:
    Berlin
    Okay, werd ich gleich mal testen - muchas gracias!

    Gruß, Oli
     
  17. #15 Ratatosk, 05.01.2005
    Zuletzt bearbeitet: 05.01.2005
    Ratatosk

    Ratatosk /dev/null

    Dabei seit:
    15.12.2004
    Beiträge:
    76
    Zustimmungen:
    0
    Ort:
    Berlin
    Joah....
    shell > cd /etc/rc.d/rc5.d > su <passwort> > vi xstart.sh > inhalt:
    Code:
    #!/bin/bash
    startx
    ausführbar gemacht mit "chmod u+x xstart.sh",
    reboot - und kein kde, kein x.... ;(

    hab noch n bisken gegoogelt und das da gefunden:
    Code:
     case `/usr/bin/tty` in /dev/tty[0-9]*)
       # ist X schon gestartet?
       PID_X=$(/sbin/pidof xinit)
       if [ -z "$PID_X" ]; then
          startx
       fi
    esac
    Soll in die .bash_profile rein (naja, siehe Link halt...), werdsch ma antesten und berichten.... Wenn des auch nich klappt... hmm.... entweder leb ich dann damit, daß des nich will oder setz des Sch**ßsystem nomma auf (wie ich mich kenne eher ersteres...) *grmpf*

    Gruß, Oli

    // Edit:
    Funzt, X und KDE startet beim Login... Hat zwar net so geklappt, aber trotzdem besten Dank für die ganzen Tips!

    mfg Oli
     
Thema:

[MDK 10.1] kein X beim Booten

Die Seite wird geladen...

[MDK 10.1] kein X beim Booten - Ähnliche Themen

  1. [MDK 10.0] KDE Autostart Befehl hinzufügen

    [MDK 10.0] KDE Autostart Befehl hinzufügen: Hi! Mal eine frage. Kann man Befehl hinzufügen die beim start von KDE automatisch starten. Ich möchte das Karamba 2 themen automatisch...
  2. Network Device [RTL-8139C | Chip 8101] Problem

    Network Device [RTL-8139C | Chip 8101] Problem: Hallo, ich hab mir nen MAXDATA ECO 4200X Notebook gekauft. Vorab hab ich alle technischen Details (welche ich finden konnte) abgecheckt - mit...