mcafee uvscan libstdc++.so.2.8

Dieses Thema im Forum "Anwendungen" wurde erstellt von paaaaede, 15.12.2004.

  1. #1 paaaaede, 15.12.2004
    paaaaede

    paaaaede Jungspund

    Dabei seit:
    13.12.2004
    Beiträge:
    22
    Zustimmungen:
    0
    Ort:
    CH
    guten morgen

    ich habe den mcafee antivirus installiert und wenn ich den uvscan starten möchte kommt folgende fehler message:

    uvscan: error while loading shared libraries: libstdc++.so.2.8: cannot open shared object file: No such file or directory

    danach habe ich mir das rpm (libstdc++-2.95.1_2.10.0-3.i386.rpm)
    heruntergeladen und wollte es installieren.

    Folgende rückgabe habe ich bekommen:


    package libstdc++-3.2.2-5 (which is newer than libstdc++-2.95.1_2.10.0-3) is already installed



    das packet habe ich von http://www.dlhoffman.com/publiclibrary/RPM/contrib/libc6/i386/libstdc++-2.95.1_2.10.0-3.i386.html
    heruntergeladen

    welches diese shared libaries unterstützt:

    Provides
    libstdc++
    libstdc++
    libg++.so.2.7.2
    libstdc++-libc6.1-1.so.2
    libstdc++-libc6.1-2.so.3
    libstdc++.so.2.7.2
    libstdc++.so.2.8

    suche ich mit dem befehl

    find / -name libstdc++.so.2.8

    findet er die libarie nicht.

    was soll ich tun ; ) ?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 paaaaede, 15.12.2004
    paaaaede

    paaaaede Jungspund

    Dabei seit:
    13.12.2004
    Beiträge:
    22
    Zustimmungen:
    0
    Ort:
    CH
    habe jetzt schnell eine neuinstallation von meinem redhat linux gemacht und das lib libstdc++ ist drauf....

    ich weiss nicht mehr weiter
     
  4. khs

    khs Routinier

    Dabei seit:
    19.08.2004
    Beiträge:
    408
    Zustimmungen:
    0
    Woran hapert es denn jetzt, wenn die gesuchte lib drauf ist?

    -khs
     
  5. #4 redlabour, 15.12.2004
    redlabour

    redlabour -

    Dabei seit:
    23.05.2003
    Beiträge:
    4.353
    Zustimmungen:
    0
    Ort:
    Wuppertal, NRW
    Steht doch oben - es will Version libstdc++.so.2.8 - aber es ist libstdc++-3.2.2-5 drauf. Benutzt Du die neueste Version von mcafee antivirus ?
     
  6. #5 Havoc][, 15.12.2004
    Havoc][

    Havoc][ Debian && Gentoo'ler

    Dabei seit:
    27.07.2003
    Beiträge:
    898
    Zustimmungen:
    0
    Ort:
    GER/BaWü/Karlsruhe (bzw. GER/NRW/Siegen)
    hm, sucht mcafee vielleicht nur nach "libstdc++"? Welche vielleicht keinen link auf .2.8 bzw 3.2.2.-5 hat?

    Havoc][
     
  7. #6 paaaaede, 15.12.2004
    paaaaede

    paaaaede Jungspund

    Dabei seit:
    13.12.2004
    Beiträge:
    22
    Zustimmungen:
    0
    Ort:
    CH

    auf was soll ich jetzt einen link machen ?? :hilfe2:

    von mcaffee ist die neuste version installiert: vlnx440l


    danke & gruss patrik
     
  8. #7 paaaaede, 15.12.2004
    paaaaede

    paaaaede Jungspund

    Dabei seit:
    13.12.2004
    Beiträge:
    22
    Zustimmungen:
    0
    Ort:
    CH
    Ich habe die libstdc++ gesucht:

    [root@cachi local]# find / -name libstdc++*
    /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/libstdc++.a
    /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/libstdc++.so
    /usr/lib/libstdc++.so.5.0.3
    /usr/lib/libstdc++.so.5
    /usr/share/doc/libstdc++-devel-3.2.2
    /usr/share/doc/libstdc++-devel-3.2.2/html/17_intro/libstdc++-assign.txt


    fehlermeldung beim starten des scanners:

    ./uvscan
    ./uvscan: error while loading shared libraries: libstdc++.so.2.8: cannot open shared object file: No such file or directory


    ich habe jetzt einen symbolischen link erstellt

    libstdc++.so.2.8 -> /usr/lib/libstdc++.so.5

    ist das schlau ?

    jetzt bringt der scanner einfach eine andere meldung:

    ./uvscan: relocation error: ./uvscan: undefined symbol: __eh_pc


    ??? ich seh da nicht mehr durch
     
  9. #8 redlabour, 15.12.2004
    redlabour

    redlabour -

    Dabei seit:
    23.05.2003
    Beiträge:
    4.353
    Zustimmungen:
    0
    Ort:
    Wuppertal, NRW
    Nö denn nun sucht er eine Befehlszeile die es in dieser Version nicht gibt.
     
  10. #9 paaaaede, 15.12.2004
    paaaaede

    paaaaede Jungspund

    Dabei seit:
    13.12.2004
    Beiträge:
    22
    Zustimmungen:
    0
    Ort:
    CH
    das heisst ich soll sie wieder unlinken ? und wie soll ich das ding jetzt zum laufen bringen ?

    gruss & danke patrik
     
  11. #10 redlabour, 15.12.2004
    redlabour

    redlabour -

    Dabei seit:
    23.05.2003
    Beiträge:
    4.353
    Zustimmungen:
    0
    Ort:
    Wuppertal, NRW
    Indem Du die alte Version installierst und die neuere deinstallierst. Welche Distri ?
     
  12. #11 paaaaede, 15.12.2004
    paaaaede

    paaaaede Jungspund

    Dabei seit:
    13.12.2004
    Beiträge:
    22
    Zustimmungen:
    0
    Ort:
    CH
    RedHat 9 habe ich im einsatz... ich hoffe ich bekomme noch irgendwo eine alter version vom mc afee
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. #12 paaaaede, 15.12.2004
    paaaaede

    paaaaede Jungspund

    Dabei seit:
    13.12.2004
    Beiträge:
    22
    Zustimmungen:
    0
    Ort:
    CH
    so ich habe jetzt die alte version des mcafee von einem alten system wegkopieren können und installiert funktioniert perfekt... ich frage mich schon warum die eine neue version "basteln" die nicht läuft.... ich habe ja eine neuere version des libstdc++ als er verlangt.... ?
     
  15. khs

    khs Routinier

    Dabei seit:
    19.08.2004
    Beiträge:
    408
    Zustimmungen:
    0
    Der will ne 2.8 und du hast ne 3.x. Da gabs sicherlich irgendwas ganz entscheidend neues in der Zwischenzeit, was schaedlich fuer die Binaerkompatibilitaet war...
    Zum Glueck gibt es compat(ibility)-Pakete fuer Redhat. Such mal mit einer der RPM-Suchmaschinen wie rpmfind.net oder wftp.tu-chemnitz.de. Zumindest die tu-chemnitz kennt da nen Stapel compat-libstdc++-2.96 - Pakete. Versuch mal, eins davon zu installieren. Und eventuell noch den 2.8-Link anzulegen.

    -khs, daumendrueckend
     
Thema:

mcafee uvscan libstdc++.so.2.8

Die Seite wird geladen...

mcafee uvscan libstdc++.so.2.8 - Ähnliche Themen

  1. McAfee Virtual Technician 6.3.0.1911 Code Execution

    McAfee Virtual Technician 6.3.0.1911 Code Execution: McAfee Virtual Technician version 6.3.0.1911 suffers from a MVT.MVTControl.6300 GetObject() active-x control security bypass remote code execution...
  2. McAfee Web Gateway And Squid Proxy 3.1.19 Bypass

    McAfee Web Gateway And Squid Proxy 3.1.19 Bypass: McAfee Web Gateway and Squid Proxy version 3.1.19 suffers from a bypass vulnerability due to putting trust in Host headers. Proof of concept tool...