Login (10sec timeout) SSH

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von cami, 17.03.2011.

  1. cami

    cami Jungspund

    Dabei seit:
    17.03.2011
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo,

    ich habe eine CentOS 5.5 Root-Server den ich per SSH verwalte. Nun habe ich folgendes Problem: Wenn ich mich mit den Server per SSH verbinde, dann benötigt er ~10sec um mir meine Shell aufzumachen. Es ist egal ob ich den Login per Username/pwd oder per SSH-Key mache, 10sec Wartezeit. Es ist einfach nervig und kostet nur Zeit.
    Nun hab ich google schon bemüht und meine sshd_config angepasst und "UseDNS no" eingetragen, SSH restartet, etc. Keine Verbesserung.
    Die Namensauflösung an sich läuft und auch IPs per nslookup abfragen läuft.

    Also für mich sieht das wie ein DNS-Problem aus, aber die Namensauflösung per nslookup läuft und auch die reverse Auflösung via ip und nslookup liefert die richtigen Ergebnisse in einer normalen Geschwindigkeit. Ich bin ziemlich ratlos woran es noch liegen kann.

    Gruß cami

     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Verbinde dich doch mal per ssh und setzt noch -vv (very verbose), da sollte drin stehen, was er in den 10 Sekunden macht. (Zur Not kann man sogar noch ein weiteres v dranhängen, dann wirds aber spammy.)
     
  4. #3 cami, 17.03.2011
    Zuletzt bearbeitet: 17.03.2011
    cami

    cami Jungspund

    Dabei seit:
    17.03.2011
    Beiträge:
    10
    Zustimmungen:
    0
    Hmmm, also ich denke dieser Teil hier ist Interessant:

    Code:
    debug1: Authentications that can continue: publickey,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-with-mic
    debug1: An invalid name was supplied
    Cannot determine realm for numeric host address
    
    debug1: An invalid name was supplied
    Cannot determine realm for numeric host address
    
    debug1: An invalid name was supplied
    
    
    debug1: Next authentication method: publickey
    
    Ok, nicht der sshd-Server war schuld, sondern mein Client hier, ich hab in der lokalen ssh_config: GSSAPIAuthentication no eingetragen und nun klappt der Login sehr schnell.

    thx
     
  5. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Hm magst du mal das ganze Verbindungs-Geraffel posten/pastebinnen? Natürlich annonymisiert.
     
  6. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Kannst Du nicht ueberpruefen, ob es an DNS liegt, indem Du mal die IP-Adresse benutzt zum Login?
     
  7. cami

    cami Jungspund

    Dabei seit:
    17.03.2011
    Beiträge:
    10
    Zustimmungen:
    0
    GSSAPIAuthentication yes
    Code:
    user@laptop:~$ ssh -v server
    OpenSSH_5.3p1 Debian-3ubuntu5, OpenSSL 0.9.8k 25 Mar 2009
    debug1: Reading configuration data /home/user/.ssh/config
    debug1: Applying options for index2
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to x.x.x.x [x.x.x.x] port 22.
    debug1: Connection established.
    debug1: identity file /home/user/.ssh/identity type -1
    debug1: identity file /home/user/.ssh/id_rsa type -1
    debug1: identity file /home/suer/.ssh/id_dsa type 2
    debug1: Checking blacklist file /usr/share/ssh/blacklist.DSA-1024
    debug1: Checking blacklist file /etc/ssh/blacklist.DSA-1024
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
    debug1: match: OpenSSH_4.3 pat OpenSSH_4*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3p1 Debian-3ubuntu5
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host 'x.x.x.x' is known and matches the RSA host key.
    debug1: Found key in /home/user/.ssh/known_hosts:49
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-with-mic
    debug1: An invalid name was supplied
    Cannot determine realm for numeric host address
    
    debug1: An invalid name was supplied
    Cannot determine realm for numeric host address
    
    debug1: An invalid name was supplied
    
    
    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/user/.ssh/id_dsa
    debug1: Server accepts key: pkalg ssh-dss blen 434
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = de_DE.utf8
    Last login: Thu Mar 17 11:16:50 2011 from x.x.x.x
    
    GSSAPIAuthentication no
    Code:
    user@laptop:~$ ssh -v index2
    OpenSSH_5.3p1 Debian-3ubuntu5, OpenSSL 0.9.8k 25 Mar 2009
    debug1: Reading configuration data /home/user/.ssh/config
    debug1: Applying options for index2
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to x.x.x.x [x.x.x.x] port 22.
    debug1: Connection established.
    debug1: identity file /home/user/.ssh/identity type -1
    debug1: identity file /home/user/.ssh/id_rsa type -1
    debug1: identity file /home/user/.ssh/id_dsa type 2
    debug1: Checking blacklist file /usr/share/ssh/blacklist.DSA-1024
    debug1: Checking blacklist file /etc/ssh/blacklist.DSA-1024
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
    debug1: match: OpenSSH_4.3 pat OpenSSH_4*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3p1 Debian-3ubuntu5
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host 'x.x.x.x' is known and matches the RSA host key.
    debug1: Found key in /home/user/.ssh/known_hosts:49
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,gssapi-with-mic,password
    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/user/.ssh/id_dsa
    debug1: Server accepts key: pkalg ssh-dss blen 434
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = de_DE.utf8
    Last login: Thu Mar 17 13:04:37 2011 from x.x.x.x
    
     
  8. #7 cami, 17.03.2011
    Zuletzt bearbeitet: 17.03.2011
    cami

    cami Jungspund

    Dabei seit:
    17.03.2011
    Beiträge:
    10
    Zustimmungen:
    0
    @rikola es machte keinen Unterschied ob ich die IP oder den Namen oder nen Alias benutzt habe.
     
  9. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Die anderen Beitraege sind mir wohl dazwischen geraten, aus denen ist das ja auch ersichtlich. Ist Dein Problem denn jetzt geloest?
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. cami

    cami Jungspund

    Dabei seit:
    17.03.2011
    Beiträge:
    10
    Zustimmungen:
    0
    Ja, ist bestens gelöst. Danke
     
  12. #10 saeckereier, 18.03.2011
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Naja, aber die Methoden verhandeln beide, eigentlich müsstest dus auch auf dem Server ausschalten können..
     
Thema:

Login (10sec timeout) SSH

Die Seite wird geladen...

Login (10sec timeout) SSH - Ähnliche Themen

  1. Solaris Login mit Active Directory User

    Solaris Login mit Active Directory User: Hallo zusammen, Ich arbeite daran unsere Solaris Systeme ans AD anzubinden. Teilweise ist mir das schon gelungen, teilweise stehe ich aber auch...
  2. Frage zu QNX - habe login nie gefunden

    Frage zu QNX - habe login nie gefunden: ′
  3. SSH Login nur mit einer bestimmten IP die in einer Textdatei gespeichert wird

    SSH Login nur mit einer bestimmten IP die in einer Textdatei gespeichert wird: Hallo Ich bin andauernd Opfer einer Brute Force Attacke. Die IPs die fehlerhafte Logins produzieren werden nach dem 3ten Versuch gesperrt. Aber...
  4. Root Login nach installation ohne Desktop Environment

    Root Login nach installation ohne Desktop Environment: Hey, Ich habe mir gerade Linux Debian 8 auf meinen alten PC gezogen und bei Desktop Environment das Sternchen rausgenommen, da das ja bei nem...
  5. Auto-Login auf Slackware

    Auto-Login auf Slackware: Hi, Ist gegen ein Auto-login auf einem nur privat zugänglichem Rechner (SL-13.37) grundsätzlich etwas einzuwenden? Und (falls nicht), wie am...