Linux-Windows-Netwerk-Problem

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von MrSing, 12.01.2007.

  1. MrSing

    MrSing Jungspund

    Dabei seit:
    12.01.2007
    Beiträge:
    12
    Zustimmungen:
    0
    Ich habe eine Frage zu, wie solls anders sein, einer Verbindung von Linux zu Windows.

    Ich benutze Windows XP,SP1 und OpenSuse 10.2
    Ich habe Samba komplett eingerichtet; Unter smb:/ kann ich auch den Windows-Rechner und seine Freigaben sehen. Andersrum genauso; doch:
    sobald ich auf eine Freigabe klicke muss ich Benutzer und Passwort eingeben. In beide Richtungen.

    Könnt ihr mir helfen?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 pitschi5, 12.01.2007
    pitschi5

    pitschi5 ***BOFH

    Dabei seit:
    30.04.2005
    Beiträge:
    81
    Zustimmungen:
    0
    Ort:
    Wasserliesch, Germany
    du musst die authentifizieren! Wo liegt das Problem?

    so long...
     
  4. MrSing

    MrSing Jungspund

    Dabei seit:
    12.01.2007
    Beiträge:
    12
    Zustimmungen:
    0
    Das Problem ist, dass ich nciht weiß, mit welchem Benutzernamen ich mcih anmelden soll.
    Wenn cih dem Vom Linux-Rechner nehme, dann geht es genausowenig wie bei dem vom Windows Rechner
     
  5. #4 pitschi5, 12.01.2007
    pitschi5

    pitschi5 ***BOFH

    Dabei seit:
    30.04.2005
    Beiträge:
    81
    Zustimmungen:
    0
    Ort:
    Wasserliesch, Germany
    Um auf die SAMBA-Freigaben zugreifen zu können, musst du auch SAMBA-User angelegt haben und diese müssen Zugriff auf die Sharings haben.

    smbpasswd -a username --> anschließend Passwort vergeben und die User mit valid users = xxx und
    in deine smb.conf einfügen.

    Auf der Windowsseite musst du mal den Reiter Security überprüfen, wer alles Zugriff auf eine Freigabe hat und guck dir auch mal die Rechte der Freigabe selbst an. Aber das ist Stoff für ein anderes Forum.

    fyi: :rtfm:

    so long...
     
  6. MrSing

    MrSing Jungspund

    Dabei seit:
    12.01.2007
    Beiträge:
    12
    Zustimmungen:
    0
    Erstmal riesen Dank, für deine schnellen Antworten!

    Danke für diesen Tip, das habe ich gar nciht gewusst.

    Hm, den Reiter Security finde ich nirgens.
    kannst du mir genauer sagen, wo der ist?

    Gruß, MrSing
     
  7. #6 ElektroPunk, 12.01.2007
    ElektroPunk

    ElektroPunk INSUBORDINANT

    Dabei seit:
    06.07.2006
    Beiträge:
    139
    Zustimmungen:
    0
    Ort:
    Konstanz
    Heisst nicht Security sondern Freigabe und Sicherheit oder Berechtigungen meine ich.
     
  8. MrSing

    MrSing Jungspund

    Dabei seit:
    12.01.2007
    Beiträge:
    12
    Zustimmungen:
    0
    In welchem Fenster/Dialog finde ich das denn?
     
  9. #8 pitschi5, 12.01.2007
    pitschi5

    pitschi5 ***BOFH

    Dabei seit:
    30.04.2005
    Beiträge:
    81
    Zustimmungen:
    0
    Ort:
    Wasserliesch, Germany
    Hi,
    du musst erstmal in die Ordneroptionen gehen und dann die Option
    "Einfache Dateifreigabe verwenden (Empfohlen)" deaktivieren, anschließend hast du dann den Reiter "Sicherheit".

    Kleiner TIP: Samba 3 für Unix/Linux-Administratoren vom dpunkt.verlag --> sehr gute Erklärungen.

    so long...
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 MrSing, 12.01.2007
    Zuletzt bearbeitet: 12.01.2007
    MrSing

    MrSing Jungspund

    Dabei seit:
    12.01.2007
    Beiträge:
    12
    Zustimmungen:
    0
    Jo, das Buch Hab ich sogar ISBN 3-89864-193-7
    Ist echt gut, aber ich fürchte ncoh nen bisschen zu hoch für mcih. Werde ich mcih in nem halben Jahr dran wagen. Ich bin erst seid 1/4 Jahr auf Linux umgestiegen ...

    Danke für den Tip wegen der erinfachen Dateifreigabe ...
    ich werde es mal probieren ...

    PS: wo habe ich dann den Reiter?
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Schon da haperts ...
    Fehlermeldung:

    Failed to modify password entry for user Admin
     
  12. #10 pitschi5, 13.01.2007
    pitschi5

    pitschi5 ***BOFH

    Dabei seit:
    30.04.2005
    Beiträge:
    81
    Zustimmungen:
    0
    Ort:
    Wasserliesch, Germany
    Du musst zuerst die User auf der Linux-Ebene anlegen.

    1. Schritt: useradd -g users -s /bin/false -d /home/username username
    2. Schritt: smbpasswd -a username
    3. Schritt: smbpasswd -e username

    Damit solltest du einen SAMBA-User haben, mit dem du dich anmelden kannst.
    Wenn das nicht geht, dann wäre vielleicht nicht schlecht, wenn du deine smb.conf mal posten würdest.

    so long....
     
Thema:

Linux-Windows-Netwerk-Problem