Linux kann keine Umlaute in Dateinamen lesen

Dieses Thema im Forum "Linux OS" wurde erstellt von chv, 16.09.2008.

  1. chv

    chv Jungspund

    Dabei seit:
    28.01.2008
    Beiträge:
    14
    Zustimmungen:
    0
    Moin :)
    Ich habe hier ein großes Problem. Meine beiden Linux-Systeme (einmal Kubuntu 8.10 "Hardy" KDE4 - leider noch - und Fedora 9 mit KDE4-Desktop) können seltsamerweise keine Umlaute in Dateinamen lesen, wenn die Datei auf einer Festplatte liegt, die nicht mit ext3 formatiert ist. Weder funktioniert es von einer NTFS-Festplatte meines Laptops, auf die ich via smb zugreife, noch bei meiner exterenen USB Festplatte, welche ich mit FAT32 formatiert habe.
    Das Schreiben ist hingegen kein Problem - Dateien wie "äöü.php" oder Ordner wie "äöü" kann ich auf beiden Platten problemlos erstellen und auch anschließend lesen. Bloß mit den Ordnern, die ich von Windows aus erstellt habe funktioniert es nicht.
    Ich habe leider keine Ahnung woran es liegen könnte, denn das Charset müsste ja richtig eingestellt sein - schließlich kann ich Dateinamen mit Umlauten ja auch schreiben.

    Ich weiß, man sollte eigentlich generell keine Umlaute in Dateinamen verwenden, aber leider wurden diese Dateien und Verzeichnisse automatisch angelegt, weil die meisten Musikverwaltungsprogramme für eine Band wie "Die Ärzte" nun mal einen gleichnamigen Ordner anlegen und den Namen nicht zu "Die Aerzte" machen. Bei den Dateinamen ist es eben genauso.

    Vielen Dank schon mal im Vorraus.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 saeckereier, 16.09.2008
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Wie sehen denn die angelegten Dateien nachher unter Windows aus?
     
  4. #3 Wolfgang, 16.09.2008
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Du suchst die richtige Mountoption.
    Für NTFS siehe nls...
     
  5. chv

    chv Jungspund

    Dabei seit:
    28.01.2008
    Beiträge:
    14
    Zustimmungen:
    0
    Ich bin zwar eigentlich kein absoluter Vollnoob, habe mich aber leider nie mit manuellem Mounten auseinander gesetzt.
    Was genau soll ich nun also machen?

    Wie ich gerade festgestellt habe, kann ich die Dateien auch nur auf der FAT32-Platte richtig anlegen - auf der NTFS HDD, auf die ich via Netzwerk zugreife, kann ich sie nicht anlegen bzw. sie haben das selbe Problem, wie die bereits vorhandenen.
    Die angelegten Dateien werden allerdings bei NTFS auch mit Windows falsch angezeigt - statt den Umlauten besteht der Dateiname unter Windows nur aus Rechtecken, die zeigen, dass das Zeichen nicht existiert.:think:
     
  6. #5 saeckereier, 18.09.2008
    Zuletzt bearbeitet: 18.09.2008
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    man mount -> Dann nach ntfs suche (durch Eingabe von / kommst du in den Suchmodus)
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Genau das ist übrigens dein Problem. GGf. musst du die Option nls= beim Mounten mitgeben und da einfach mal utf8 oder iso-8859-14 probieren. Ich weiß leider nicht, welches Encoding Windows benutzt..
     
  7. #6 chaotic, 18.09.2008
    chaotic

    chaotic Foren As

    Dabei seit:
    26.08.2004
    Beiträge:
    94
    Zustimmungen:
    0
    Ort:
    Erding
    Windows benutzt so weit ich weiß nicht UTF8 als Encoding.
    Ich würde eher das ISO-8859-14 probieren.

    Windows 2000 jedenfalls hat nicht UTF8 als Encoding benutzt, das hab ich durch Ausprobieren rausbekommen.
     
  8. c0re

    c0re Debian Guy

    Dabei seit:
    09.02.2008
    Beiträge:
    79
    Zustimmungen:
    0
    Ort:
    Köln
  9. chv

    chv Jungspund

    Dabei seit:
    28.01.2008
    Beiträge:
    14
    Zustimmungen:
    0
    So habe gerade mal getestet, ob es beim manuellen Mounten mit der FAT32-Platte geht und da hat
    Code:
    # mount -t vfat -o utf8 /dev/sdc1 /media/USBHDD
    problemlos funktioniert.
    Denke mal, das Problem hat sich erledigt - werde dann nachher oder morgen noch mal testen, ob es bei NTFS jetzt auch geht, aber die Option
    Code:
    -o nls=utf8
    sollte wohl weiterhelfen.

    Kann also geschlossen werden. ;)

    @chaotic: Vista verwendet aber UTF-8.
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 chaotic, 19.09.2008
    chaotic

    chaotic Foren As

    Dabei seit:
    26.08.2004
    Beiträge:
    94
    Zustimmungen:
    0
    Ort:
    Erding
    @chv: mit Vista hab ich mich nie genauer beschäftigt, danke für die Info. Ich hatte zu Hause nur Windows 2000, und da hatte ich auch mal die Probleme mit dem Dateinamen weil Linux UTF-8 als Encoding hatte und Win2000 eben nicht.
     
  12. Gast1

    Gast1 Guest

    Arrrrrrrrrr! Ihr Landratten!

    Also der Vergleich Windows 2000 / Vista hinkt ja wie Käpt'n Rotbart mit seinen beiden Holzbeinen.

    Arrrr!

    Aber schön zu sehen, daß sich seit Arrrrrsta la Vistarrrr auch so langsam bei MS herumgesprochen hat, was UTF-8 ist und welche Vorteile es hat, sonst müsste man diesen bebrillten Stockfisch Gates und den glatzköpfigen Pottwal Ballmer über die Planke zu den Haien schicken.

    Arrr, genug Süßwassermatrosengeschwätz, und nun schrubbt die Planken bis sie glänzen, oder ich lasse euch drei mal Kiel holen.

    Arrrrrr,

    RM
     
Thema:

Linux kann keine Umlaute in Dateinamen lesen

Die Seite wird geladen...

Linux kann keine Umlaute in Dateinamen lesen - Ähnliche Themen

  1. Linux Foundation gibt Gründung des Open Mainframe Project bekannt

    Linux Foundation gibt Gründung des Open Mainframe Project bekannt: Das jetzt auf der LinuxCon in Seattle vorgestellte »Open Mainframe Project« soll helfen, Linux auf Mainframes weiter zu etablieren und eine...
  2. Linux Foundation gibt die Gründung des Open Mainframe Project bekannt

    Linux Foundation gibt die Gründung des Open Mainframe Project bekannt: Das jetzt auf der LinuxCon in Seattle vorgestellte »Open Mainframe Project« soll helfen, Linux auf Mainframes weiter zu etablieren und eine...
  3. Welche linux-Distro kann man auf ein mac-book-pro aufspielen?

    Welche linux-Distro kann man auf ein mac-book-pro aufspielen?: Ich würde gerne linux auf eine Partition meines Mac-Book-Pros aufspielen. Ubuntu fragt bei der Installation nicht nach einem root-pw, will es aber...
  4. UEFI-Boot mit Linux kann Samsung-Notebooks unbrauchbar machen

    UEFI-Boot mit Linux kann Samsung-Notebooks unbrauchbar machen: Mehrere Samsung-Notebooks sind von einem BIOS-Fehler betroffen, der bewirkt, dass die Geräte schon nach einmaligem Booten eines Linux-Systems über...
  5. Install wer kann mir das bitte erklären unter Linux

    Install wer kann mir das bitte erklären unter Linux: Bin immer noch auf Kriegsfuss mit dem Neuinstallieren von Programmen. sudo apt-get install audacity und wenn das klappt, dann ist es ok....