Linux ignoriert smb.conf settings

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Iceman75, 27.11.2007.

  1. #1 Iceman75, 27.11.2007
    Iceman75

    Iceman75 Mitglied

    Dabei seit:
    19.04.2007
    Beiträge:
    26
    Zustimmungen:
    0
    Hi!

    Ich beatel da grad ein meiner Suse 10.2 herum (mit KDE Desktop) und wollt samba ein wenig anpassen. Die graphische Benutzeroberfläche bietet mir da zu wenig und ich hab die smb.conf per hand angepasst.
    Jedoch ist es egal, welche Einstellungen ich vornehme, Linux (oder Win XP?) ignoriert die einstellungen.
    Irgendeine Idee, was ich da machen könnte?
    Oder ist meine Denkweise falsch?
    z.B.:
    [global]
    server string = %h
    sollte doch im windows Explorer was anderes anzeigen als
    server string = %h server (Samba %v)

    Oder lieg ich da falsch?

    lg
    Ice
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    Liegst du glaub richtig.
    Aber merkt sich der Win-Explorer nicht die Netzwerknamen ne ganze Weile, bis er die irgendwann mal aktualisiert?
     
  4. #3 Iceman75, 28.11.2007
    Iceman75

    Iceman75 Mitglied

    Dabei seit:
    19.04.2007
    Beiträge:
    26
    Zustimmungen:
    0
    Ok, alles klar - danke.

    Nachdem ich auf 10.3 upgedated hab (hätt ich sowieso gemacht) und meine XP-Maschine ein paar mal rauf und runter gefahren hab, hat es auch gepaßt.
    der beschreibene Effekt war und ist leider nicht das einzige Problem - ich hatte ihn nur als Beispiel angeführt, weil ich dachte, daß im Linux irgendwas verstellt war. Auf den Namenscache im Windows hatte ich vergessen...

    Wie auch immer... ein anderes Problem besteht weiter:
    ich stell die smb.conf folgenermaßen ein:
    (ist nur eine Minimalkonfiguration, aber zum Testen muß das reichen)

    [global]
    workgroup = WORKGROUP
    server string = %h server
    security = user
    bind interfaces only = true
    interfaces = eth0 192.168.1.100 lo 127.0.0.1
    encrypt passwords = true
    map to guest = never
    log file = /var/log/samba/log.%m
    max log size = 1000
    domain logons = No
    domain master = No

    [filesrv]
    comment = Linux Server Daten
    path = /filesrv
    writable = yes
    browseable = yes
    public = no
    valid users = christian
    guest ok = no

    Der user "christian" existiert, Samba kennt ihn auch.
    Wenn ich mich von der XP Maschine jetzt hin verbinde, kann ich nur lesen,... aber es kommt nie eine Paßwortabfrage - egal von welcher Maschine und mit welchem Login ich arbeite - ich darf immer nur lesen - von schreiben keine Rede.

    Wenn ich umgekehrt dem Directory "filesrv" auf Dateisystemebene Schreibrechte für eine Gruppe gebe, wo der user christian drinnen ist, dann darf ich plötzlich alles (schreiben, löschen,...) - ebenfalls egal, mit welchem (Windows) user ich mich hin verbinde. PW - Abfrage kommt auch nicht.

    Wo liegt mein Denk- bzw Konfigurationsfehler?

    lg
    Christian
     
  5. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    hm, setzt vielleicht mal noch ein
    write list = christian
    mit rein? Obwohls so eigentlich meiner Meinung nach schon auch passen sollte (bin aber net wirklich so der smb.conf-crack :) ). Daheim hab ich aber zum Teil trotz writable die write list mit drin, und da kann ich (bzw. der user in der write list, und sonst keiner) schreiben....

    Ich nehm übrigens swat zum Einrichten her... bietet mehr wie (Ubuntu)GUI und is noch a bissl komfortabler wie direkt in die smb.conf schreiben
     
  6. #5 Iceman75, 29.11.2007
    Iceman75

    Iceman75 Mitglied

    Dabei seit:
    19.04.2007
    Beiträge:
    26
    Zustimmungen:
    0
    Hi!
    Danke mal... hab ich probiert - hilft aber nichts - die Schreibgenhmigung steht und fällt mit den lokalen Ordnereinstellungen. Wenn auf /filesrv die lokalen settings auf "read only" stehen, kann ich im smb.conf schreiben was ich will - das wird ignoriert.
    Umgekehrt: wenn ich die lokalen Einstellungen auf "read und write" setze, dann kann ich mit Samba auch nichts einschränken - von einem Pop up zur Authentifizierung ganz zu schweigen...
     
  7. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    Hmmm, komisch... dann fällt mir auch erstmal nix mehr ein :(
     
  8. Jabo

    Jabo Aufgabe ohne Minister

    Dabei seit:
    12.10.2006
    Beiträge:
    1.322
    Zustimmungen:
    0
    Ort:
    Hamburg
    Dateisystem ist oberste Instanz

    Aber Moment mal....

    Hi, wenn ich das richtig verstanden habe: Das *muß* aber so sein! Dein Linux-System verwaltet die Daten, nicht Windows und nicht Samba! Auf jeden Fall wird Linux also am Ende der Entscheidungskette die Autorität haben zu sagen, ob ein Zugriff erlaubt ist.

    Wenn du deinem Nachbarn sagst "Lasse bitte alle Leute mit grünen Augen in meine Wohnung!" und gibst ihm aber den Türschlüssel nicht, kommen die alle nicht rein, egal wie freundlich der Nachbar zu ihnen ist... Die Instanz, die ganz am Ende am entscheidenden Punkt die Tür zur Datei auf macht oder nicht, ist und bleibt bei Samba die User- und Dateiverwaltung von Linux.
     
  9. #8 Iceman75, 29.11.2007
    Iceman75

    Iceman75 Mitglied

    Dabei seit:
    19.04.2007
    Beiträge:
    26
    Zustimmungen:
    0
    Gut klingt soweit logisch - versteh ich auch aus Windows Sicht - da ist es ja genauso.
    ABER:
    es fehlen mir 2 Sachen
    1) Wieso kommt kein Pop up, das mir ein login erlaubt? Weil aktuell ist es so, daß jeder schreiben darf
    2) unter Windows kann ich die NTFS Berechtigungen mit den Share Berechtigungen kombinieren - wenn ich auf NTFS Level Zugriff gestatte, dann kann ich sie auf Share Level einschränken... das scheint mir hier nicht der Fall zu sein...
     
  10. #9 Iceman75, 03.12.2007
    Zuletzt bearbeitet: 03.12.2007
    Iceman75

    Iceman75 Mitglied

    Dabei seit:
    19.04.2007
    Beiträge:
    26
    Zustimmungen:
    0
    Falls es wen interessiert - ich hab den Fehler gefunden. Er ist so banal gewesen, daß ich zuerst gar nicht auf die Idee gekommen bin, daß es das ein könnte. :headup:
    Wobei ich bitte die anwesenden Profis, um Korrektur, falls meine Gedankengänge falsch sind:

    Ich hab der Einfachheit halber beim Einrichten der Linux Accounts dieselben SMB - Benutzernamen wie Passwörter vergeben, wie auf meinen Windows Rechnern. Nachdem Windows bei der Anmeldung am Samba Server diese Daten übermittelt, hat der Samba Server natürlich keinen Grund gesehen, den Zugriff zu verweigern. Das schien für mich, als wären prinzipiell alle berchtigt, auf das Sahre zuzugreifen. Draufgekommen bin ich, als ich mal testweise ein anderes SMB passwort vergeben hab *g*

    Zu Punkt 2: das funktioniert jetzt auch. Ich war nur insofern verwirrt, weil bei Windoows die Rechte kumulativ sind. Sprich: wenn ich bei NTFS nur lesen darf, dann kann ich per Share Berechtigungen sehr wohl schreibrechte vergeben und umgekehrt. Ausnahme ist nur dann, wenn ich explizit das schreiben verbiete... (glaub ich jedenfalls - ist schon wieder 2 Jahre her seit ich meinen letzten Windows 2k bzw 2k3 Fileserver eingerichtet hab)
    Naja... wieder was gelernt.
    lg
    Ice

    Und wenn meine Freundin nicht den WLAN Router in der Früh abgedreht hätte (so wie ich es ihr beigebracht hab zum Strom sparen und aus Sicherheitsgründen, weil tagsüber eh keiner daheim ist), dann hätt ich auch schon die vollen 40GB von meinem Notebook auf den Server geschaufelt :D
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. maxix

    maxix Eroberer

    Dabei seit:
    16.03.2006
    Beiträge:
    74
    Zustimmungen:
    0
    was du noch machen kannst ist acl's zu aktivieren. Dann kannst Du auch schön einzelne Benutzer auf die Verzeichnisse innerhalb des Shares berechtigen (Ja, das geht natürlich auch mit Linux mitteln).
    1. acl Verwaltung installieren
    2. fstab anpassen das acl's für die Partition aktiviert sind
    3. samba dämon neu starten
     
  13. #11 Iceman75, 03.12.2007
    Iceman75

    Iceman75 Mitglied

    Dabei seit:
    19.04.2007
    Beiträge:
    26
    Zustimmungen:
    0
    Danke für den Hinweis... Hab ich mir schon soweit gedacht, daß das geht. Da der Server aber primär für die Daten von meiner Dreundin und mir gedacht sind, werd ich das wohl nicht benötigen. Außer ich will mal was vor ihr verstecken :devil:
     
Thema:

Linux ignoriert smb.conf settings

Die Seite wird geladen...

Linux ignoriert smb.conf settings - Ähnliche Themen

  1. Arch Linux via Hamachi zu bestehendem VPN verbinden

    Arch Linux via Hamachi zu bestehendem VPN verbinden: Guten Tag zusammen! Ich betreibe zu Hause einen kleinen Server für Minecraft und samba file sharing und möchte diesen nun zu meinem bestehenden...
  2. linux-firmware-nonfree in Centos 15.11 (64 Bit)

    linux-firmware-nonfree in Centos 15.11 (64 Bit): Hallo wie kann man linux-firmware-nonfree in Centos 15.11 (64 Bit) installieren?
  3. Linux konvertieren

    Linux konvertieren: Hallo, ich benutze VMware auf meinem Windows-Rechner. Dort würde ich gern eine neue Linux-VM einrichten. Nur, wie bekomme ich eine Linux-VM?...
  4. [SOLVED]Linux/W7 Dualboot efi problem

    [SOLVED]Linux/W7 Dualboot efi problem: Moin, ich plage mich gerade mit dem Problem des Dualboot Und zwar würde ich gerne mein efi installiertes Windows ebenfalls mit grub booten...
  5. Kunden-Skript ausgelöst durch Linux-Cluster Pacemaker

    Kunden-Skript ausgelöst durch Linux-Cluster Pacemaker: Hallo! Ich komme aus der AIX-Welt wo es im HACMP-Cluster die Möglichkeit der Ausführung eines Start- bzw. Stop-Skriptes im Zuge einer...