Linux 10.1 durch falsches Theme abgeschossen.

Dieses Thema im Forum "KDE" wurde erstellt von raz667, 24.05.2006.

  1. raz667

    raz667 Eroberer

    Dabei seit:
    16.05.2006
    Beiträge:
    73
    Zustimmungen:
    0
    Hallo zusammen,

    habe eben mein System von Suse 10.0 auf version 10.1 geupdated. Als nächstes wollt ich mir dann ein neues Theme über den Manager installieren. Habe mir deswegen dann eins runtergeladen, welches aber für eine ältere KDE-Version, als die bei mir verwendete (KDE 3.5.1). Ich glaub, dieses Theme war auf KDE 3.4.x ausgelegt.

    Ich dachte mir, dass es vielleicht bei inkompatibilitäten zu einer Warnung o.ä. kommt, aber dem war nicht so... Das Theme wurde zwar teilweise angezeigt, aber eben nicht richtig. So entschied ich mich dann, das System komplett neu zu booten, nachdem ein einfaches restarten des XServers nicht zum Ziel führte.

    Jedoch kam ich danach nicht mehr ins System. Ich komme zwar noch zum Login-Screen, kann Name und Passwort angeben, aber viel weiter geht's dann nicht.

    Erstmal erscheint das Suse 10.1 Bootlogo, danach verschwindet dieses und es ist nur noch der blaue Hintergrund zu sehen. Mehr passiert da nicht mehr.
    In die Konsole etc. komme ich dann noch. Weiß aber nicht wie ich von dort aus das System wieder retten kann.

    Kann mir da jemand vielleicht eine idiotenkompatible Anleitung geben? Wäre nett. ;)

    Gruß,
    raz
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 ChrisMD, 24.05.2006
    ChrisMD

    ChrisMD Haudegen

    Dabei seit:
    30.06.2005
    Beiträge:
    619
    Zustimmungen:
    0
    Dank der großen Verbreitung von RedHat und vor allen Dingen SuSE scheint sich der Glaube durchzusetzen, es gäbe ein Linux 8.0, 8.2, 9.0 etc..
    Dem ist jedoch nicht so und wer sich so artikuliert, disqualifiziert sich in jeder Diskussion.

    Warum Linux 8/9/... falsch ist

    Linux ist wie erwähnt nur der Kernel. Die Versionsnummer, hier 8, meint AUSSCHLIESSLICH die Version der Distribution, etwa SuSE 9.0, Mandrake 9.2, RedHat 9, Debian 3.0 usw.. Diese bestimmt jeder Herausgeber einer Distribution selbst, definiert eigene Releasezyklen und bezieht sich dabei in keinster Weise auf den Kernel.


    Eventuell löschen aller Einstellungen durch rm -r .kde im Heimverzeichnis.
     
  4. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    FACK @ChrisMD

    @raz667

    Wie Chris schon sagte, sollte es helfen, alle KDE-Einstellungen deines Nutzers zu löschen. Diese Einstellungen findest du im Unterverzeichnis .kde in deinem Heimatverzeichnis - sprich "/home/NUTZERNAME/.kde".

    Wenn du dich in der grafischen Anmeldung befindest, drücke STRG-ALT-F1 (bevor du dich einloggst), damit wechselst du auf eine andere Konsole (vorsicht, Textmodus :) ). Dann meldest du dich dort ganz normal mit deinem Nutzer (der Nutzer mit dem Problem) an.
    Dann landest du direkt in deinem Home-Verzeichnis.
    Mit dem Befehl "rm -r .kde" [rm = löschen, -r = rekursiv] löschst du nun das .kde Einstellungsverzeichnis. Danach kannst du entweder mit ALT-F7 wieder zum grafischen Anmeldebildschirm (KDM) wechseln oder mit STRG-ALT-ENTF den Computer neustarten. Dann solltest du dich wieder einloggen können.
     
  5. raz667

    raz667 Eroberer

    Dabei seit:
    16.05.2006
    Beiträge:
    73
    Zustimmungen:
    0
    Hi,

    ich bin über Strg+Alt+F1 in die Konsole, hab mich da aber als root angemeldet und bin dann über "cd /home/raz/" in mein Homeverzeichnis gewechselt. Sollte aufs gleiche hinauslaufen, oder?
    Dort hab ich dann dann auch den Befehl "rm -r .kde" eingegeben, welcher auch ausgeführt wurde.
    Bin dann wieder in den grafischen Modus gewechselt und hab versucht mich einzuloggen. Hat nichts geholfen. Problem besteht nach wie vor.
    Das aber nicht nur in meinem Profil, sondern auch als root.

    Hängt das Problem vielleicht doch nicht mit dem falschen Theme zusammen sondern hat irgendwas mit dem Update zu tun?!?
     
  6. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Hm also wenn das Problem auch als root besteht, hatte es nichts mit den KDE-Einstellungen zutun (das löschen des Ordners und das Wechseln in das entsprechende Verzeichnis hast du aber schon richtig ausgeführt).

    Hasat du vllt. ein Link zu diesem Theme, so dass wir uns da ein besseres Bild machen können? So könntest du sehen, wohin sich da Dateien installieren und so könnte man es auch wieder besser rückgängig machen.
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Sollte es am tatsaechlich Theme liegen (was ich nicht glaube), sollte es reichen die Dateien, die das Theme installiert hat einfach wieder zu loeschen.

    Jag evtl. mal mit YOU ein Online-Update durch. Sollte das alles nicht helfen, deinstalliere KDE einmal vollstaendig, stelle sicher, dass auch die Konfigurationen geloescht werden und installiere es nochmal sauber neu. Ich wuerde naemlich auch eher auf ein Problem beim Update des KDE tippen. Evtl. wurden dort irgendwelche Abhaengigkeiten nicht sauber aufgeloest o.ae.

    Kannst du, wenn du dich grafisch anmeldest noch mit Alt+F2 ein "Run Command"-Fenster bekommen? Passiert noch was, wenn du einen Rechtsklick auf den Desktop machst? Wenn nicht, weist das eher darauf hin, dass garkein WM gestartet wird. In diesem Fall sollten aber auch entsprechende Meldungen in der /var/log/Xorg.0.log auftauchen, denen zu entnehmen ist, warum kein WM geladen werde konnte.
     
  9. raz667

    raz667 Eroberer

    Dabei seit:
    16.05.2006
    Beiträge:
    73
    Zustimmungen:
    0
Thema:

Linux 10.1 durch falsches Theme abgeschossen.

Die Seite wird geladen...

Linux 10.1 durch falsches Theme abgeschossen. - Ähnliche Themen

  1. Kunden-Skript ausgelöst durch Linux-Cluster Pacemaker

    Kunden-Skript ausgelöst durch Linux-Cluster Pacemaker: Hallo! Ich komme aus der AIX-Welt wo es im HACMP-Cluster die Möglichkeit der Ausführung eines Start- bzw. Stop-Skriptes im Zuge einer...
  2. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  3. Linux Foundation wird durch vier neue Mitglieder verstärkt

    Linux Foundation wird durch vier neue Mitglieder verstärkt: Wie die Linux Foundation jetzt bekanntgab, konnten vier neue Mitglieder gewonnen werden. Es handelt sich um Alwinner Technology, Datto, LinBit und...
  4. Tamil Nadu ersetzt Windows XP durch Linux

    Tamil Nadu ersetzt Windows XP durch Linux: Das Ende von Windows XP trifft den indischen Bundesstaat Tamil Nadu nicht unvorbereitet. Zur Ablösung wird BOSS Linux empfohlen. Weiterlesen...
  5. Android: Google erschwert Root-Apps durch SELinux-Regeln

    Android: Google erschwert Root-Apps durch SELinux-Regeln: Durch zwei Code-Änderungen am Android-Quelltext wird das Ausführen von Applikationen, die Root-Zugang zum Smartphone voraussetzen, in Zukunft...