libogg + libvorbis

Dieses Thema im Forum "Anwendungen" wurde erstellt von lastUnic0rn, 30.08.2004.

  1. #1 lastUnic0rn, 30.08.2004
    lastUnic0rn

    lastUnic0rn Jungspund

    Dabei seit:
    30.08.2004
    Beiträge:
    24
    Zustimmungen:
    0
    Ort:
    Speyer, RLP
    Hey,

    ich als kompletter Linux Newbie hab folgendes Problem:

    Um die neuste Version von K3b zum Laufen zu bringen brauch ich die neusten libogg und libvorbis. Die Datien hab ich mir runtergeladen und versucht zu installieren.

    Die libogg zuerst, weil die für die libvorbis gebraucht wird. Da kam es dann zu folgendem Fehler:
    Code:
    rpm -Uhv libogg-1.1-1.i386.rpm
    Preparing...                ########################################### [100%]
            file /usr/lib/libogg.so.0 from install of libogg-1.1-1 conflicts with file from package libogg0-1.0-6mdk
    Beim Versuch die libvorbis jetzt zu installieren kommt folgendes:
    Code:
    rpm -Uhv libvorbis-1.0.1-1.i386.rpm
    Fehler: Failed dependencies:
            libogg >= 1.1 is needed by libvorbis-1.0.1-1
    Wie muss ich jetzt weiterverfahren, um die Datei zu installieren? Ich nutze Mandrake Linux 9.2.

    THX für die Hilfe
    Christopher​
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    rpm -e libogg0-1.0-6mdk - damit das alte Paket gelöscht wird.

    Dann mit rpm -i libogg-1.1-1.i386.rpm das neue Installieren ...

    Allerding solltest du dir das Mandrake Paket dazu suchen und eigentlich nicht ein "beliebiges" RPM :/
     
  4. #3 lastUnic0rn, 30.08.2004
    lastUnic0rn

    lastUnic0rn Jungspund

    Dabei seit:
    30.08.2004
    Beiträge:
    24
    Zustimmungen:
    0
    Ort:
    Speyer, RLP
    Hey,

    wenn ich mit rpm -e libogg0-1.0-6mdk versuche das Paket zu löschen kommt folgender Fehler:

    Code:
    rpm -e libogg0-1.0-6mdk
    Fehler: Failed dependencies:
            libogg.so.0 is needed by (installed) libvorbis0-1.0-10mdk
            libogg.so.0 is needed by (installed) libvorbisfile3-1.0-10mdk
            libogg.so.0 is needed by (installed) libvorbisenc2-1.0-10mdk
            libogg.so.0 is needed by (installed) libarts1-1.1.3-7mdk
            libogg.so.0 is needed by (installed) arts-1.1.3-7mdk
            libogg.so.0 is needed by (installed) kdelibs-common-3.1.3-35mdk
            libogg.so.0 is needed by (installed) libkdecore4-3.1.3-35mdk
            libogg.so.0 is needed by (installed) libkdebase4-3.1.3-79mdk
            libogg.so.0 is needed by (installed) libkdemultimedia1-common-3.1.3-16mdk
            libogg.so.0 is needed by (installed) vorbis-tools-1.0-6mdk
            libogg.so.0 is needed by (installed) kdemultimedia-common-3.1.3-16mdk
            libogg.so.0 is needed by (installed) koffice-1.3-0.beta3.6mdk
            libogg.so.0 is needed by (installed) libSDL_mixer1.2-1.2.5-3mdk
            libogg.so.0 is needed by (installed) liboggflac1-1.1.0-5mdk
            libogg.so.0 is needed by (installed) xmms-1.2.7-25mdk
            libogg.so.0 is needed by (installed) csmash-0.6.5-2mdk
            libogg.so.0 is needed by (installed) libkdegames1-3.1.3-12mdk
            libogg.so.0 is needed by (installed) kdegames-3.1.3-12mdk
            libogg.so.0 is needed by (installed) mplayer-0.91-7mdk
            libogg.so.0 is needed by (installed) k3b-0.9-10mdk
            libogg0 = 1.0-6mdk is needed by (installed) libogg0-devel-1.0-6mdk
            libogg0 >= 1.0-1mdk is needed by (installed) vorbis-tools-1.0-6mdk
    Ich hab keine Ahnung was ich jetzt machen soll.

    Christopher
     
  5. khs

    khs Routinier

    Dabei seit:
    19.08.2004
    Beiträge:
    408
    Zustimmungen:
    0
    "--force" mit anhaengen, da fliegts trotzdem raus. Die RPM-Datenbank soll sich nicht beschweren, sie bekommt ja gleich ne neue libogg... ;)
    "--nodeps" ist manchmal auch gut zu wissen. Wo ich das herweiss? man rpm.

    -khs
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

libogg + libvorbis