libexpat.so.0

Dieses Thema im Forum "Installation & Basiskonfiguration" wurde erstellt von EdiNelly, 31.05.2006.

  1. #1 EdiNelly, 31.05.2006
    EdiNelly

    EdiNelly **+._.+**

    Dabei seit:
    10.01.2006
    Beiträge:
    53
    Zustimmungen:
    0
    Hallo...
    Weiss einer wo ich libexpat.so.0 herbekomme?
    ?(
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 DennisM, 31.05.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Bitte ein bisschen mehr Infos, worum geht es, welche Distri usw.

    MFG

    Dennis
     
  4. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Von deinem Distributor nehme ich mal an und wenn du uns verraetst, welcher das ist, und wenn du uns dann auch noch sagst, welche Version dieser Distribution du hast, kann dir bestimmt jemand sagen in welchem Paket du die Datei findest.
     
  5. #4 DennisM, 01.06.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Höchstwahrscheinlich in (lib)expat :P

    MFG

    Dennis
     
  6. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Davon gehe ich aus, ist nur die Frage ob mit oder ohne 'lib' davor. :)
     
  7. #6 slasher, 01.06.2006
    slasher

    slasher König

    Dabei seit:
    22.03.2006
    Beiträge:
    827
    Zustimmungen:
    0
    ich tippe auf *expat* *g*.
     
  8. #7 DennisM, 01.06.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    ROFL

    MFG

    Dennis
     
  9. #8 damager, 01.06.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    mal von dem bescheidenen topic abgesehen wette ich das er den ati-treiber installieren möchte und sich dafür über den installer ein rpm-paket hat schnüren lassen? und diesem fehlt die libexpat.so.0.

    wer hält mit? :sly:
     
  10. #9 EdiNelly, 01.06.2006
    EdiNelly

    EdiNelly **+._.+**

    Dabei seit:
    10.01.2006
    Beiträge:
    53
    Zustimmungen:
    0
    damager hat absolut recht! Ich möchte den ATi Treiber installieren. Tut mir leid das ich nicht mehr Info's gegeben habe... ;( Ich benutze Suse 10.1 wie in meiner Sig zu lesen ist. Hab mir den Treiber als rpm runtergeladen aber zum installieren fehlt libexpat.so.0 Übrigens auch bei vielen anderen rpm paketen. z.B. KDE Desktop Themes. leider komme ich mit Suse nicht ins Internet.. Kann ich die DAtei mit Win runterladen und manuell installieren?

    Vielen Dank
     
  11. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Dann installiere dir mal einfach mit YaST das Paket expat. Sollte es bereits installiert sein, schau in der /etc/ld.so.conf, ob dort eine Zeile existiert, in der '/usr/lib' steht und wenn nicht, fuege sie einfach an und lasse einmal 'ldconfig' durchlaufen.
     
  12. #11 DennisM, 01.06.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    expat MUSS eigentlich installiert sein, denn KDE benötigt es.

    MFG

    Dennis
     
  13. #12 damager, 02.06.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    offtopic:
    schade, habe gehofft das jemand noch auf die wette einsteigt :D

    @EdiNelly:
    was sagt den locate libexpat.so ?
    expat ist, wie auch DennisM sagt, sicher installiert... aber mit libexpat.so.1 bzw. libexpat.so.1.5.0.

    also ich habe ein sym.link von libexpat.so.1 auf libexpat.so.0 gemacht und mit rpm -Uvh <paket.rpm> --nodeps --force gemacht und der treiber funtzt.
    ist zwar wirklich dirty aber was solls....hab ja ein gutes backup :D
     
  14. #13 EdiNelly, 02.06.2006
    Zuletzt bearbeitet: 02.06.2006
    EdiNelly

    EdiNelly **+._.+**

    Dabei seit:
    10.01.2006
    Beiträge:
    53
    Zustimmungen:
    0
    Vielen DAnk werd mal probieren... melde mich wieder....

    Edit: da bin ich wieder....

    @theton:
    in der /etc/ld.so.conf steht folgendes:
    Code:
    /usr/X11R6/lib/Xaw3d
    /usr/X11R6/lib
    /usr/i486-linux-libc5/lib=libc5
    /usr/i386-suse-linux/lib
    /usr/local/lib
    /opt/kde3/lib
    /opt/gnome/lib
    include /etc/ld.so.conf.d/*.conf 
    
    @damager:
    es ist wie du und DennisM vermuten. libexpat.so.1 und libexpat.so.1.5.0 sind installiert. Heisst das ich muss auf den treiber verzichten oder auf eine neuere version warten oder was? Hat es einen Nachteil wenn ich aus libexpat.so.1 libexpat.so.0 mache für andere Progamme?
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 DennisM, 02.06.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Wo ist die Datei denn? Wenn der Pfad nicht in der ld.so.conf steht, wo die Datei enthalten ist, füge den Pfad hinzu und danach ldconfig als root.

    MFG

    Dennis
     
  17. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Du brauchst nur die Datei libexpat.so.1 zu libexpat.so.0 verlinken.
    Code:
    ln -s /usr/lib/libexpat.so.1 /usr/lib/libexpat.so.0
    Dadurch sollte sich das Problem eigentlich beheben und fuer andere Programme entstehen keine Probleme.
     
Thema:

libexpat.so.0