libdvdread4 fehler (kaffeine und co)

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von tuxlover, 22.12.2008.

  1. #1 tuxlover, 22.12.2008
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    hallo liebe leutz,

    ich hätte da mal wieder geren ein problem. ich habe opensuse 11.0 und wollte gestern zum ersten mal dvd gucken und mit dvdrip auslesen. Wenn ich die dvd mit vlc anschaue, der intern noch libdvdread3 verwendet funktioniert alles wunderbar.

    Mplayer stürzt sofort ab und versucht erst gar nicht die dvd abzuspielen. Kaffeine und dvdrip versuchen beide die dvd zu lesen, in htop sehe ich dann dass sie dann den speicher nebst swap bis zum anschlag vollknallen (1GB RAM) und (2GB Swap) und dann hängt logischerweise der ganze rechner. Alle 3 programme haben eines gemeinsam, sie benutzen nämlich die neuere library libdvdread4.

    ist dieser bug bekannt, gibt es möglicherweise ein downgrade oder ein anderen workaround.

    vielen dank für eure fleißige hilfe
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Gast1

    Gast1 Guest

    Funktioniert hier auf einer deutlich schwächeren Maschine (512MB) ohne Probleme.
     
  4. #3 tuxlover, 22.12.2008
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    und wie hilft mir das weiter? ;)
     
  5. #4 Gast1, 22.12.2008
    Zuletzt von einem Moderator bearbeitet: 22.12.2008
    Gast1

    Gast1 Guest

    Ob Dir das weiterhilft ist mir schnurzpiepegal, es zeigt nur, daß es sich nicht um einen "Bug" sondern um einen Anwenderfehler handelt.

    Also nicht immer gleich "Bug" schreien, wenn etwas nicht funktioniert, der Bug sitzt meist vor dem Schirm.

    Und da Du ja auch gerne mal die smart-questions verlinkst, hab ich sie hier mal für Dich verlinkt, sogar einen speziellen Abschnitt:

    http://www.tty1.net/smart-questions_de.html#dontclaimbug
     
  6. #5 tuxlover, 22.12.2008
    Zuletzt bearbeitet: 22.12.2008
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    ok verrate mir bitte was ich dann falsch gemacht haben soll.
    ich bin so vorgegangen: dvd reingelegt, dann dvdfach geschlossen, anschließend mplayer ausgewählt und auf dvd abspielen geklickt.

    Ich reiche mal den output nach:
    Code:
    #
    ]2;matthias@Alucard:~]1;Alucardmatthias@Alucard:~> mplayermplayerexitmplayermplayer /dev/sr0
    #
    MPlayer dev-SVN-r27637 (C) 2000-2008 MPlayer Team
    #
    CPU: AMD Athlon(tm) Dual Core Processor 4450e (Family: 15, Model: 107, Stepping: 2)
    #
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
    #
    Compiled with runtime CPU detection.
    #
    Can't open joystick device /dev/input/js0: No such file or directory
    #
    Can't init input joystick
    #
    mplayer: could not connect to socket
    #
    mplayer: No such file or directory
    #
    Failed to open LIRC support. You will not be able to use your remote control.
    #
     
    #
    Playing /dev/sr0.
    #
    MPEG-PS file format detected.
    #
    VIDEO:  MPEG2  720x576  (aspect 2)  25.000 fps  9800.0 kbps (1225.0 kbyte/s)
    #
    Xlib:  extension "XFree86-VidModeExtension" missing on display ":0.0".
    #
    ==========================================================================
    #
    Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
    #
    VDec: vo config request - 720 x 576 (preferred colorspace: Mpeg PES)
    #
    Could not find matching colorspace - retrying with -vf scale...
    #
    Opening video filter: [scale]
    #
    The selected video_out device is incompatible with this codec.
    #
    Try appending the scale filter to your filter list,
    #
    e.g. -vf spp,scale instead of -vf spp.
    #
    VDecoder init failed :(
    #
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    #
    Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
    #
    ==========================================================================
    #
    ==========================================================================
    #
    Opening audio decoder: [liba52] AC3 decoding with liba52
    #
    Using SSE optimized IMDCT transform
    #
    a52: CRC check failed!  
    #
    Using MMX optimized resampler
    #
    AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
    #
    Selected audio codec: [a52] afm: liba52 (AC3-liba52)
    #
    ==========================================================================
    #
    AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
    #
    Starting playback...
    #
    a52: error at resampling
    #
    a52: CRC check failed!  
    #
    a52: error at resampling
    #
    A:   0.5 V:   0.0 A-V:  0.448 ct:  0.000   1/  1 ??% ??% ??,?% 1 0 
    #
    No bind found for key ''.                        
    #
    a52: CRC check failed!  
    #
    a52: error at resampling
    #
    A:   0.6 V:   0.1 A-V:  0.485 ct:  0.004   2/  2 ??% ??% ??,?% 1 0 
    #
    A:   0.7 V:   0.1 A-V:  0.623 ct:  0.008   3/  3 ??% ??% ??,?% 1 0 
    #
    A:   0.7 V:   0.2 A-V:  0.584 ct:  0.012   4/  4 ??% ??% ??,?% 1 0 
    #
    A:   0.7 V:   0.2 A-V:  0.544 ct:  0.016   5/  5 ??% ??% ??,?% 1 0 
    #
    A:   0.8 V:   0.2 A-V:  0.534 ct:  0.020   6/  6 ??% ??% ??,?% 1 0 
    #
    A:   0.8 V:   0.3 A-V:  0.530 ct:  0.024   7/  7 ??% ??% ??,?% 1 0 
    #
    A:   0.8 V:   0.3 A-V:  0.526 ct:  0.028   8/  8 ??% ??% ??,?% 1 0 
    #
    A:   0.9 V:   0.4 A-V:  0.534 ct:  0.032   9/  9 ??% ??% ??,?% 1 0 
    #
    A:   0.9 V:   0.4 A-V:  0.530 ct:  0.036  10/ 10 ??% ??% ??,?% 1 0 
    #
    a52: CRC check failed!  
    #
    A:   1.1 V:   0.4 A-V:  0.614 ct:  0.040  11/ 11 ??% ??% ??,?% 1 0 
    #
    A:   1.1 V:   0.5 A-V:  0.590 ct:  0.044  12/ 12 ??% ??% ??,?% 1 0 
    #
    a52: CRC check failed!  
    #
    a52: error at resampling
    #
    A:   1.1 V:   0.5 A-V:  0.618 ct:  0.048  13/ 13 ??% ??% ??,?% 1 0 
    #
    A:   1.3 V:   0.6 A-V:  0.690 ct:  0.052  14/ 14  0%  0%  1.1% 1 0 
    #
    A:   1.3 V:   0.6 A-V:  0.698 ct:  0.056  15/ 15  0%  0%  1.1% 1 0 
    #
    A:   1.3 V:   0.6 A-V:  0.694 ct:  0.060  16/ 16  0%  0%  1.1% 1 0 
    #
    A:   1.4 V:   0.7 A-V:  0.670 ct:  0.064  17/ 17  0%  0%  1.0% 1 0 
    #
    A:   1.4 V:   0.7 A-V:  0.666 ct:  0.068  18/ 18  0%  0%  1.0% 1 0 
    #
    A:   1.4 V:   0.8 A-V:  0.662 ct:  0.072  19/ 19  0%  0%  0.9% 1 0 
    #
    A:   1.5 V:   0.8 A-V:  0.670 ct:  0.076  20/ 20  0%  0%  0.9% 1 0 
    #
    A:   1.5 V:   0.8 A-V:  0.666 ct:  0.080  21/ 21  0%  0%  0.9% 1 0 
    #
    a52: CRC check failed!  
    
     
  7. Gast1

    Gast1 Guest

    Keine Ahnung, bei den spärlichen Informationen ist das auch nur Rätselraten.

    Hier funktioniert es mit vlc, kaffeine und mplayer (sowie gmplayer, kmplayer und smplayer als Frontends).
     
  8. #7 tuxlover, 22.12.2008
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    ich weiß nicht was das ist. auf meinem alten rechner hat ja auch alles problemlos funktioniert mit opensuse 10.3.
     
  9. #8 gropiuskalle, 22.12.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Häng Dich mal → hier oder → hier ran, klingt nach dem gleichen Problem (auch wenn es die 11.1 betrifft).
     
  10. Gast1

    Gast1 Guest

    Der Bugreport mit mit Sicherheit 11.1-spezifisch, da es um ein Rechteproblem geht, vermutlich darauf zurückzuführen, daß bei der 11.1 kräftig am Unterbau geändert wurde (resmgr ist z.B. gar nicht mehr vorhanden).

    Ausserdem funktioniert es hier auf 11.0 ohne Probleme, die Fehlermeldung deutet auch eher auf ein Problem mit der Decodierung und nicht auf ein Rechteproblem hin.
     
  11. #10 gropiuskalle, 22.12.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    War mir auch nicht ganz sicher deswegen (da ich die 11.1 mir noch nicht genauer angesehen habe), aber Du hast recht: ein bug im eigentlichen Sinne kann es kaum sein, denn auch hier läuft es mit den üblichen Konfigurationen ohne Probleme.

    tuxlover, checke nochmal die codecs → klick. libdvdcss2 nicht vergessen (wird im HowTo aus rechtlichen Gründen nur indirekt erwähnt) und vielleicht auch mal schauen, ob irgendwelche Videolan-Pakete sich in Dein System geschlichen haben.
     
  12. #11 tuxlover, 22.12.2008
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    ich benutze für vlc auschließlich die paket von videolan und libdvdcss-1.2.9 habe ich daher.

    wieso was ist mit den paketen von diesem repo?
     
  13. Gast1

    Gast1 Guest

    Und da der Rest (z.B. mplayer) dann sicherlich von Packman kommen, gibt es genau diesen Ärger.
     
  14. #13 gropiuskalle, 22.12.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Videolan und Packman beißen sich - die libdvdcss geht aber noch in Ordnung. Prüfe mal, ob Du libdvdcss oder libdvdcss2 hast.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 tuxlover, 22.12.2008
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    ok dann werde ich mal den vlc von packman nehmen. ich habe die libdvdcss. weiß aber nicht ob das den unterschied macht. weil libdvdcss in der version 1.2.10 und libdvdcss2 in der version 1.2.9 vorliegen. *verwirrt bin*
     
  17. #15 gropiuskalle, 22.12.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Nimm doch die libdvdcss2-1.2.10 von Packman. Wo jetzt der Unterschied liegt, weiß ich nicht. Die 2er funktioniert bei mir grundsätzlich, die andere Version nicht mit jeder DVD. Ich vermute einfach ein paar zusätzliche Entschlüsselungsalgorithmen oder sowas.
     
Thema:

libdvdread4 fehler (kaffeine und co)

Die Seite wird geladen...

libdvdread4 fehler (kaffeine und co) - Ähnliche Themen

  1. Terminal Fehlermeldung

    Terminal Fehlermeldung: Hola, mir ist aufgefallen das ständig ein Fehler erscheint sobald ich einen Terminal öffne. Hat zwar keine Auswirkung auf die Arbeit damit sieht...
  2. LibreOffice 5.1.1 korrigiert Fehler

    LibreOffice 5.1.1 korrigiert Fehler: Das LibreOffice-Projekt hat die Verfügbarkeit der Version 5.1.1 der freien Office-Suite bekannt gegeben. In diesem planmäßigen Update werden...
  3. Fehler in glibc gefährdet zahlreiche Systeme

    Fehler in glibc gefährdet zahlreiche Systeme: Sicherheitsforscher haben eine Sicherheitslücke in der glibc-Bibliothek entdeckt, die sich von externen Angreifern über das Netzwerk ausnutzen...
  4. LibreOffice veranstaltet Fehlerjagd

    LibreOffice veranstaltet Fehlerjagd: Das LibreOffice-Projekt hat angekündigt, vom 15. bis 17. Januar die mittlerweile dritte öffentliche »Bug Hunting Session« für Version 5.1 der...
  5. Linux.Encoder: Das Laster der fehlerhaften Kryptografie

    Linux.Encoder: Das Laster der fehlerhaften Kryptografie: Der mittlerweile in der dritten Generation nun vorliegende Ransomware »Linux.Encoder« kann immer noch kaum Schrecken unter Linux verbreiten -...