ld - errors beim compilieren von diversen dingen...

Dieses Thema im Forum "Linux OS" wurde erstellt von Blender3D, 12.07.2008.

  1. #1 Blender3D, 12.07.2008
    Zuletzt bearbeitet: 12.07.2008
    Blender3D

    Blender3D Vitamin C++

    Dabei seit:
    17.09.2007
    Beiträge:
    228
    Zustimmungen:
    0
    Ort:
    /root
    Hallo, liebes Forum!

    Ich benutze seit schon einiger Zeit Slackware. Wegen eines neuen Rechners und seinem RAM musste ich auf Slamd64 umsteigen. Da die Version 12.1 zu dem Zeitpunkt noch nicht erschienen war begnügte ich mich mit der Version 12.0, die allerdings von Haus aus eine ältere version des GCC mitbringt. Da ich die OpenMP-Library, die erst seit GCC 4.2.3 im GCC vorhanden ist benutzen möchte habe ich auf die neueste GCC-version geupdatet. Ich habe einfach GCC 4.3.1 neucompiliert und kann diese jetzt auh verwenden. Leider kann ich manche Sachen, wie openEXR oder ODE nicht compilieren, da er mir imer eine Meldung nach dem Motto:

    Code:
    /usr/local/lib/gcc/x86_64-unknown-linux-gnu/4.3.1/../../../../include/c++/4.3.1/ostream:465: undefined reference to `std::basic_ostream<char, std::char_traits<char> >& std::__ostream_insert<char, std::char_traits<char> >(std::basic_ostream<char, std::char_traits<char> >&, char const*, long)'
    collect2: ld returned 1 exit status
    zurückgibt. Woran liegt das und wie kann ich es beheben? Reicht es, wenn ich eine ältere GCC-Version compiliere? z.B. 4.2.3, die schon etwas betagter ist, aber auch openMP mitbringt.

    Achja: Hier noch einiges über mein System:
    Prozessor: AMD Opteron 2350 (B3)
    Mainboard: Tyan Thunder n3600M
    OS: Slamd64 GNU/Linux 12.0 (Linux Linux 2.6.22.8 #1 SMP Tue Sep 25 20:41:25 BST 2007 x86_64 x86_64 x86_64 GNU/Linux)
    GCC: Using built-in specs.
    Target: x86_64-unknown-linux-gnu
    Configured with: ../gcc-4.3.1/configure
    Thread model: posix
    gcc version 4.3.1 (GCC)
    LD: GNU ld (Linux/GNU Binutils) 2.17.50.0.17.20070615
    AS: GNU assembler version 2.17.50.0.17 (x86_64-slamd64-linux) using BFD version (Linux/GNU Binutils) 2.17.50.0.17.20070615
    OpenEXR versionen, die ich versucht habe: 1.6.1 und 1.4.0
    ILM-Base-version: 1.0.1
    ODE: 0.10.0

    Vielen Dank für konstruktive Antworten Schonmal im Vorraus!!!

    Grüße, Blender3D
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

ld - errors beim compilieren von diversen dingen...

Die Seite wird geladen...

ld - errors beim compilieren von diversen dingen... - Ähnliche Themen

  1. Samba Errors

    Samba Errors: Hallo zusammen, Ich habe mir einen FreeNAS-Server am laufen (basiert auf FreeBSD) und bekomme vom Samba Dienst dauernd Errors wenn ich darauf...
  2. SCSI Error / I/O Errors

    SCSI Error / I/O Errors: Hi Ihr, und zwar folgendes: Bei nem Kunden steht ein CentOS Server der über einen FC-Switch (Qlogic)mit einem RAID kommuniziert. Das Raid...
  3. Problem/Fragen mit/über OpenSuse 10.1 und .xsession-errors

    Problem/Fragen mit/über OpenSuse 10.1 und .xsession-errors: EDIT: Wenn es im falschen Bereich ist bitte verschieben, oder ich irgendwas vergessen hab zu posten oder Fragen offen sind, bitte nachfragen und...
  4. Network Errors -> reset

    Network Errors -> reset: Hi Community! Ich habe ein kleines Problem, ich bin gerade daran etwas zu schreiben um die Netzwerkkarte zu überwachen. Speziell die...
  5. Grub errors

    Grub errors: hallo zu sammen ich bin neu im linux benutzen.ich hab ein problem mit grub ,wen ihc es auf die /hba mbr schreibe bekomme ich die fehler mkeldung...