Konsole auf UTF-8

Dieses Thema im Forum "Gentoo" wurde erstellt von Greenleon, 27.11.2009.

  1. #1 Greenleon, 27.11.2009
    Greenleon

    Greenleon Tripel-As

    Dabei seit:
    08.01.2007
    Beiträge:
    184
    Zustimmungen:
    0
    Hi,

    ich bin diesem Tutorial hier gefolgt: http://www.gentoo.de/doc/de/utf-8.xml
    Da 'man' immer noch keine Sonderzeichen angezeigt hat, hab ich mal die Consolefont gewechselt, von default8x16 auf ter-v16b.

    Jetzt werden Sonderzeichen korrekt dargestellt und die Schrift sieht schicker aus.

    Allerdings wird mitten im Bootvorgang die Schrift erst gesetzt, sodass alle Zeichen vorher ploetzlich irgendwelche undefinierbaren Zeichen werden. So sonderzeichen eben, die man noch nie gebraucht hat.
    Ich sehe das als dicken Schoenheitsfehler. Gibts ne Moeglichkeit die Schriftart zu Beginn des Initvorgangs zu setzen oder irgendwie zu verhinden, dass die Schriftzeichen vorher verunstaltet werden?

    Gruss
    Leon
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 doc, 27.11.2009
    Zuletzt bearbeitet: 27.11.2009
    doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    bin mir nicht ganz sicher, aber ich glaube wenn utf8 fest im kernel drin ist geht das.

    also native language support utf-8 nls fest einkompilieren

    wie gesagt ist nur geraten, aber ich weiss das es früher bei mir ging, da war es fest im kernel. jetzt ist es modular und sonderzeichen werden nicht mehr korrekt dargestellt beim booten, aber das mag auch einen anderen grund haben...

    aber ich tippe mal ist gut geraten ;)
     
  4. #3 Greenleon, 28.11.2009
    Greenleon

    Greenleon Tripel-As

    Dabei seit:
    08.01.2007
    Beiträge:
    184
    Zustimmungen:
    0
    Meinst du das hat was mit dem Kernel zu tun.
    Ich versuch das Problem nochmal etwas genauer zu beschreiben.
    Gegen Ende des Bootvorgangs, da wo die "Checkliste" mit den gestarteten Daemons und so kommt, wo am rechten Rand dann immer [OK] in gruen erscheint, da tritt das Problem dann auf wenn "Setting Console to UTF-8" kommt. Alle Sonderzeichen die bisher im Checklistenvorgang (kA wie das heisst) angezeigt wurden werden haesslich und die in der naechsten Zeile auch, bevor "Setting user font" kommt.
    Nachdem die Schriftart gesetzt ist werden alle folgenden Sonderzeichen wieder korrekt dargestellt. Die vorherigen sind aber noch verunstaltet.

    Ich schau mal wieweit mein Kernel NLS hat.
    thxout
     
  5. #4 slackfan, 28.11.2009
    slackfan

    slackfan König

    Dabei seit:
    18.04.2006
    Beiträge:
    809
    Zustimmungen:
    0
    Ort:
    Bonn
    Der Bootloader sollte auch fähig sein, da schon sinnvolle Voreinstellungen zu treffen.
    In meiner Lilo-Konfiguration steht z.B. dazu
    Code:
    append = " vt.default_utf8=1"
    
    Bei Grub geht das sicherlich auch. Einen Versuch ist es zumindest wert.
     
  6. #5 Greenleon, 28.11.2009
    Greenleon

    Greenleon Tripel-As

    Dabei seit:
    08.01.2007
    Beiträge:
    184
    Zustimmungen:
    0
    okay, ich gehe dem mal nach. Der Kernel hat ueberall ein Haekchen bei Filesystem->NLS, wo was von UTF8 steht und UTF8 ist auch default da. Von einer anderen NLS-Option weiss ich nix.
     
  7. #6 Greenleon, 08.12.2009
    Greenleon

    Greenleon Tripel-As

    Dabei seit:
    08.01.2007
    Beiträge:
    184
    Zustimmungen:
    0
    Hmm also was Grub angeht, finde ich ich auch keine entsprechende Option.

    Irgendwelche anderen Ideen? Kann ich nen Screenshot von dem VT machen, damit ihr euch das mal besser vorstellen koennt??

    lg
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 slackfan, 08.12.2009
    Zuletzt bearbeitet: 08.12.2009
    slackfan

    slackfan König

    Dabei seit:
    18.04.2006
    Beiträge:
    809
    Zustimmungen:
    0
    Ort:
    Bonn
    Ob du kannst, weiß ich nicht, aber sehen würde ich das schon gerne einmal :)

    Das ist ein Parameter, der dem Kernel beim Booten übergeben wird. Wenn ich die Konfigurationsdatei von Grub richtig interpretiere, müsste es in etwa so aussehen
    Code:
    ...
    title linux
        kernel (hd0,0)/vmlinuz vt.default_utf8=1 root=/dev/hda2 vga=791
        initrd (hd0,0)/initrd
    ...
    
    cu
     
  10. #8 Greenleon, 09.12.2009
    Zuletzt bearbeitet: 09.12.2009
    Greenleon

    Greenleon Tripel-As

    Dabei seit:
    08.01.2007
    Beiträge:
    184
    Zustimmungen:
    0
    Also diese bootparameter haben leider nichts gebracht...

    Lag scheinbar an der Schriftart. Hab jetzt CONSOLEFONT="lat0-16" genommen und keine Probleme mehr. Vorher war CONSOLEFONT="ter-v16b" eingestellt. Hoechst seltsam. Die Schrift vorher war schoener.
     
Thema:

Konsole auf UTF-8

Die Seite wird geladen...

Konsole auf UTF-8 - Ähnliche Themen

  1. String auf Konsole ausgeben

    String auf Konsole ausgeben: Hallo zusammen, ich bin auf ein Problem gestoßen dass für mich sehr unverständlich ist, aber vllt übersehe ich auch etwas Offensichtliches. Es...
  2. Artikel: Das Konsolentool top

    Artikel: Das Konsolentool top: Wer sich über einen langsam laufenden Computer ärgert, kann mit Hilfe verschiedener Programme nachschauen, woran es liegt. Das Programm top geht...
  3. CopyPaste Problem: Sonderzeichen in die Konsole einfügen

    CopyPaste Problem: Sonderzeichen in die Konsole einfügen: Hallo, ich hatte irgendwann mal ein Befehl gesehen, indem jemand ein Problem hatte, einen sed Einzeiler in die Konsole einzufügen. Gut, das...
  4. redhat 6.4 Probleme grafische Konsole

    redhat 6.4 Probleme grafische Konsole: Hallo zusammen, ich habe ein komisches Phänomen. Nachdem ich einen Redhat 6.2 Server auf 6.4 upgegraded habe bekomme ich nach dem Login an der...
  5. Offene Android-Spielkonsole Ouya ist fertig

    Offene Android-Spielkonsole Ouya ist fertig: Die Android-Spielkonsole Ouya, die mittels einer Kickstarter-Initiative Kapital für die Finalisierung des Projektes suchte, will nun Ende des...