Könnt so kotzen (Samba Problem)

Dieses Thema im Forum "Samba" wurde erstellt von vektorzeit, 10.09.2006.

  1. #1 vektorzeit, 10.09.2006
    vektorzeit

    vektorzeit Jungspund

    Dabei seit:
    09.09.2006
    Beiträge:
    15
    Zustimmungen:
    0
    Hi Leute,

    Sitz hier nun Tagelang vor Samba habe schon das Internet kaputt gegoogelt und mein Hass auf Computer Systeme wird immer größer!!! Der verdammte dumme Samba Server macht nicht das was er tun soll. Er gibt Ordner Frei, diese Erkennt man schließlich auch im Browser, aber will man dann darauf zugreifen, kommt der verdammte Client mit dem Kommentar : Der Ordner existiert nicht! Totaler Hass pur!!! Ich weiß nicht was es soll. Im Netz findet man dazu nichts brauchbares.


    [global]
    workgroup = TUX-NET
    printcap name = cups
    cups options = raw
    map to guest = Bad User
    include = /etc/samba/dhcp.conf
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    domain master = No
    usershare max shares = 100

    [SIEDLER2]
    path = /home/checker/Desktop/
    guest ok = yes
    case sensitive = no
    msdfs proxy = no

    :hilfe2: :hilfe2: :hilfe2: :hilfe2:
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 10.09.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Poste mal deine gesamt smb.conf.
     
  4. #3 satisfied, 10.09.2006
    satisfied

    satisfied Mitglied

    Dabei seit:
    09.09.2006
    Beiträge:
    32
    Zustimmungen:
    0
    Wenn Schreib - Zugriff für alle, dann Zeilen anfügen
    Code:
    public = yes            # Zugriff für alle
    read only = no        # Schreibzugriff
    browseable = yes  
    
    Und in der [global] hinzufügen:
    Code:
    security = share
    Mein Desktop Zugriff mit Passwort:
    Code:
    [Desktop]
            path = /home/daniel/Desktop
            comment = Daniel Desktop
            valid users = daniel
            public = No
            writable = Yes
    
     
  5. #4 vektorzeit, 10.09.2006
    vektorzeit

    vektorzeit Jungspund

    Dabei seit:
    09.09.2006
    Beiträge:
    15
    Zustimmungen:
    0
    Es funktioniert nicht.
    Die Änderungen habe ich probiert.
    Ich weiß nicht was ich falsch mache!
    Falls jemand mehr weiß, bitte helfen.
    Danke








    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    # Date: 2006-05-02
    [global]
    workgroup = TUX-NET
    printcap name = cups
    cups options = raw
    map to guest = Bad User
    include = /etc/samba/dhcp.conf
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    domain master = No
    usershare max shares = 100
    security = user
    domain logons = No

    [siedler2]
    path = /home/checker/Desktop/Siedler2
    guest ok = yes

    case sensitive = no
    msdfs proxy = no
    public = yes
    read only = no
    browesable = yes
     
  6. Lumpi

    Lumpi Haudegen

    Dabei seit:
    14.06.2006
    Beiträge:
    663
    Zustimmungen:
    0
    Ort:
    Dessau
    Hallo,

    Was für einen Client verwendest du?
    Wenn Du z.B. Windows ne Firewall verwendest, hast du dein internes Netz erlaubt?
    Sonst kannst du zwar die Freigaben (teilweise) sehen, aber der Zugriff wird dann geblockt...

    Gruß
    Lumpi
     
  7. #6 FalseCAM, 10.09.2006
    Zuletzt bearbeitet: 10.09.2006
    FalseCAM

    FalseCAM Tripel-As

    Dabei seit:
    24.12.2005
    Beiträge:
    155
    Zustimmungen:
    0
    Benutze doch bitte beim nächsten Mal einen angemesseneren Titel!
    Wenn du noch keinen Samba Benutzer erstellt hast, dann mache dies mit: "smbpasswd -a USERNAME"
     
  8. #7 vektorzeit, 10.09.2006
    vektorzeit

    vektorzeit Jungspund

    Dabei seit:
    09.09.2006
    Beiträge:
    15
    Zustimmungen:
    0
    Hey Lumpi ich geh einfach über smb://ip per Konqueror auf die Daten drauf.
    Es ist egal ob ich es vom Localhost oder vom Netzwerrechner anzusprechen versuche. Ist immer dasselbe Problem... bla bla Ordner exisiert nicht!

    Die Kritik zum angemessenen Titel ist berechtigt. Beim nächsten Mal werde ich darauf achten!
     
  9. #8 Lumpi, 10.09.2006
    Zuletzt bearbeitet: 10.09.2006
    Lumpi

    Lumpi Haudegen

    Dabei seit:
    14.06.2006
    Beiträge:
    663
    Zustimmungen:
    0
    Ort:
    Dessau
    Hallo,
    entferne doch mal Die proxy-share-Umleitung. Viell. stört diese ja?
    Was ich nicht verwende, muss ich auch nicht unbedingt eintragen. *find*

    Gruß Lumpi

    [EDIT]
    Im Übrigen können nur Dfs root-User als Proxy-Share agieren.
    Ob der Parameter "NO" funktioniert, weis ich nicht.
    IMHO müsstes du sonst noch den Parameter msdfs root = jes eintragen und die Share-Directory wie folgt angebeben.

    msdfs:serverA\\shareA,serverB\\shareB
     
  10. #9 Kesar_Neron, 10.09.2006
    Kesar_Neron

    Kesar_Neron Tripel-As

    Dabei seit:
    25.03.2006
    Beiträge:
    218
    Zustimmungen:
    0
    Rechte

    ich tippe ganz einfach auf ein rechteproblem.
    ändere doch mal den pfad zu deinem desktop in z.B. /tmp oder so... irgendwo hin, wo jeder zugriff hat (777)
    Order müssen auch ausführbar sein, da man sie sonst nicht öffnen kann und sie daher nicht existent sind...
    egal... check das mit den rechten einfach mal. wenn du den ordner /tmp freigeben kannst, kannst du dir sicher sein, dass es was mit rechten zu tun hat.

    gruß
     
  11. Lumpi

    Lumpi Haudegen

    Dabei seit:
    14.06.2006
    Beiträge:
    663
    Zustimmungen:
    0
    Ort:
    Dessau
    Warum komme ich auf sowas nicht? ;)
    Viell. existiert ja dann auch der ganze Ordner nicht an der gesuchten Stelle?

    Gruß Lumpi
     
  12. #11 satisfied, 10.09.2006
    Zuletzt bearbeitet: 10.09.2006
    satisfied

    satisfied Mitglied

    Dabei seit:
    09.09.2006
    Beiträge:
    32
    Zustimmungen:
    0
    Statt "security=user" würde ich "security=share" einstellen. Und im [siedler2] vielleicht noch "guest ok" raus bzw in [global]. Wenn das ein Share für alle sein soll.

    Simple conf für ein public Share:
    Code:
    # This is /usr/local/samba/lib/smb.conf
    
    [global]
       netbios name = BIGSERVER
       workgroup = WORKGROUP
       log level = 2
       log file = /usr/local/samba/var/samba.log
       security = share
    
    [pub]
       path = /home/public
       browseable = yes
       public = yes     # keine Passwortprüfung
       read only = no # beschreibbar
    
    Die Einstellung in /etc/sysconfig/iptables evtl. noch überprüfen, ob die Samba - Ports alle frei sind.
    Code:
    -A RH-Firewall-1-INPUT -m state --state NEW -m udp -p udp --dport 137 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m udp -p udp --dport 138 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 139 -j ACCEPT
    Und wie weiter oben erwähnt, die Zugriffsrechte vom Share prüfen, am besten Eigentümer und Gruppe auf "nobody".
    Gruß
     
  13. #12 phrenicus, 11.09.2006
    phrenicus

    phrenicus Routinier

    Dabei seit:
    24.05.2006
    Beiträge:
    253
    Zustimmungen:
    0
    Ort:
    Tübingen, Germany
    Hallo,

    ja die Fehlermeldung ist doch an sich eindeutig. Entweder er hat den Pfad in der smb.conf falsch eingetragen (/home/checker/Desktop/siedler2 statt Siedler2), hier ist beim Pfad Groß- und Kleinschriebung zu beachten, oder der User nobody, als der er dann zugreift, hat keinerlei Rechte auf /home/checker/Desktop und sieht deshalb das Verzeichnis Siedler2 nicht einmal.
    Auf die Gefahr hin, mich zum 1000. Mal zu wiederholen: Über 90% der SAMBA-Probleme kommen daher, dass die Leute das Filesystem falsch konfigurieren. Da kann man dann in der smb.conf tausend Sachen einstellen, es wird nie funktionieren, wenn es im Filesystem verboten ist.

    Gruß
     
  14. #13 MadJoker, 11.09.2006
    MadJoker

    MadJoker Tripel-As

    Dabei seit:
    06.06.2006
    Beiträge:
    219
    Zustimmungen:
    0
    Ort:
    Tampa, FL
    Falls es doch ein rechteprolem ist kann man ja immer noch den User auf den besitzer der Home verzeichnisses ändern oder gleich auf root.

    oder

     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Peregrine, 11.09.2006
    Peregrine

    Peregrine Honorarkonsul

    Dabei seit:
    03.08.2006
    Beiträge:
    338
    Zustimmungen:
    0
    Ort:
    München, Bayern, Germany
    Ich tippe auch auf ein Rechteproblem.
    Persönlich würde ich so vorgehen - du richtest einen Guest-User auf deinem *nix-System an, der entsprechen isoliert ist. Dann stellst du sicher, dass der User auf das "Siedler"-Verzeichnis zugreifen kann. Dann fügst du Folgendes in deine cfg ein.

    Code:
    map to guest = Bad User
    guest account = unixguest
    und dann stellst du sicher, dass guest ok = yes gesetzt ist - evtl. erkennt der Samba deinen User nicht und so kannst du generell erstmal das Verzeichnis freigeben. Viele Leute sind damit schon zufrieden :-)
    ________________________________________
    Um tiefer hinter das Problem zu steigen, würde ich das logging anwerfen. In die cfg
    Code:
    [/FONT]log level = 2
    log file = /var/log/samba.log.%m
    
    Dann versuchst du einen weiteren Zugriff; nach Scheitern kuckst du ins log-File und bist hoffentlich dann schlauer. Wenn nein, poste den Inhalt (tail -n20 /var/log/samba.log) in den Thread...
     
  17. #15 vektorzeit, 11.09.2006
    vektorzeit

    vektorzeit Jungspund

    Dabei seit:
    09.09.2006
    Beiträge:
    15
    Zustimmungen:
    0
    Hallo, vielen Dank für eure vielen Hinweise!!!
    Es lag tatsächlich nur daran, dass kein User angelegt war.
    Sorry, dass ich so duselig war.
     
Thema:

Könnt so kotzen (Samba Problem)

Die Seite wird geladen...

Könnt so kotzen (Samba Problem) - Ähnliche Themen

  1. Eu-Richtlinie für Funknetzsicherheit könnte freier Software schaden

    Eu-Richtlinie für Funknetzsicherheit könnte freier Software schaden: 23 Organisationen, darunter die Free Software Foundation Europe (FSFE), haben sich zusammengeschlossen, um die von der Europäischen Union bereits...
  2. Ubuntu 16.04 LTS könnte Canonicals letzte 32-Bit Veröffentlichung werden

    Ubuntu 16.04 LTS könnte Canonicals letzte 32-Bit Veröffentlichung werden: Ubuntu-Entwickler Bryan Quigley überlegt derzeit, einen Vorschlag zu machen, der mit Ubuntu 16.04 LTS den Anfang vom Ende von Installationen auf...
  3. Diese URL könnte für euch von Interesse sein

    Diese URL könnte für euch von Interesse sein: http://blog.br-online.de/report-muenchen/2010/09/03/neue-chips-im-visier-der-kreditkartenmafia.html
  4. Farblaser+Kopierer - Was könnt ihr empfehlen?

    Farblaser+Kopierer - Was könnt ihr empfehlen?: Hi! Bei mir steht langsam ein neuer Drucker an und da die Preise für Laserdrucker in den letzten Jahren stark gefallen sind, bin ich am...
  5. Nächste LTS-Version von Ubuntu könnte später kommen

    Nächste LTS-Version von Ubuntu könnte später kommen: Ubuntu-Gründer Mark Shuttleworth deutete in einen Interview an, dass sich die nächste Ubuntu-Version mit verlängertem Support auf Oktober 2010...