Keyb.Layout GERMAN bei Notebooks

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von odcheck, 25.02.2004.

  1. #1 odcheck, 25.02.2004
    odcheck

    odcheck Jungspund

    Dabei seit:
    24.02.2004
    Beiträge:
    15
    Zustimmungen:
    0
    Folgendes Redhat 9 shrike - i386 installiert
    Kernel: 2.2.20-8
    XFree bereits auf 4.3.0-2.90.55 geupped ohne Erfolg
    Jetzt kommts
    Wenn ich in INIT 3 starte sprich kein xwindows kde blahfassel sprich kein xserver dann funktioniert die AltGr Taste (oder Alt_R) ich kann @, € und so weiter erzeugen die Umlaute gehen natürlich auch.
    In xwindows keine Chance. Mit dem Befehl "xev" kann ich mir anzeigen lassen das er die Taste erkennt. Toll!
    - habe mal mittels # xmodmap -pm > /tmp/test_pm
    und
    # xmodmap -pk > /tmp/test_pk die Ausgabe in eine Datei schreiben lassen und diese angeschaut. Schön.

    Kurzum das gleiche mal mit SUSE versucht da geht es natürlich... :-(
    da deutsche distri... An einem "normalen PC" kein Notebook geht es auch mit Redhat einwandfrei. So also was ist der Unterschied zwischen Suse und Redhat was die XFree86Config und die xmodmap angeht siehe da es gibt einen.
    FRAGE kann ich die xmodmap einfach kopieren.???
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 odcheck, 01.03.2004
    odcheck

    odcheck Jungspund

    Dabei seit:
    24.02.2004
    Beiträge:
    15
    Zustimmungen:
    0
    Wie es geht

    Ich habe die Möglichkeit direkt mit den Leuten von Redhat zu kommunizieren und die haben mir den Fehler bestätigt.
    Das ich auf die Lösung letzt endlich selbst gestoßen bin davon waren Sie peinlich berührt.

    Es ist so Simpel

    Bei der Standardmäßigen Installation auf einem Handelsüblichen Notebook mit deutschen Keyboard Layout unter Verwendung von Redhat 9. Wird die XFree86Config fehlerhaft erstellt.

    Standard trotz korrekter Auswahl bei der Installation auch nachträglich über "redhat-config-keyboard".
    - XkbLayout "pc102"
    - XkbLanguage "us"
    - XkbDisable

    - Es ist zu ändern :
    "Input Section"
    XkbLanguage "de"
    XkbLayout "pc105"
    und
    - XkbDisable auskommentieren !!! Erst nach dem auskommentieren oder entfernen dieser Option hat man Zugriff auf die AltGr (Alt_R) Taste.

    vergleicht man mit dem Befehl "xmodmap" die Ausgabe unter Suse und Redhat dann sieht man genau den Unterschied bei der Belegung von "mod5".

    Redhat ist dran dies nachträglich über ein "Patch" zu ändern.

    Achtet mal drauf ob Sie es richtig machen oder doch nur "XkbDisable" auskommentiert wurde.... :-)
     
Thema:

Keyb.Layout GERMAN bei Notebooks

Die Seite wird geladen...

Keyb.Layout GERMAN bei Notebooks - Ähnliche Themen

  1. Humble Bundle - Germany Edition vorgestellt

    Humble Bundle - Germany Edition vorgestellt: Das Humble-Bundle-Team hat ein weiteres Humble Indie Bundle geschnürt. Unter dem Titel »The Humble Weekly Bundle: German Edition« finden sich...
  2. Kile und ngerman

    Kile und ngerman: Fange gerade an mich in kile (ver. 1.8) einzuarbeiten. Kann mir jemand sagen, wohin ich das ngerman package kopieren muss, damit kile drauf...
  3. how to flame in german

    how to flame in german: http://www.newgrounds.com/portal/view.php?id=151783 Auf "Play this games" klicken :D
  4. German Language-File für Opera 7.11

    German Language-File für Opera 7.11: Endlich gibts die Deutschen Language-files für die aktuelle (Linux)Opera Version 7.11: http://www.opera.com/download/languagefiles/