Kernelproblem...

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Marco, 07.07.2002.

  1. Marco

    Marco Routinier

    Dabei seit:
    15.04.2002
    Beiträge:
    267
    Zustimmungen:
    0
    Ort:
    München
    Ich hab Debian Woody mit dem Defaultkernel (2.2.20-idepci) installiert und wollte jetzt im Nachhinein den Kernel auf 2.4.18-k7 updaten.

    Also schnell mal apt-get install kernel-image-2.4.18-k7 ausgeführt, LILO konfiguriert, neu gestartet und es lief... Mit Ausnahme des Internets. Er kann keine DSL Verbindung mehr aufbauen...

    Hat wer ne Lösungsidee? Oder das selbe Problem?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Andre, 07.07.2002
    Zuletzt bearbeitet: 07.07.2002
    Andre

    Andre Foren Gott
    Moderator

    Dabei seit:
    01.04.2002
    Beiträge:
    3.876
    Zustimmungen:
    0
  4. #3 devilz, 07.07.2002
    Zuletzt von einem Moderator bearbeitet: 07.07.2002
    devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    hmmm netzwerkkarte wurde beim booten initialisiert ?
    bzw. kannste sonst mit der netzkarte arbeiten ?
     
  5. rup

    rup Haudegen

    Dabei seit:
    10.04.2002
    Beiträge:
    627
    Zustimmungen:
    0
  6. rup

    rup Haudegen

    Dabei seit:
    10.04.2002
    Beiträge:
    627
    Zustimmungen:
    0
    Ach ja, du must dir keinen eigenen Kernel erstellen, der Standard Kernel und die passenden Module reichen.
     
  7. Marco

    Marco Routinier

    Dabei seit:
    15.04.2002
    Beiträge:
    267
    Zustimmungen:
    0
    Ort:
    München
    @rup, hast du mit bf24 installiert oder hast du mit idepci installiert und dir dann über apt-get des Kernel Image geladen?

    Neuer Stand der Dinge ist folgender:
    Installiere ich mit bf24, startet er die Karte mit dem Modul 8319cp, meldet aber dass ich 8139too verwenden soll. Trotzdem fährt er eth0 hoch. Verwendbar ist sie weder im LAN noch für DSL. Zum Modul 8139too kann ich nicht wechseln, da es bei bf24 nicht dabei ist.

    Installiere ich idepci, funktioniert alles problemlos mit dem Modul rtl8139. Wenn ich dann über apt-get Kernel-Image-2.4.18-k7 runterlade, installiere und boote, geht meine Karte nicht mehr. (Ist klar warum!) Konfiguriere ich die Karte so, dass das Modul 8139too verwendet wird, geht wieder nix *arg* Immerhin krieg ich die folgende Fehlermeldung:
    NETDEV WATCHDOG: eth0: transmited time out

    Dann kommt noch ne Meldung die ich ned 100%ig wiedergeben kann, in der mir aber mitgeteilt wird, dass die Karte auf Halbduplex aufgrund der Fähikgeiten des Partners gesetzt wird (-> DSL-Modem, 10 Mbit Ethernet).

    Noch ne Idee? *verzweifel*

    PS: Komische Sache, aber kein andres Linux mit 2.4.18´er hat Probleme mit der Karte! (trotz gleichem Modul -> Red Hat 7.3)
     
  8. Marco

    Marco Routinier

    Dabei seit:
    15.04.2002
    Beiträge:
    267
    Zustimmungen:
    0
    Ort:
    München
    So die Frage geht jetzt an die deutsche Debian User Mailinglist. Ich hab kein Bock mehr!!
     
  9. rup

    rup Haudegen

    Dabei seit:
    10.04.2002
    Beiträge:
    627
    Zustimmungen:
    0
    hab den kernel mit dselect installiert, in /etc/lilo.conf folgende Zeile eingefuegt
    initrd=/initrd.img
    dselect hat nach Nachfrage noch den Link in / erstellt und das war´s.
     
  10. Marco

    Marco Routinier

    Dabei seit:
    15.04.2002
    Beiträge:
    267
    Zustimmungen:
    0
    Ort:
    München
    Gleiche Prozedur wie bei mir...
     
  11. Marco

    Marco Routinier

    Dabei seit:
    15.04.2002
    Beiträge:
    267
    Zustimmungen:
    0
    Ort:
    München
    Haltet mich für bescheuert, aber mir weiß keiner mehr zu helfen. Ich hab von a-z alles durchprobiert (selbst nen eigenen Kernel kompiliert) und es geht einfach nicht.

    Fazit: Ich kauf mir ne andre Netzwerkkarte. Eine die sicher läuft, ein teures, gutes Modell ;)
     
  12. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  13. rup

    rup Haudegen

    Dabei seit:
    10.04.2002
    Beiträge:
    627
    Zustimmungen:
    0
    Wenn du eine neue Netzwerkkarte fuer Linux brauchst, kann ich dir die aller billigste NE2000 kompatieble (meist mit einem Realtec Chip) Karte empfehlen (fuer ca. 10 - 15 Euro), Ich habe mehrere im Einsatz, ISA und PCI und keinerlei Probleme damit. Allerdings habe ich nur 10 Mbit Karten, wie die 10/100´er Karten funzen kann dir sicher jemand anderer sagen.
     
  14. Marco

    Marco Routinier

    Dabei seit:
    15.04.2002
    Beiträge:
    267
    Zustimmungen:
    0
    Ort:
    München
    Hab mir jetzt die hier 2x bestellt: http://www.linkpro.com.tw/tl4500e.htm

    Wenn die bei mir ned geht verkauf ich die eben an die Schülerzeitung meiner Schule (als Chefredakteur ist das ja kein Problem *fg*)
     
Thema:

Kernelproblem...

Die Seite wird geladen...

Kernelproblem... - Ähnliche Themen

  1. VirtualBox Kernelproblem?

    VirtualBox Kernelproblem?: Folgende Ausgabe wenn ich vb starte: [devanet@fedora7 ~]$ VirtualBox WARNING: The vboxdrv kernel module is not loaded. Either there is no module...