Kernel 2.6 Kein Netzwerk

Dieses Thema im Forum "Linux OS" wurde erstellt von flammenflitzer, 17.01.2004.

  1. #1 flammenflitzer, 17.01.2004
    flammenflitzer

    flammenflitzer Routinier

    Dabei seit:
    26.12.2003
    Beiträge:
    388
    Zustimmungen:
    0
    Hallo
    Ich habe unter Gentoo den Kernel 2.6-win4lin kompilliert. Bin kein Insider, habe aber schon einige Kernel kompilliert. Habe mit die Konfiguration von meinem letzten Kernel vorsichtshalber noch mal ausgedruckt und zum Vergleich unter die Nase gehalten. Aber ich bekomme eth0 und eth1 nicht zum laufen. Ich habe auch keinen Ansatz, was ich hier an Infos anbieten sollte. Ich habe mal Auszugsweise die logs untereinander gepackt.
    2.4
    Jan 15 15:23:15 Roadrunner PCI: Setting latency timer of device 00:07.5 to 64
    Jan 15 15:23:15 Roadrunner 8139too Fast Ethernet driver 0.9.26
    Jan 15 15:23:15 Roadrunner eth0: RealTek RTL8139 at 0xe0a36000, 00:50:ba:d4:9d:42, IRQ 11
    Jan 15 15:23:15 Roadrunner eth0: Identified 8139 chip type 'RTL-8139B'
    Jan 15 15:23:15 Roadrunner eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
    Jan 15 15:23:16 Roadrunner CDCEther.c: CDCEther.c: 0.98.6 7 Jan 2002 Brad Hards and another
    Jan 15 15:23:16 Roadrunner usb.c: registered new driver CDCEther
    Jan 15 15:23:16 Roadrunner CDCEther.c: Ethernet information found at device configuration. Trying to use it anyway.
    Jan 15 15:23:16 Roadrunner CDCEther.c: Found Header descriptor, CDC version 110.
    Jan 15 15:23:16 Roadrunner CDCEther.c: Imperfect filtering support - need sw hashing
    Jan 15 15:23:16 Roadrunner CDCEther.c: Can't use SetEthernetMulticastFilters request
    Jan 15 15:23:16 Roadrunner CDCEther.c: Ethernet information found at device configuration. Trying to use it anyway.
    Jan 15 15:23:16 Roadrunner CDCEther.c: Found Header descriptor, CDC version 110.
    Jan 15 15:23:16 Roadrunner CDCEther.c: Imperfect filtering support - need sw hashing
    Jan 15 15:23:16 Roadrunner CDCEther.c: Can't use SetEthernetMulticastFilters request
    Jan 15 15:23:16 Roadrunner CDCEther.c: Ethernet information found at device configuration. Trying to use it anyway.
    Jan 15 15:23:16 Roadrunner CDCEther.c: Found Header descriptor, CDC version 110.
    Jan 15 15:23:16 Roadrunner CDCEther.c: Probably broken Union descriptor, fudging data interface.
    Jan 15 15:23:16 Roadrunner CDCEther.c: Imperfect filtering support - need sw hashing
    Jan 15 15:23:16 Roadrunner CDCEther.c: Can't use SetEthernetMulticastFilters request
    Jan 15 15:23:16 Roadrunner CDCEther.c: detected BULK OUT packets of size 64
    Jan 15 15:23:16 Roadrunner CDCEther.c: interrupt address: 5
    Jan 15 15:23:16 Roadrunner CDCEther.c: interrupt interval: 64
    Jan 15 15:23:16 Roadrunner CDCEther.c: eth1: Motorola Corporation SB4100 USB Cable Modem 00080E51EE73
    Jan 15 15:23:16 Roadrunner CDCEther.c: eth1: 00:08:0E:51:EE:73
    Jan 15 15:23:16 Roadrunner CDCEther.c: eth1: set multicast filters
    Jan 15 15:23:16 Roadrunner CDCEther.c: eth1: too many MC filters for hardware, using allmulti
    Jan 15 15:23:16 Roadrunner CDCEther.c: eth1: too many MC filters for hardware, using allmulti
    Jan 15 15:23:16 Roadrunner CDCEther.c: eth1: too many MC filters for hardware, using allmulti
    Jan 15 15:23:17 Roadrunner usb.agent[1562]: ... no modules for USB product 0/0/0
    ##################################################
    ##################################################
    #####################################Jan
    2.6
    15 15:13:52 Roadrunner
    Jan 15 15:13:52 Roadrunner drivers/usb/input/hid-core.c: ctrl urb status -104 received
    Jan 15 15:13:52 Roadrunner drivers/usb/input/hid-core.c: timeout initializing reports
    Jan 15 15:13:52 Roadrunner
    Jan 15 15:13:52 Roadrunner drivers/usb/input/hid-ff.c: hid_ff_init could not find initializer
    Jan 15 15:13:52 Roadrunner input: USB HID v1.00 Mouse [Logitech Inc. iFeel MouseMan] on usb-0000:00:07.2-2
    Jan 15 15:13:52 Roadrunner hub 2-0:1.0: new USB device on port 1, assigned address 2
    Jan 15 15:13:52 Roadrunner drivers/usb/input/hid-ff.c: hid_ff_init could not find initializer
    Jan 15 15:13:52 Roadrunner input: USB HID v1.00 Joystick [Saitek Saitek X36] on usb-0000:00:07.3-1
    Jan 15 15:13:52 Roadrunner pci.agent[3362]: ... no modules for PCI slot
    Jan 15 15:13:52 Roadrunner pci.agent[3379]: ... no modules for PCI slot
    Jan 15 15:13:52 Roadrunner pci.agent[3396]: ... no modules for PCI slot
    Jan 15 15:13:52 Roadrunner pci.agent[3413]: ... no modules for PCI slot
    Jan 15 15:13:52 Roadrunner pci.agent[3430]: ... no modules for PCI slot
    Jan 15 15:13:52 Roadrunner pci.agent[3447]: ... no modules for PCI slot
    Jan 15 15:13:53 Roadrunner pci.agent[3464]: ... no modules for PCI slot
    Jan 15 15:13:53 Roadrunner pci.agent[3481]: ... no modules for PCI slot
    Jan 15 15:13:53 Roadrunner pci.agent[3498]: ... no modules for PCI slot
    Jan 15 15:13:53 Roadrunner pci.agent[3516]: ... no modules for PCI slot
    Jan 15 15:13:53 Roadrunner ohci_hcd: 2003 Oct 13 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
    Jan 15 15:13:53 Roadrunner ohci_hcd: block sizes: ed 64 td 64
    Jan 15 15:13:53 Roadrunner usb.agent[3544]: ... no modules for USB product 0/0/0
    Jan 15 15:13:53 Roadrunner usb.agent[3559]: ... no modules for USB product 0/0/0
    Jan 15 15:13:53 Roadrunner usb.agent[3574]: ... no modules for USB product 0/0/0
    Jan 15 15:13:53 Roadrunner usb.agent[3589]: ... no modules for USB product 0/0/0
    Jan 15 15:13:53 Roadrunner usb.agent[3604]: ... no modules for USB product 0/0/0
    Jan 15 15:13:56 Roadrunner rc-scripts: Failed to bring eth0 up
    Jan 15 15:13:56 Roadrunner rc-scripts: Failed to bring eth1 up
    Jan 15 15:13:56 Roadrunner rc-scripts: ERROR: Problem starting needed services.
    Jan 15 15:13:56 Roadrunner rc-scripts: "netmount" was not started.
    Jan 15 15:13:56 Roadrunner cron[4070]: (CRON) STARTUP (fork ok)
    Also sieht aus als ob das irgendwas mit pci zu tun hat. Habe aber alle Optionen von 2.4 soweit möglich übernommen.
    Hat jemand eine Idee.
    Ich denke nicht, das es an den Netzwerkkarten liegt, da ja sonst eine mindestens funktionieren sollte.
    eth0 DRN-32TX Fast Ethernet
    eth1Motorola SB4100 USB Cable Modem
    Welche Infos wären noch hilfreich?
    :help:
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 MTS, 17.01.2004
    Zuletzt bearbeitet: 17.01.2004
    MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    1.hast du die Treiber für deine Netzwerkkarte als Modul oder Fest einkompiliert?
    2. Was sagt er denn wenn du "ifconfig eth0 up" eingibst??
    3. Poste mal aus /etc/conf.d/ die net.eth0 (wenns die gibt) und die net datei

    Bei dem 2.4er log hast du :
    Jan 15 15:23:15 Roadrunner eth0: RealTek RTL8139 at 0xe0a36000, 00:50:ba:d4:9d:42, IRQ 11
    Jan 15 15:23:15 Roadrunner eth0: Identified 8139 chip type 'RTL-8139B'
    Jan 15 15:23:15 Roadrunner eth0: link up, 100Mbps, full-duplex, lpa 0x41E1

    Das vermisse ich bei dem 2.6er ... du musst glaub ich mehr von dem Log posten ... // zur übersichtlichkeit pack die ausgaben bitte in dateien und häng diese an ;)
     
Thema:

Kernel 2.6 Kein Netzwerk

Die Seite wird geladen...

Kernel 2.6 Kein Netzwerk - Ähnliche Themen

  1. Kein WLAN mit eigenem Kernel 2.6.31

    Kein WLAN mit eigenem Kernel 2.6.31: [GELÖST] Kein WLAN (Intel) mit eigenem Kernel 2.6.31 Hallo, ich habe mir gestern einen eigenen Vanilla-RT-Kernel (2.6.31-rt11) mit ein paar...
  2. Linux Kernel Summit: Kein Linux 3.0

    Linux Kernel Summit: Kein Linux 3.0: Der Linux-Entwicklungsprozess wird sich wohl nicht wesentlich ändern - ein kurzer Bericht vom ersten Tag des Linux Kernel Summit. Weiterlesen...
  3. KDE Kontrollzentrum (Toshiba Notebook) Fehler: Kein Toshiba kernel module gefunden

    KDE Kontrollzentrum (Toshiba Notebook) Fehler: Kein Toshiba kernel module gefunden: Hallo Leuts, ...schon wieder das Toshiba Portege r500 ( ppr50e-03902MGR ).... Diesmal: Die FN-Tasten funktionieren nicht richtig...
  4. Nach Kernelupgrade kein OpenGL/WINE mehr

    Nach Kernelupgrade kein OpenGL/WINE mehr: Hallo, ich habe kürzlich meinen Kernel durch den Autoupdater aktualisieren lassen (2.6.18.2-34 → 2.6.18.8-0.5). Weil danach Suspend to Disk...
  5. nach kernel update kein inet

    nach kernel update kein inet: bin neu hier und darum erstmal "hallöchen zusamm"! mal ne frage,habe über yast den kernel geupdatet und sollte vor dem neu booten wenn ich lo...