Kernel-2.6.7 - Kleine Fehler in der dmesg

Dieses Thema im Forum "Linux OS" wurde erstellt von Zico, 17.07.2004.

  1. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Hi
    Hab grad den neuen Kernel draufgebügelt und wollt nun ma frägen ob jemand was mit diesen paar kleien Fehlern anfangen kann, die ich im Protokoll entdeckt habe:
    ANM - ich verwend SuSE 9.1

    1)
    Failed to disable AUX port, but continuing anyway... Is this a SiS? [ANM - jepp isses - Asche auf mein Haupt]
    If AUX port is really absent please use the 'i8042.noaux' option.

    2)
    Resume Machine: resuming from /dev/hda2
    Resuming from device hda2
    Resume Machine: This is normal swap space
    PM: Reading pmdisk image.
    PM: Resume from disk failed.

    ANM - Hat das was mit dem Grub Eintrag "resume=/dev/hda2" zutun? Wenn ja was und ist es gut es zu deaktivieren? War standarmäßig bei der SuSE Install mit drin.

    3)
    hda: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
    hda: drive_cmd: error=0x04 { DriveStatusError }
    hdb: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
    hdb: drive_cmd: error=0x04 { DriveStatusError }

    hda und hda sind meine beiden WD Platten. Hört sich fast nach Defakt an, die Teile sind aber realtiv neu und Fehler erst seit dem neuen Kernel.

    So... mehr hab ich nicht gesehen. Hat wer auf einen oder mehrere Punkte nen Ansatz?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Bonk

    Bonk Tripel-As

    Dabei seit:
    07.10.2003
    Beiträge:
    240
    Zustimmungen:
    0
    Hi!

    2. Könnte etwas mit suspend-to-disk zutun haben.

    3. Platte ist im Eimer.
     
  4. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Zu 3)
    Nach nem Kernel Update gehen 2 (je 2 und 5 Monate alte Platten) schlagartig kaputt? ?(
    Reife Leistung vom Kernel
     
  5. saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    Ort:
    Sachsen/ Meerane
    Ich würde sagen 3. hat eher was mit 2. zu tun.
    und 2. hat definitiv was mit dem resume ausm grub zu tun. kannste in der grub.conf abschalten, bzw. ausommentieren, sollte keine auswirkungen haben, außer das du dann halt kein suspend to disk hast.
     
  6. #5 Zico, 17.07.2004
    Zuletzt bearbeitet: 02.08.2004
    Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Ok, also ich habe nun das resume aus dem Grub weggemacht und die entsprechende meldung verschwand.
    Dies:
    hda: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
    hda: drive_cmd: error=0x04 { DriveStatusError }
    hdb: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
    hdb: drive_cmd: error=0x04 { DriveStatusError }
    hab ich dennoch.

    Btw habe ich langsam den Verdacht, dass dies irgendwie etwas mit meiner fstab in Verbindung mit meinem mittlerweile deaktivierten und auscompilierten automounter von SuSE zutun hat.
    Denn ich habe mittlerweile ein anderes Problem gehabt und auch gelöst.
    Folgendermaßen:
    NAch der compilierung des Kernels war SuSE noch auf automount eingerichtet , doch der Kernel wies mich darauf hin, dass dies nicht unterstützt sei.

    Also habe ich meine fstab Einträge dementsprechend geändert:

    Vorher:
    /dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
    /dev/dvdrecorder /media/dvdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
    /dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0

    Nachher:
    /dev/cdrecorder /media/cdrecorder auto ro,noauto,user,exec,iocharset=utf8 0 0
    /dev/dvdrecorder /media/dvdrecorder auto ro,noauto,user,exec,iocharset=utf8 0 0
    /dev/fd0 /media/floppy auto noauto,user,exec,sync 0 0

    Dann kam aber beim booten vom cdrecorder ebenfalls
    hdd: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
    hdd: drive_cmd: error=0x04 { DriveStatusError }
    hdd: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
    hdd: drive_cmd: error=0x04 { DriveStatusError }
    [Wiederholungen ca 40-50 mal.]
    In SuSE 9.0 habe ich dieses Problem gelöst, indem ich ihn auf SCSI Emulation schlatete.
    Gesagt getan - GRUB hdd=scsi
    dann "mount /dev/sr0 /media/cdrecorder" --> Systemabsturz.
    Ich nehm einfach mal an, dass der ide-cd nen Problem mit dem Brenner hat... war ja wie gesagt schon früher so. GELÖST habe ich es nun damit, indem ich ihn wieder über ide-cd laufen lasse und den Eintrag in der fstab enbtsprechend abgeändert habe:

    SO:
    /dev/hdd /media/cdrecorder auto
    fs=cdfss,ro,procuid,nosuid,noauto,user,exec,iocharset=utf8 0 0

    Nun funktioniert das alles. Er läuft per ide-cd, keine fehlermeldungen und keine Abstürze.
    Also: ist der Eintrag so in Ordnung? Wenn ich das nun richtig verstanden habe, sind die einzigen änderungen, die ich eingetragen habe:
    von subfs --> auto = kein automounter
    fs=cdfss --> cd-filesystem (?)
    procuid,nosuid --> Benutzerrechte

    Korrigiert mich, wenn ich was falsch gemacht habe.

    Leider ist somit diese Fehlermeldung von hda und hdb aber noch nicht gelöst...
    Der Grund warum ich das nun schreibe... könnte das nen Zusammenhang haben?
    Ich weiss, dass die Platten das Problem erst seit dem neuen Kernel melden... Also schließe ich wie gesagt nen defekt aus.

    PROBLEME GELÖST:

    Workaround - HDA und HDB Errors:
    powersaved deaktivieren

    Workaround - CD-Writer IDE-CD/SCSI:
    1) Eintrag in /etc/fastab abändern:
    /dev/cdrecorder /media/cdrecorder iso9660 ro,noauto,user,exec,iocharset=utf8 0 0
    2) In /boot/grub/menu.lst folgende Option hinzufügen:
    hdd=cdrom
    Nun verursacht der Brenner keine Fehler mehr in der dmesg.
     
  7. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Ort:
    D -> BW -> Karlsruhe
    Ich hab FC2 und bei mir kommen nach einer gewissen Laufzeit die gleichen Fehlermeldungen. Kernel ist 2.6.5-1.358. Und die Platte ist definitiv in Ordnung. Aud meiner alten Platte war das gleiche System installiert, da hatte ich diese Meldung nicht.
    Die alte Platte hatte kein S.M.A.R.T., die neue schon. Haben Deine Platten zufällig auch diese Funktion ?
     
  8. #7 Zico, 18.07.2004
    Zuletzt bearbeitet: 18.07.2004
    Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Joa, smart haben die Platten, sind aber deaktiviert.
    EDIT: MAcht SMART die platten nicht sehr langsam?
     
  9. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Ort:
    D -> BW -> Karlsruhe
    Kann ich nicht sagen, ich hab es eingeschaltet, weil es ne FSC-Platte ist, und bei denen gabs mal massive Probleme. Ist die Baureihe MPG-3409, und bei denen war mal ne riesen charge fehlerhaft. Ich werd den Krempel jetzt aber auch mal abschalten, bzw. den smartd deaktivieren.
     
  10. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Also die Fehler mit hda und hdb hab ich partout nicht wegbekommen. auch nicht mit aktiviertem
    SMART.
    Und der CD-Brenner macht mir auch immer mehr Sorgen.
    Mit Kernel 2.4 funktionierte er standardmäßig mit SCSI Emulation. Im Kernel 2.6 funktionierte er auch perfekt mit SCSI Emulation - mit IDE-CD bekam ich die selben Fehler wie derzeit mit hda und hda ... nur öfter.. ne ganze dmesg voll.
    Nun , seit 9.1 geht er trotz neuem Kernel mal "halbwegs" mit SCSI Emulation...
    Lässt sich mounten und per Shell einsehen... Öffne ich jedoch den Mountpunkt per KDE kackt die Maschine ab... Könnte das damit zusammenhängen, dass ich /dev/sr0 direkt mit dem mountpunkt verbinde? vorher wurde /dev/hdd zu /dev/cdrecorder ... dies wird nun nicht mehr gelinkt [sprich von /dev/sr0 zu /dev/cdrecorder]... im YaST2 wird das Laufwerk auch gar nicht mehr erkannt...
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Ort:
    D -> BW -> Karlsruhe
    Hmm, ich hatte als kernel-option "hdb=ide-scsi" angegeben, dann war der fehler (beim cdrom, nicht bei der Platte) auch weg. Das deaktivieren des smartd hatte auch keine Besserung gebracht. Aber jetzt wo ich lese, dass Du den powersaved deaktiviert hast, wird mir einiges klarer. Der Fehler tritt bei mir ja wie gesagt nach einer gewissen Zeit ein, und zwar dann, wenn ich quasi nichts mit der Platte mache. Ich hatte schon intensiv files auf der Platte erzeugen, löschen und hin- und her kopieren lassen ohne das der Fehler auftrat.
    Jetzt ists klar warum :]
     
  13. #11 Zico, 19.07.2004
    Zuletzt bearbeitet: 02.08.2004
    Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Jepp das ist möglich. Nun kann ich mir auch (wenn auch unlogischerweise erklären), warum übertragungen von Laufwerken lahm war und brennen auf DVD meinen RAM zumüllte und nimmer freigab.
    Zu der SCSI-IDE Funktion:
    So hatte ich das mit Kernel 2.6.5 im SuSE 9.0 auch gelöst. Nur seit SuSE 9.1 kommt der KDE (oder ne andere SuSE ... "Funktion") damit nimmer zurecht und lässt, sobald der Konqueror auf den Mountpunkt zugreift den kompletten PC (oder zumindest XDM) komplett abstürzen.
    Daher musste ich so lang anderes Zeuch versuchen.

    EDIT1:
    Nachdem mit dem Brenner die Fehler gelegentlich - anscheinend völlig willkürlich - wieder auftauchten habe ich es wieder auf SCSI Emulaion gesetzt.
    Die Abstürze hab ich nun auch erfolgreich verhindert:
    sysconfig: FORCE_IDE_DMA /dev/hdd:on

    BTW. EVIL DEAD RULT :D
     
Thema:

Kernel-2.6.7 - Kleine Fehler in der dmesg

Die Seite wird geladen...

Kernel-2.6.7 - Kleine Fehler in der dmesg - Ähnliche Themen

  1. Kleine Frage (Solaris ein Cloud Betriebsystem?)

    Kleine Frage (Solaris ein Cloud Betriebsystem?): ′
  2. VoCore: Kleiner Open-Source-Platinenrechner mit OpenWrt

    VoCore: Kleiner Open-Source-Platinenrechner mit OpenWrt: VoCore ist Open Source, was Hard- und Software betrifft, kostet 20 US-Dollar und setzt beim Basteln eine Stufe tiefer an als der Raspberry Pi....
  3. Artikel: LibreOffice 5.0: Installation und kleiner Überblick

    Artikel: LibreOffice 5.0: Installation und kleiner Überblick: Es hat eine Weile gedauert, bis LibreOffice 5.0 schließlich in der finalen Version erschienen ist. Wir stellen Ihnen die neueste Version und auch...
  4. SSD auf einen (geringfügig) kleineren USB-Stick wiederherstellen

    SSD auf einen (geringfügig) kleineren USB-Stick wiederherstellen: Hallo, ich habe hier ein Ubuntu, instaliert auf einer SSD. Für einige Systemtests möchte ich das System auf einen USb-Stick klonen, der leider...
  5. Firefox 41 mit kleineren Neuerungen

    Firefox 41 mit kleineren Neuerungen: Nachdem Mozilla einige Neuerungen von Firefox verschoben hat, fallen die Änderungen der aktuell freigegebenen Version 41 eher bescheiden aus. Neu...