Kernel 2.6.3 ALSA Probleme

Dieses Thema im Forum "Linux OS" wurde erstellt von blue, 18.02.2004.

  1. blue

    blue Mitglied

    Dabei seit:
    06.01.2004
    Beiträge:
    36
    Zustimmungen:
    0
    Moin!

    Da im Kernel 2.6.3 die neue Schwachstelle in der Funtkion "do_mremap()" gefixed ist, habe ich den bei mir heute auch gleich eingespielt.

    Aber leider machen bei mir die Soundtreiber Probleme.
    Aus dem Changelog ist zu erkennen, dass im 2.6.3er die ALSA Treiber in der Version 1.0.2c (im 2.6.0-2.6.2 ALSA-0.9.7) implementiert sind und die machen bei mir mächtig Probleme.


    1. In XMMS (1.2.9) kann ich das ALSA output plugin nicht verwenden, da es beim Abspielen immer wieder zu Rucklern kommt und schließlich XMMS einfach beendet wird. Ich habe daraufhin XMMS aus der Konsole heraus gestartet und konnte daraufhin bei jedem Ruckler in der Konsole ein
    "** WARNING **: alsa_mmap_audio(): snd_pcm_mmap_commit returned 8820, expected 1" lesen. Mit dem OSS output plugin habe ich dieses Problem nicht.


    2. In Enemy Territory funktioniert der Sound garnicht mehr.
    (Richtige Zugriffsrechte für /dev/dsp sind gesetzt)


    Ich habe auch schon die alsalibs (auf 1.0.2) aktualisiert, was aber nichts gebracht hat.

    Hat jemand eine Idee, wie ich diese Probleme beseitigen kann, ohne die aktuellen ALSA's aus dem Kernel zu werfen und die 0.9.7er zu verwenden?

    Danke.

    mfg
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. chb

    chb Steirer

    Dabei seit:
    01.06.2003
    Beiträge:
    2.359
    Zustimmungen:
    0
    Ort:
    ÖSTERREICH
    zu 2.

    The solution is the following echo "nameofexecutable 0 0 direct" > /proc/asound/card0/pcm0p/ossWhere nameofexecutable is the Quake / RTCW / ET binary, just do that before you start the game.
     
  4. #3 blue, 18.02.2004
    Zuletzt bearbeitet: 19.02.2004
    blue

    blue Mitglied

    Dabei seit:
    06.01.2004
    Beiträge:
    36
    Zustimmungen:
    0
    Danke für die Hilfe.
    Es funktioniert aber leider nicht :-(

    Hat sonst noch jemand eine Idee, oder muss ich wirklich wieder die alten ALSAs installieren?

    mfg

    EDIT:
    Ich hab die do_mremap Schwachstelle "per Hand" geschlossen und hab jetzt den 2.6.2er am laufen.

    EDIT2:
    Hab mir jetzt ne neue Soundkarte angeschafft...Der AC'97 Chip hat aber auch genug Stress gemacht...
    jetzt läuft es auch mit dem 2.6.3er ohne Probleme
    :-)

    mfg
     
  5. Milbo

    Milbo Jungspund

    Dabei seit:
    27.02.2004
    Beiträge:
    10
    Zustimmungen:
    0
    Hehehe, ist es eigentlich wert sowas den entwicklerteam zu berichten?
    Ich denke mir das gerade, weil habe kein bock ne neue Soundkarte schon wieder wegen Treiberprobs anzuschaffen.
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Kernel 2.6.3 ALSA Probleme

Die Seite wird geladen...

Kernel 2.6.3 ALSA Probleme - Ähnliche Themen

  1. Sound Kernel 2.6 OSS vs ALSA

    Sound Kernel 2.6 OSS vs ALSA: Hallo, ich habe einen alten Laptop (Thinkpad 380XD) mit Etch drauf welches ALSA den vorzug gibt. Der Soundchip wird von ALSA nicht unterstützt...
  2. Alsasound probleme seit Kernel-2.6.15-gentoo-r1

    Alsasound probleme seit Kernel-2.6.15-gentoo-r1: Moin Moin Ich hab seit Kernel-2.6.15-gentoo-r1 Probleme mit Alsa. Nach jedem Neustart, oder aus- und wieder einloggen eines Users, bleiben...
  3. ALSA und Kernel 2.6.8

    ALSA und Kernel 2.6.8: Aloha... Ich hab nun schon etliches ausprobiert und gesucht, aber ich komme nicht mehr weiter. Ich habe auf Kernel 2.6.8 upgedated und dabei...
  4. nach Kernelupdate Soundprobleme (ALSA)

    nach Kernelupdate Soundprobleme (ALSA): Kernelupdate + Alsa Nach den ganzen 'Streit' hoffe ich ma', dass 'Installation & Konfiguration' der richtige Bereich ist... ;) Also, ich hab'...
  5. Hauppauge Win/TV - Kernel 2.6 - Alsa - No Sound :/

    Hauppauge Win/TV - Kernel 2.6 - Alsa - No Sound :/: Also ich bin kurz vorm verzweifeln ... nach knappen 20 Stunden des experimetierens funktioniert immernoch kein Sound mit meiner TV Karte....