Keine Grafik nach online Update

Dieses Thema im Forum "Grafik / Video" wurde erstellt von Matz, 27.03.2009.

  1. Matz

    Matz Foren As

    Dabei seit:
    06.01.2006
    Beiträge:
    96
    Zustimmungen:
    0
    Hallo,

    habe gerade ein Online-Update gemacht, Rechner startet aber jetzt ohne grafisches System. Der Versuch wird unternommen, bricht aber mit Fehlermeldung ab. Komandozeile klappt.
    Ich habe Suse 10.2 installiert, Grafikkarte ist ne Nvidia Gforce 6700 XL.
    Und weil die nicht schnell war unter Linux (keine 3D-Unterstützung) habe ich mal ein Update gemacht da auf der Nvidiaseite für meine Karte auch kein Treiber war.
    Gibt es irgend einen Befehl der mich erstmal wieder auf ein grafisches System bringen kann? Bin noch ne Weile in Spanien, all meine Linuxbücher in Deutsch sind aber noch in D.
    Gruß, Matz
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 gropiuskalle, 27.03.2009
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    1. Welche Fehlermeldung kommt denn da?

    2. Deine Karte müsste doch mit dem aktuellen 180er-Treiber laufen.

    3. Allerdings ist die 10.2 im Dezember aus dem support gerutscht, vor weiteren Schraubereien solltest Du ohnehin eine frischere SuSE aufspielen.

    4. Ein update macht noch keine 3D-Unterstützung, sondern ein entsprechender Treiber, nech?

    5. siehe 3.
     
  4. #3 Ritschie, 27.03.2009
    Zuletzt bearbeitet: 27.03.2009
    Ritschie

    Ritschie SuSE-User

    Dabei seit:
    10.09.2003
    Beiträge:
    1.216
    Zustimmungen:
    0
    Ort:
    D-Bayreuth
    Hey Matz,

    versuch's mal so:

    1. melde Dich als root an

    2. beende alle mit X zusammenhängenden Dienste mit dem Befehl
    Code:
    init 3
    3. konfiguriere X mit hilfe von sax neu
    Code:
    sax2 -r -m 0=nv
    4. zurück zu X mit
    Code:
    init 5
    Normalerweise dürfte dann die grafische Oberfläche in 2D wieder laufen. Falls es nicht funktioniert, bitte die Fehlermeldung posten. Antworten wie "bricht aber mit Fehlermeldung ab" helfen uns nicht weiter.

    3D kannst Du mit hilfe vom Nvidia_Howto_openSUSE zum Laufen bringen.

    Gruß,
    Ritschie

    P.S. ich würde gropiuskalle im übrigen zustimmen - ein Wechsel auf ne aktuellere openSUSE wäre schon alleine wegen den für die 10.2 nicht mehr erhältlichen Sicherheitsupdates durchaus sinnvoll.
     
  5. #4 Matz, 27.03.2009
    Zuletzt bearbeitet: 27.03.2009
    Matz

    Matz Foren As

    Dabei seit:
    06.01.2006
    Beiträge:
    96
    Zustimmungen:
    0
    Hallo gropiuskalle,

    danke für Deine Antwort, das mit den neuen Treibern hatte ich vor, aber wenn ich versuche den 180.29 zu laden, dann wird mir der ganze Bildschirm mit dem Inhalt vollgeschrieben, es ist aber keine Datei die dann kommt. Wenn alles fertig ist habe ich den ganzen Bildschirm voller Hieroglyphen, mehr nicht. Im April bin ich für 2 Wochen in D, dann besorge ich mir mal die aktuelle Version von Linux.
    Ist nicht leicht von Windows weg zu kommen, was so Treibergeschichten angeht sind die besser finde ich, denn da klappt ja meist erstmal alles, nur eben nicht stabil. Aber ob genau dies hier mit Linux besser ist weiß ich ja auch erst später.
    Gruß, Matz
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Hallo Ritschie,

    ja vielen Dank, das hat geklappt! Aber mit der neuen Version muss ich noch warten, ich habe hier noch kein Telefon und DSL, arbeite über UMTS, habe nur 5 GB im Monat, deshalb kann ich das nicht einfach saugen. Ich kann mir das zwar auch hier in Spanien kaufen, aber dann sind die Bücher in spanisch, kann ich zwar schon ganz gut aber sicher nicht in diesem speziellen Bereich. Vielen Dank, jetzt schreibe ich wieder unter Linux.
    Gruß, Matz
     
  6. #5 Ritschie, 27.03.2009
    Zuletzt bearbeitet: 27.03.2009
    Ritschie

    Ritschie SuSE-User

    Dabei seit:
    10.09.2003
    Beiträge:
    1.216
    Zustimmungen:
    0
    Ort:
    D-Bayreuth
    Freut mich, wenn ich helfen konnte :)

    Dazu möchte ich nochmal kurz das Wiki zitieren:
    ;)

    Wenn Du die aktuelle openSUSE hast, musst Du den Nvidia-Treiber übrigens nicht so umständlich installieren. Dann genügt es, die Nvidia-Quellen in die Repositories einzutragen. Anschließend kann man dann den Treiber mit 3D-Support komfortabel über YaST installieren. Vorteil: Nach Online-Updates des Kernels muss der Treiber nicht mehr von Hand nachinstalliert werden, sondern wird automatisch mit in's System eingebunden.

    Gruß,
    Ritschie
     
  7. Matz

    Matz Foren As

    Dabei seit:
    06.01.2006
    Beiträge:
    96
    Zustimmungen:
    0
    ....nochmals danke!
    Ist das mit "Repositories" nen neues Future von der aktuellen Version oder ist das auch schon in Suse 10.2? Und da Du schon 5 Pinguine hast, welche Linuxversion ist denn die Beste? Gibt Linux ja von vielen Anbietern, mir hat Suse nur gefallen weil es die überall gibt mit nem guten Buch dazu.

    (Darf ich das hier schreiben?) Oder gehört das dann wieder unter Bücher? :think:

    Gruß, Matz
     
  8. #7 Ritschie, 28.03.2009
    Ritschie

    Ritschie SuSE-User

    Dabei seit:
    10.09.2003
    Beiträge:
    1.216
    Zustimmungen:
    0
    Ort:
    D-Bayreuth
    Tja, das mit den Repositories. Jetzt, wo Du mich fragst, muss ich zugeben, so genau weiß ich gar nicht, ab wann's die bei SuSE gab. Musst Dich mal bissl in YaST unter "Software" umsehen. Wenn dort nichts von "Software-Repositories" steht, dann hat die 10.2 diese Funktion wohl leider noch nicht. Dann wäre das der nächste Grund, eine aktuellere Version zu verwenden. Über die Repositories kannst Du nämlich bequem mit YaST über das Internet diverse Sachen nachinstallieren, wie z.B. verschiedene Codecs zum Video schauen, mp3-Support und eben den Nvidia-Treiber, wobei dabei evtl. mögliche Abhängigkeiten gleich mit aufgelöst werden.

    Zu Deiner zweiten Frage: "die beste" Linux-Version gibt es nicht. Letztendlich setzen die ganzen Distributionen immer auf den mehr oder weniger gleichen Betriebssystemkern auf. Die Unterschiede zwischen den Distributionen liegen in dem ein oder anderen Kernel-Patch, der Aktualität des Kernels und ganz erheblich darin, was noch so an Drumherum mitgeliefert wird.

    Im Prinzip entscheiden Deine Kenntnisse und Ansprüche, welche Distribution für Dich die beste ist. Als Anfänger und jemand, für den grafische Helferlein wie YaST und SaX angenehm sind, bist Du bei openSUSE goldrichtig. Ich persönlich bin auch nach vielen Jahren Linux noch sehr zufrieden mit meiner openSUSE. Andere anfängerfreundliche Distris wären z.B. Fedora, Mandriva oder *buntu.
    Willst Du aber mehr in der Konsole rumfummeln und in die Tiefen des Betriebssystems vordringen, wird Dich openSUSE vielleicht auf Dauer nicht befriedigen (obwohl auch damit möglich. Nur verleiten die "Helferlein" gerne zur Faulheit *g*). Dann wären vielleicht eher Slackware, Debian oder Gentoo was für Dich.

    Das schöne ist, dass man so viele Distributionen wie man will kostenlos anschauen und testen kann. Schau Dich doch einfach bissl um. Einen Überblick, welche Distributionen es alles gibt, kannst Du dir bei distrowatch verschaffen.
    Meinungen zu vielen Distris findest Du auch hier in diesem Thread: Welches Linux-Distro verwendet Ihr und warum?

    Gruß,
    Ritschie
     
  9. #8 tuxlover, 28.03.2009
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    bei dem update ist wahrscheinlich ein neuerer kernel installiert worden. die kernelmodule für den nvidia treiber müssen dann natürlich neu kompilliert werden. bei einem treiberupdate passiert das natürlich auch.

    aber einfacher wäre es gewesen, das install script von nvidia mal mit --help option aufzurufen und heruaszusuchen wie man den alten treiber deinstalliert. danach wie gehabt den treiber installieren. fertig.
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. Matz

    Matz Foren As

    Dabei seit:
    06.01.2006
    Beiträge:
    96
    Zustimmungen:
    0
    Danke für Deine wirklich sehr hilfreichen Antworten ! :o)

    Habe jetzt geschafft Linux 11.1 in Spanien zu bekommen. Hat man mir im Internetcafe heruntergeladen!

    Kannst Du mir eine Beispiel URL nennen z.B. für den MP3-Support?
    Mit Nvidia hat das nicht geklappt! Hörte gar nicht mehr auf den eingegebenen Link zu testen, da blieb mir nur ein Neustart.

    LG, Matz
     
  12. Krotti

    Krotti Foren As

    Dabei seit:
    01.03.2007
    Beiträge:
    78
    Zustimmungen:
    0
    Siehe:
    http://www.unixboard.de/vb3/showpost.php?p=329776&postcount=3

    Für mp3 Support das Packman Repo einfügen.
     
Thema:

Keine Grafik nach online Update

Die Seite wird geladen...

Keine Grafik nach online Update - Ähnliche Themen

  1. Nach standby keine Grafik mehr! Warum?

    Nach standby keine Grafik mehr! Warum?: Hallo, habe ein siemens lifebook und dort debian etch installiert. Wenn ich den Rechner aus dem Standby hole, bleibt der Bildschirm weiß. Jedoch...
  2. Keine Vi Funktion meiner TI4200 Vi/Vo Grafikkarte

    Keine Vi Funktion meiner TI4200 Vi/Vo Grafikkarte: Hallo liebes Forum, habe die o.g. Grafikkarte von MSI (nVidia GF4 Ti4200 8x) mit S-VHS IN/OUT Eingang/Ausgang. Ich habe an diesem Eingang über...
  3. Debian-Server, neu installiert = keine Grafiken mehr

    Debian-Server, neu installiert = keine Grafiken mehr: Hallo, ich habe einen Debian Server (sarge3). Nachdem ich diesen letzte Woche komplett neu installiert habe zeigt er im Browser überhaupt keine...
  4. RRDTool unter Suse 10.0 keine GIF Grafiken

    RRDTool unter Suse 10.0 keine GIF Grafiken: Hallo, mir ist es leider nicht möglich, mit dem RRDTool unter Suse 10.0 GIF Grafiken zu erstellen. PNG gehen ohne Probleme. GD unterstützt...
  5. Nvidia = Nach Reboot keine Grafik mehr?

    Nvidia = Nach Reboot keine Grafik mehr?: Hallo, ich hab eine Geforce 2 geschenkt bekommen, die ich auch unter Linux benutzen moechte. Ich hab den Treiber von der Homepage...