keine /dev/sda* mehr

Dieses Thema im Forum "Gentoo" wurde erstellt von Bloodsurfer, 23.12.2005.

  1. #1 Bloodsurfer, 23.12.2005
    Bloodsurfer

    Bloodsurfer Gentoo-User

    Dabei seit:
    15.10.2005
    Beiträge:
    243
    Zustimmungen:
    0
    Ich habe ein seltsames Problem. Ich nutze eine USB Festplatte, die ich bisher immer als /dev/sda1 gemountet und anschließend wieder umountet habe, was bisher immer funktionierte. Letztens ist allerdings die Datei /dev/sda1 verschwunden, nachdem ich die Platte ausgehängt hatte. Mounten konnte ich sie dann aber immer noch mit /dev/sdb1. Aber paradoxerweise war kurze Zeit später auch diese Datei verschwunden, seitdem kann ich die Platte nicht mehr mounten.

    In meiner Kernelconfig stimmt noch alles USB/Hotplug-mäßig, es hat ja funktioniert und ich habe nichts daran geändert, habe nicht mehr getan als die Platte auszuhängen.

    Ich hab diverse Sachen ausprobiert. Z.B. habe ich udev, baselayout und hal upgedatet, aber auch das hat nichts gebracht. Danach waren alle /dev/sd* Dateien weg.

    Die Platte wird auch immer noch wunderbar erkannt, dmesg sagt nur:

    usb 1-1: new high speed USB device using ehci_hcd and address 3
    scsi3 : SCSI emulation for USB Mass Storage devices
    usb-storage: device found at 3
    usb-storage: waiting for device to settle before scanning
    Vendor: WDC WD20 Model: 00BB-00GUA0 Rev: 0811
    Type: Direct-Access ANSI SCSI revision: 00
    usb-storage: device scan complete

    Ich habe auch versucht mit makedev die Dateien einfach wieder zu erstellen. Sie sind dann zwar wieder da, aber funktionieren nicht. Ich bekomm dann nur die Meldung "is not a valid block device"...

    Bin so ziemlich ratlos...
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Kannst du die Platte mit

    fdisk -l

    sehen, wenn sie angeschlossen ist? Evtl. wird jetzt nen anderes Device, z.B. /dev/usbblabla1 benutzt. Hatte ich aehnlich mal bei Ubuntu Hoary. Die Devices sind zwar dagewesen, aber die Platte wurde trotzdem staendig auf /dev/usbichweissnichtmehr1 eingehaengt.
     
  4. #3 Edward Nigma, 24.12.2005
    Edward Nigma

    Edward Nigma Back again!

    Dabei seit:
    30.08.2003
    Beiträge:
    1.193
    Zustimmungen:
    1
    Ort:
    Erde
    welche Version von udev hast du denn installiert?
    Ich hatte da letztens eine Version wo beim start ne Fehlermeldung kam. Die war kaum zu sehen da trotzdem alles mit "ok" mackiert wurde. Ein downgrade auf Version 0.73 hat aber abhilfe geschaffen.
     
  5. #4 Bloodsurfer, 24.12.2005
    Zuletzt bearbeitet: 24.12.2005
    Bloodsurfer

    Bloodsurfer Gentoo-User

    Dabei seit:
    15.10.2005
    Beiträge:
    243
    Zustimmungen:
    0
    fdisk -l liefert mir nur meine interne Festplatte, das findet die externe nicht. Denke auch nicht dass sie nun ein anderes device ist, sehe unter /dev/ nichts was auch nur im entferntesten eine Platte oder ein USB Gerät sein könnte...

    Fehlermeldungen beim Start seh ich keine. Auch nichts bedenkliches im dmesg.
    Hab udev-078 drauf, vorher war es die 068-r1. Meinst du ich sollte die 073 mal probieren? Kann ja nicht schaden.

    EDIT: Auch mit der 073 gehts nicht, keine Änderung. :(
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

keine /dev/sda* mehr

Die Seite wird geladen...

keine /dev/sda* mehr - Ähnliche Themen

  1. Keine Benachrichtigungen im Vollbild Modus

    Keine Benachrichtigungen im Vollbild Modus: Arch Linux Plasma 5.8 Weiss einer ob das gehen sollte, bzw kann mal einer testen ob es bei ihm geht, gerne auch mit anderen kde/plasma versionen....
  2. BSI-Audit findet keine akuten Probleme in OpenSSL

    BSI-Audit findet keine akuten Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...
  3. BSI-Audit findet keine akute Probleme in OpenSSL

    BSI-Audit findet keine akute Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...
  4. RoboVM keine freie Software mehr

    RoboVM keine freie Software mehr: RoboVM, Hersteller der gleichnamigen Entwicklungsumgebung für Mobilsysteme, hat die Lizenz von der GPL in eine proprietäre Lizenz gewandelt. Nach...
  5. Steam: Keine Unterstützung für »unsaubere« Linux-Spiele

    Steam: Keine Unterstützung für »unsaubere« Linux-Spiele: Der Betreiber der Steam-Plattform, Valve, hat einer Reihe von Spielen die Kennzeichnung entzogen, wonach das Produkt unter Linux oder SteamOS...