kein Shutdown

Dieses Thema im Forum "Linux OS" wurde erstellt von Holodoc, 12.07.2003.

  1. #1 Holodoc, 12.07.2003
    Holodoc

    Holodoc Mitglied

    Dabei seit:
    02.07.2003
    Beiträge:
    28
    Zustimmungen:
    0
    Hi,

    da ich inzwischen auch schon die Distri gewechselt hab, will ich mein Prob nochmal hier im Main posten.
    Wenn ich Linux heruntergefahren habe, geht der Rechner nicht ganz aus, nur die Festplatte schaltet sich ab.

    Herumspielen mit den Power Management, APM und real-mode-shutdown-Optionen im Kernel sowie im Bios hat leider nichts gebracht.

    Beim Starten bekomme ich immer die Meldung APM: BIOS NOT FOUND, falls das etwas zu sagen hat...

    Vielleicht hat ja noch jemand eine Idee, nerviges Prob, wenn man Rechner jeden Tag ausmacht :(

    --
    Kernel 2.4.18 @ Debian-3.0r1 on Asus K7VM2
     

    Anhänge:

  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Andre

    Andre Foren Gott
    Moderator

    Dabei seit:
    01.04.2002
    Beiträge:
    3.876
    Zustimmungen:
    0
    hasst du es mal mit "poweroff" versucht?
     
  4. tr0nix

    tr0nix der-mit-dem-tux-tanzt

    Dabei seit:
    11.07.2003
    Beiträge:
    1.585
    Zustimmungen:
    0
    Ort:
    Schweiz, Opfikon/Glattbrugg
    Was passiert wenn du "apm" eingibst? Hast du die APMTools installiert?
     
  5. #4 Holodoc, 14.07.2003
    Holodoc

    Holodoc Mitglied

    Dabei seit:
    02.07.2003
    Beiträge:
    28
    Zustimmungen:
    0
    Also poweroff ist dasselbe.

    apm kann ich nicht eingeben, also kann schon, aber passiert natürlich nix... ;)

    Sollte ich die Tools mal installieren?
     
  6. tr0nix

    tr0nix der-mit-dem-tux-tanzt

    Dabei seit:
    11.07.2003
    Beiträge:
    1.585
    Zustimmungen:
    0
    Ort:
    Schweiz, Opfikon/Glattbrugg
    Ja mach das mal. k.A. obs was bringt aber vielleicht gibts dann mehr Info's
     
  7. #6 Holodoc, 17.07.2003
    Zuletzt bearbeitet: 17.07.2003
    Holodoc

    Holodoc Mitglied

    Dabei seit:
    02.07.2003
    Beiträge:
    28
    Zustimmungen:
    0
    Mmh, was soll das denn.

    fileserver:~# apm
    No APM support in kernel

    Dabei hab ich es direkt reincompiliert ?(

    [*] Power Management support
    <*> Advanced Power Management BIOS support

    Entsprechend existiert /proc/apm auch nicht...
     
  8. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Hast du vielleicht ACPI aktiv ?
     
  9. tr0nix

    tr0nix der-mit-dem-tux-tanzt

    Dabei seit:
    11.07.2003
    Beiträge:
    1.585
    Zustimmungen:
    0
    Ort:
    Schweiz, Opfikon/Glattbrugg
    Bist du dir ganz sicher, dass du auch den neuen Kernel benutzt?
    Mach mal uname -a, so siehst du auch das Datum. Bist du sicher an diesem Ta g den Kernel kompiliert zu haben? Vielleicht hast du einfach nur vergessen "lilo" auszufuehren ;).

    Lustig ist auch der Unterschied bei einzelnen Distris.. meine Kernel-kompilier-Formel ist:
    make dep clean bzImage modules modules_install bzlilo && reboot

    Bei Debian hat man dann nach nem Restart den neuen kompilierten Kernel.
    Bei RH musste ich den kompilierten Kernel zuerst an den richtigen Ort kopieren und lilo laufen lassen.
     
  10. #9 Holodoc, 17.07.2003
    Zuletzt bearbeitet: 17.07.2003
    Holodoc

    Holodoc Mitglied

    Dabei seit:
    02.07.2003
    Beiträge:
    28
    Zustimmungen:
    0
    ACPI wüsst ich nicht, dass das an ist, dazu muss man doch extra Kernel patchen, oder? /proc/acpi existiert zumindest nicht...

    Jep, uname zeigt den Kernel, den ich vor 15min mal wieder neu compiliert hab ;).

    Wenn ich APM als Modul einbinde und dann modprobe apm mache, kommt übrigens

    fileserver:~# modprobe apm
    /lib/modules/2.4.18/kernel/arch/i386/kernel/apm.o: init_module: No such device
    Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
    /lib/modules/2.4.18/kernel/arch/i386/kernel/apm.o: insmod /lib/modules/2.4.18/kernel/arch/i386/kernel/apm.o failed
    /lib/modules/2.4.18/kernel/arch/i386/kernel/apm.o: insmod apm failed

    fileserver:~# ls -al /lib/modules/2.4.18/kernel/arch/i386/kernel/
    insgesamt 28
    drwxr-xr-x 2 root root 4096 17. Jul 16:13 .
    drwxr-xr-x 3 root root 4096 17. Jul 16:13 ..
    -rw-r--r-- 1 root root 18388 17. Jul 16:13 apm.o


    Wie man sieht geht meine Uhr 2h vor, muss ich beizeiten auch mal korrigieren :D
     
  11. tr0nix

    tr0nix der-mit-dem-tux-tanzt

    Dabei seit:
    11.07.2003
    Beiträge:
    1.585
    Zustimmungen:
    0
    Ort:
    Schweiz, Opfikon/Glattbrugg
    Hmm... waere es moeglich, dass du den Kernel versucht hast abzuspecken bei Mainboard Treibern? Es gibt da so spezielle Board-Unterstuetzungen.. aktivier da doch mal alles (testweise). So geh ich auch vor wenn ich mir unsicher bin. Erst mal das aktivieren was sein koennte, wenns nix hilft den Rest.. und dann langsam abspecken ;) (danke CPU's dass ihr bereits ueber 2ghz taktet! ;))
     
  12. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Nochmal kurz für mich, welche Distro verwendest du ?
    Welche Kernelsourcen ?
     
  13. #12 megamimi, 17.07.2003
    megamimi

    megamimi Nörgler vom Dienst

    Dabei seit:
    12.01.2003
    Beiträge:
    469
    Zustimmungen:
    0
    Ort:
    /home/megamimi
     
  14. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  15. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    <Havoc][> # Kernel command line options that apply to all installed images go
    <Havoc][> # here. See: The `boot-prompt-HOWO' and `kernel-parameters.txt' in
    <Havoc][> # the Linux kernel `Documentation' directory.
    <Havoc][> #
    <Havoc][> append="apm=power-off"
    <Havoc][> -> vi /etc/lilo.conf
    <Havoc][> und dann halt "append=""" nach "append="apm=power-off"" umschreiben
    <Havoc][> lilo wiedeer ausführen und den nächsten shutdown geniessen


    dank an havoc
     
  16. #14 Holodoc, 30.07.2003
    Holodoc

    Holodoc Mitglied

    Dabei seit:
    02.07.2003
    Beiträge:
    28
    Zustimmungen:
    0
    Hatte ich auch schon versucht, bringt nücht :/
     
Thema:

kein Shutdown

Die Seite wird geladen...

kein Shutdown - Ähnliche Themen

  1. debian Xfce, kein shutdown möglich

    debian Xfce, kein shutdown möglich: hallo.. wenn ich mich bei debian xfce als normaler user anmelde, kann ich mich max. wieder ausloggen. reboot und shutdown kann ich nich...
  2. keine shutdownmeldungen

    keine shutdownmeldungen: Hallo Hab auf einem PC Debian-Sid, Kernel 2.6.18-4-k7 mit nvidia 3D Beschleunigung, KDE .Erhalte aber beim Abmelden, bzw. genauer beim...
  3. Kein booten nach shutdown -F now möglich

    Kein booten nach shutdown -F now möglich: Hallo liebe Linux User Ich hoffe ihr könnt mir weiterhelfen. Nachdem ich bei einem meiner Server diesen mittels shutdown -F now (forced fsck)...
  4. kein shutdown mit sata hd

    kein shutdown mit sata hd: Hallo! Habe gestern SuSE 10.1 auf meinem kleinen Homeserver installiert. Der Server sollte unter anderem als router, firewall und fileserver...
  5. ubuntu mit gnome / kein shutdown recht

    ubuntu mit gnome / kein shutdown recht: hi, mein problem ist das rechtemanagement bei suse. wie ermögliche ich es einem user ein programm zu starten & alle anderen programme oder...