Kein openGl mehr

Dieses Thema im Forum "Gnome" wurde erstellt von Crossmaker, 03.08.2008.

  1. #1 Crossmaker, 03.08.2008
    Crossmaker

    Crossmaker Grünschnabel

    Dabei seit:
    27.11.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Hi Gemeinde,

    mich plagt seit einer vermeintlichen Erneuerung des Gk-Treibers ein Problem. Beim Update meines Nvidia Treibers (integrierter Grafikchip älteren Typs) funzt openGL nicht mehr, so das ich z.B. Blender nicht mehr nutzen kann.
    Hier meine xorg.conf
    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"de"
    	Option		"XkbOptions"	"lv3:ralt_switch"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"	"/dev/input/mice"
    	Option		"Protocol"	"ImPS/2"
    	Option		"ZAxisMapping"	"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"stylus"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"stylus"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"eraser"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"eraser"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"cursor"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"cursor"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "Device"
    	Identifier	"nVidia Corporation NVCrush11 [GeForce2 MX Integrated Graphics]"
    	Boardname	"nv"
    	Busid		"PCI:2:0:0"
    	Driver		"nv"
    	Screen	0
    EndSection
    
    Section "Monitor"
    	Identifier	"Standardbildschirm"
    	Vendorname	"Generic LCD Display"
    	Modelname	"LCD Panel 1280x1024"
    	Horizsync	31.5-64.0
    	Vertrefresh	56.0 - 65.0
      modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
      modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
      modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
      modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
      modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
      modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
    	Gamma	1.0
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"nVidia Corporation NVCrush11 [GeForce2 MX Integrated Graphics]"
    	Monitor		"Standardbildschirm"
    	Defaultdepth	24
    	SubSection "Display"
    		Depth	24
    		Virtual	1280	1024
    		Modes		"1280x1024@60"	"1280x960@60"	"1024x768@60"	"800x600@60"	"800x600@56"	"640x480@60"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen 0 "Default Screen" 0 0
    	Inputdevice	"Generic Keyboard"
    	Inputdevice	"Configured Mouse"
    	
    	# Uncomment if you have a wacom tablet
    	#	InputDevice     "stylus"	"SendCoreEvents"
    	#	InputDevice     "cursor"	"SendCoreEvents"
    	#	InputDevice     "eraser"	"SendCoreEvents"
    EndSection
    Section "Module"
    	Load		"glx"
    	Load		"v4l"
    EndSection
    Section "ServerFlags"
    EndSection
    Laut Paketverwaltung ist alles installiert im Terminal ist dann folgende Meldung
    zu lesen

    Code:
    heino@heimi:~$ glxinfo | grep rendering
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    heino@heimi:~$ 
    
    oder

    Code:
    heino@heimi:~$ sudo nvidia-glx-config enable
    [sudo] password for heino: 
    sudo: nvidia-glx-config: command not found
    heino@heimi:~$ 
    
    meine Ideen sind mir ausgegangen :hilfe2:

    Danke schon mal im Vorraus
    Gruß Crossmaker
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 BloodyMary, 03.08.2008
    BloodyMary

    BloodyMary Pornophon

    Dabei seit:
    15.03.2005
    Beiträge:
    615
    Zustimmungen:
    1
    Ort:
    Bayern
    Wie bist du beim update vorgegangen? Treiber aus den Repos? treiber von Nvidia Website?
    Wenn du ein Howto benutzt hast poste den Link.
     
  4. #3 Crossmaker, 03.08.2008
    Crossmaker

    Crossmaker Grünschnabel

    Dabei seit:
    27.11.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Hi BloodyMary,
    Update aus den Repos. Nach diesem konnte ich mit X nicht mehr arbeiten, heist das System hat sich beim booten aufgehängt. Nach Start im «abgesicherten» Modus xfig ausgeführt und wieder mit dem alten Treiber gearbeitet. Wobei mir dann auffiehl das eben nicht mehr alles funktioniert. Das neu konfigurieren über Terminal funktioniert auch nur für die Tastatur und die Maus ein einstellen der Grafikkarte ist gar nicht möglich.
     
  5. #4 Crossmaker, 04.08.2008
    Crossmaker

    Crossmaker Grünschnabel

    Dabei seit:
    27.11.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Keiner eine Idee?
     
  6. #5 Linthorul, 04.08.2008
    Linthorul

    Linthorul Arch Luxer

    Dabei seit:
    01.12.2007
    Beiträge:
    205
    Zustimmungen:
    0
    Änder mal das "nv" in deiner xorg.conf zu "nvidia"
     
  7. #6 Crossmaker, 06.08.2008
    Crossmaker

    Crossmaker Grünschnabel

    Dabei seit:
    27.11.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Hi Linthorul,
    wenn ich das tue startet mein X nicht mehr, oder besser gesagt meine Muehle friert waehrend des bootens ein.

    Trotzdem danke fuer die Meldung.
     
  8. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    ohne nvidia modul wirst du aber kein gl bekommen, also löse das problem, warum x damit nicht startet ...
     
  9. #8 Crossmaker, 06.08.2008
    Crossmaker

    Crossmaker Grünschnabel

    Dabei seit:
    27.11.2007
    Beiträge:
    9
    Zustimmungen:
    0
    hi doc,
    jetzt bin ich jedoch überfragt. Was ist ein nvidia-modul? Eine Zeile in der xorg-conf, oder zusätzliche Software. Als jemand der nicht unbedingt gleich alles auf dem Sender hat was Linux betrifft ist deine Aussage etwas undurchsichtig.

    Ich werd mich aber schlau machen und dann vieleicht das Problem selber lösen können. (in gefühlten 120 Jahren)

    Gruß Crossmaker
     
  10. #9 supersucker, 07.08.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. #10 saeckereier, 07.08.2008
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Die closed-source Treiber von nvidia und ati haben früher aber auch wirklich Nerven gekostet. Heute kann man sich ja fast nicht mehr beschweren:-)
     
  13. #11 Crossmaker, 07.08.2008
    Crossmaker

    Crossmaker Grünschnabel

    Dabei seit:
    27.11.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Hi supersucker,
    danke für den Link.
     
Thema:

Kein openGl mehr

Die Seite wird geladen...

Kein openGl mehr - Ähnliche Themen

  1. ATi Treiber -> aticonfig -> trotzdem kein OpenGL

    ATi Treiber -> aticonfig -> trotzdem kein OpenGL: Hab mein Kubuntu gestern neu draufmachen müssen (zu krass rumexperimentiert ;) ) und auf einmal gibts keine OpenGL Unterstützung mehr. Hab...
  2. Nach Kernelupgrade kein OpenGL/WINE mehr

    Nach Kernelupgrade kein OpenGL/WINE mehr: Hallo, ich habe kürzlich meinen Kernel durch den Autoupdater aktualisieren lassen (2.6.18.2-34 → 2.6.18.8-0.5). Weil danach Suspend to Disk...
  3. VNC, auf display :1 und folgende keine opengl

    VNC, auf display :1 und folgende keine opengl: hi, ich habe das prob, das ich auf meinem server ein windows-game laufen habe. dieses braucht mittels cedega opengl beim start. wie bekomme...
  4. Keine Benachrichtigungen im Vollbild Modus

    Keine Benachrichtigungen im Vollbild Modus: Arch Linux Plasma 5.8 Weiss einer ob das gehen sollte, bzw kann mal einer testen ob es bei ihm geht, gerne auch mit anderen kde/plasma versionen....
  5. Torvalds: »Kein Porno unter Linux«

    Torvalds: »Kein Porno unter Linux«: Ohne eine größere Ankündigung hat Linus Torvalds im Zuge des aktuellen Merge-Fensters einen Patch der Gruppe »Gesellschaft gegen Porno« in den...