karamba - problem beim kompilieren

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von dark_apollo, 04.02.2007.

  1. #1 dark_apollo, 04.02.2007
    dark_apollo

    dark_apollo Mitglied

    Dabei seit:
    17.01.2005
    Beiträge:
    30
    Zustimmungen:
    0
    Ort:
    Bodø, Nord Norway
    Hallo Leute

    Wollte heute das super-karamba installieren (0.39 Version) auf openSuSE 10.2 System. python-devel Paket ist installiert. Beim kompilieren meckert der compiler aber rum, da kommt das hier:

    checking for Python2.4... header no library no modules no
    checking for Python2.3... header no library no modules no
    checking for Python2.2... header no library no modules no
    checking for Python2.1... header no library no modules no
    checking for Python2.0... header no library no modules no
    checking for Python1.5... header no library no modules no
    checking for libxmms... ./configure: line 43081: xmms-config: command not found
    ./configure: line 43083: xmms-config: command not found
    no
    checking for main in -lknewstuff... yes
    checking for main in -lkvm... no
    checking if doc should be compiled... yes
    checking if superkaramba should be compiled... no
    configure: creating ./config.status
    fast creating Makefile
    fast creating doc/Makefile
    fast creating doc/superkaramba/Makefile
    fast creating superkaramba/Makefile
    fast creating superkaramba/doc/Makefile
    fast creating superkaramba/icons/Makefile
    fast creating superkaramba/mimetypes/Makefile
    fast creating superkaramba/src/Makefile
    config.pl: fast created 8 file(s).
    config.status: creating config.h
    config.status: config.h is unchanged
    config.status: executing depfiles commands

    Superkaramba can't be compiled
    because of missing Python libraries/headers.


    braucht karamba noch was anderes ausser dieses Paket?

    Gruss d_a
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    superkaramba is doch bestimmt bei yast inst dabei, dann sparste dir das kompiliern
     
  4. #3 dark_apollo, 05.02.2007
    dark_apollo

    dark_apollo Mitglied

    Dabei seit:
    17.01.2005
    Beiträge:
    30
    Zustimmungen:
    0
    Ort:
    Bodø, Nord Norway
    moin sinn3r

    hab bisher alle "karambas" einkompiliert, ohne Probleme mit diversen Abhaengigkeiten. Merkwuerdig warum die Bibliotheken nicht gefunden werden :think: Auch das installieren aus einem RPM Paket schlug fehl. Wieder fehlte das devel-paket :think:

    Hab es jetzt ueber einen anderen Weg gemacht:
    Diese Quelle im Yast hinzugefuegt ....
    http://ftp.gwdg.de/pub/linux/misc/suser-guru/rpm/10.2/RPMS/ (Yum-Repo)

    Und nach kdeutils3-extra gesucht. Dort ist das Karamba enthalten.

    Mehr findet man unter:
    http://www.linux-club.de/faq/Superkaramba

    Gruss d_a
     
  5. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    das du das mit yast machen sollst hab ich doch vorgeschlagen^^
     
  6. #5 dark_apollo, 05.02.2007
    dark_apollo

    dark_apollo Mitglied

    Dabei seit:
    17.01.2005
    Beiträge:
    30
    Zustimmungen:
    0
    Ort:
    Bodø, Nord Norway
    Sicher hast du das erwaehnt ...

    aber nicht die Quelle und das Sesam Zauberwort. Hatte ja schon einige Quellen im Yast drinne, nur nicht die richtige. Auf den Begriff "karamba" wurde Null und Nix gefunden.

    Ehrlich, wenn die Abhaengigkeiten mit den Bibliotheken immer gleich passen wuerden, kommt man mit dem kompilieren aus den Sourcen schneller ans Ziel.
     
  7. #6 mornoyce, 23.02.2007
    Zuletzt bearbeitet: 23.02.2007
    mornoyce

    mornoyce Grünschnabel

    Dabei seit:
    23.02.2007
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo,
    bin durch google auf dies Board aufmerksam geworden und hab eine Frage zu superkaramba unter suse 10.2 und dachte mir, dass passt vielleicht hier hinein???
    Ich wollte auch zuerst superkaramba 0.39 installieren (hab mir ein passendes .rpm gesucht); da erhalte ich jedoch diverse Fehlermeldungen, das Abhängigkeiten nicht richtig aufgelöst werden können (welche, weiß ich nicht mehr, kanns aber nochmal prüfen).
    Über yast hab ich dann gemäß suse wiki versucht, superkaramba zu installieren (hab die repositorys von suse-guru hinzugefügt http://ftp.gwdg.de/pub/linux/misc/suser-guru/rpm/10.2/RPMS/ (Yum-Repo)); da findet er aber superkaramba nicht. Ich kann da somit nur kdeutils3 finden und auch installieren.
    -> Jedenfalls hab ich dann superkaramba 0.35 (glaube ich) und es läuft auch mit verschiedenen Themes. Mein Favorit AIO jedoch nicht mehr :( Nachdem ich das Teil zum laufen hatte und die Network Komponente einrichten wollte, werden im AIO keine Inhalte mehr angezeigt. Das deinstallieren des designs hat nichts gebracht; andere Designs laufen wie gesagt immer noch und da werden auch Netzwerkkomponenten angezeigt.
    Nun las ich auf kde-look zum Design AIO, dass wohl min. superkaramba 0.37 installiert sein muss http://www.kde-look.org/content/show.php?content=24626... wie krieg ich also am gescheitesten ein update hin (über yast kann keine aktuellere variante als 0.35 gefunden werden, glaube ich).
    Hoffe, es ist deutlich geworden, was mein Prob is... Danke vorab!:)
     
  8. #7 supersucker, 23.02.2007
    Zuletzt bearbeitet: 23.02.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    @dark_apollo:

    Wie wäre es, wenn du mal die Fehlermeldung selber liest, bevor du hier reinpostest?

    Noch klarer KANN der Fehler ja gar nicht beschrieben werden:

    @mornoyce

    Vermutlich wirst du nicht darum herum, superkaramba selber zu kompilieren, wenn du in deinem Paketmanager nichts aktuelleres findest.

    Das solltest du aber erst mal prüfen.

    Also, wie sehen deine Quellen aus?
     
  9. #8 mornoyce, 23.02.2007
    Zuletzt bearbeitet: 23.02.2007
    mornoyce

    mornoyce Grünschnabel

    Dabei seit:
    23.02.2007
    Beiträge:
    4
    Zustimmungen:
    0
    aha, danke. Da muss ich zuhaus nachschauen :) weiß ich nicht ausm Kopp...
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    ...aber mal andersruM. welche Quellen kannst du denn so empfehlen?
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 supersucker, 23.02.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Naja,

    wenn du die packman, guru und alle offiziellen suse-repositories drin hast, solltest du auch ein aktuelles kdeutils haben (vorrausgesetzt natürlich, das du von Zeit zu Zeit auch ein system-update machst......)
     
  12. #10 mornoyce, 23.02.2007
    mornoyce

    mornoyce Grünschnabel

    Dabei seit:
    23.02.2007
    Beiträge:
    4
    Zustimmungen:
    0
Thema:

karamba - problem beim kompilieren

Die Seite wird geladen...

karamba - problem beim kompilieren - Ähnliche Themen

  1. Ey SuperKaramba Problem - Plugins weg

    Ey SuperKaramba Problem - Plugins weg: Hi leute ich habe mir superkaramba installiert. Dort gibtes ja die möglichekit sich plugins direkt im Porgramm herunterzuladen und zu...
  2. Problem bei Installation von VLC Player und Super Karamba

    Problem bei Installation von VLC Player und Super Karamba: Hallo! Beim installieren von VLC und Super Karamba ist ein Fehler aufgetreten. Zuerst einmal der Fehler von Super Karamba: checking build...
  3. Probleme Superkaramba 0.35 zu kompilieren

    Probleme Superkaramba 0.35 zu kompilieren: Hallo an alle :) Ich möchte gern die aktuelle Version von Superkaramba für mein Debian Sarge Linux kompilieren. Leider bleibe ich da schon bei...
  4. Screenlet? gDesklet? Superkaramba?

    Screenlet? gDesklet? Superkaramba?: Hallo zusammen, habe nur eine ganz kurze Frage und zwar welches Widget wurde hier rechts auf dem Screen benutzt?...
  5. Superkaramba Ordnersymbol auf Desktop

    Superkaramba Ordnersymbol auf Desktop: Hi Leute, ich würde gerne eine superkaramba-anwendung programieren, aber mir fehlt ein wichtiger befehl dazu, vielleicht hat hier ja jemand eine...