kann ssh2 nicht isntallieren

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von sisko, 02.09.2008.

  1. sisko

    sisko Grünschnabel

    Dabei seit:
    02.09.2008
    Beiträge:
    5
    Zustimmungen:
    0
    ich muss ssh2 auf meinen server installieren weil cih es fuer php benoetige, aber ich bekomme laufend einen fehler.

    zunaechst habe ich libssh2 (libsssh2-0.12 - hatte ich ncoh auf dem server liegen) installiert. dann fiel mir ein nach einer neueren zu suchen. bekomme aber beim install diesen fehler:

    Code:
    apt-get install libssh2*
    Reading package lists... Done
    Building dependency tree... Done
    Note, selecting libssh2-1 for regex 'libssh2*'
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
      libssh2-1: Depends: libc6 (>= 2.6.1-1) but 2.3.6.ds1-13etch7 is to be installed
                 Depends: zlib1g (>= 1:1.2.3.3.dfsg-1) but 1:1.2.3-13 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    mit pear gehts auch nicht und aus verzweifelung habe ich es sogar mit force versucht, aber auch das bringt den selben fehler.

    hab dann ein neueres paket runtergeladen:

    Code:
    dpkg -i libssh2-1_0.18-1_i386.deb
    (Reading database ... 38490 files and directories currently installed.)
    Preparing to replace libssh2-1 0.18-1 (using libssh2-1_0.18-1_i386.deb) ...
    Unpacking replacement libssh2-1 ...
    dpkg: dependency problems prevent configuration of libssh2-1:
     libssh2-1 depends on libc6 (>= 2.6.1-1); however:
      Version of libc6 on system is 2.3.6.ds1-13etch7.
     libssh2-1 depends on zlib1g (>= 1:1.2.3.3.dfsg-1); however:
      Version of zlib1g on system is 1:1.2.3-13.
    dpkg: error processing libssh2-1 (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     libssh2-1
    
    versuche ich nun dennoch ssh2 zu installieren bekomm ich das:

    Code:
    configure: WARNING: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.
    checking for gawk... no
    checking for nawk... nawk
    checking if nawk is broken... no
    checking for ssh2 support... yes, shared
    checking for ssh2 files in default path... found in /usr
    checking for libssh2_banner_set in -lssh2... no
    configure: error: libssh2 version >= 0.4 not found
    
    wie kann ich das fixen? dreh schon am rad.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Goodspeed, 02.09.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Nur soviel ... n unstable/testing Paket unter stabel (Etch) zu installieren ist ne saublöde Idee!
     
  4. defcon

    defcon Kaiser
    Moderator

    Dabei seit:
    22.08.2005
    Beiträge:
    1.486
    Zustimmungen:
    1
    Ort:
    Bruchsal
    Probier es stattdessen mal lieber mit
    Code:
    apt-get install ssh
    
     
  5. #4 sisko, 02.09.2008
    Zuletzt bearbeitet: 02.09.2008
    sisko

    sisko Grünschnabel

    Dabei seit:
    02.09.2008
    Beiträge:
    5
    Zustimmungen:
    0
    hatte ich auch schon pribiert. selbes ergebnis. :(

    Code:
    The following packages have unmet dependencies:
      libssh2-1: Depends: libc6 (>= 2.6.1-1) but 2.3.6.ds1-13etch7 is to be installed
                 Depends: zlib1g (>= 1:1.2.3.3.dfsg-1) but 1:1.2.3-13 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    mir faellt gerade auf. auch wenn ich apt-get upgrade machen will bekomm ich diese meldung. woran kann das denn liegen?

    Code:
    Reading package lists... Done
    Building dependency tree... Done
    You might want to run `apt-get -f install' to correct these.
    The following packages have unmet dependencies:
      libssh2-1: Depends: libc6 (>= 2.6.1-1) but 2.3.6.ds1-13etch7 is installed
                 Depends: zlib1g (>= 1:1.2.3.3.dfsg-1) but 1:1.2.3-13 is installed
    E: Unmet dependencies. Try using -f.
     
  6. #5 Goodspeed, 02.09.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Weil Du versucht hast ein Paket ins System zu prügeln, das da nix verloren hat.
    Mach einfach das, was dort steht ... das sollte es wieder entfernen.
     
  7. sisko

    sisko Grünschnabel

    Dabei seit:
    02.09.2008
    Beiträge:
    5
    Zustimmungen:
    0
    ok. das alte libssh2 ist raus. danke. da stehts vor einem und man siehts nicht.
    aber wie bekomm ich nun libssh2 und ssh2 drauf ohne fehler?
    :think:

    hab das paket libssh2-1_0.18-1_i386.deb runtergeladen, aber das gibt den selben fehler aus.
     
  8. Dizzy

    Dizzy Brain Damage

    Dabei seit:
    02.05.2007
    Beiträge:
    857
    Zustimmungen:
    0
    Ort:
    Graz
  9. #8 sisko, 02.09.2008
    Zuletzt bearbeitet: 02.09.2008
    sisko

    sisko Grünschnabel

    Dabei seit:
    02.09.2008
    Beiträge:
    5
    Zustimmungen:
    0
    openssh-server ist installiert. ich benoetige, wie gesagt die ssh2.so als extension fuer php.
    ich les mal was da zu libssh steht.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    ich hab nun libssh2 ohne fehler drauf in der neuesten version.
    nun moechte ich gern ssh2 mit

    Code:
    phpize && ./configure && make install
    klar machen, bekomme aber nun folgendes:

    Code:
    /bin/sh /home/ssh2-0.10/libtool --mode=compile gcc  -I. -I/home/ssh2-0.10 -DPHP_ATOM_INC -I/home/ssh2-0.10/include -I/home/ssh2-0.10/main -I/home/ssh2-0.10 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -DHAVE_CONFIG_H  -g -O2   -c /home/ssh2-0.10/ssh2.c -o ssh2.lo
    mkdir .libs
     gcc -I. -I/home/ssh2-0.10 -DPHP_ATOM_INC -I/home/ssh2-0.10/include -I/home/ssh2-0.10/main -I/home/ssh2-0.10 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CONFIG_H -g -O2 -c /home/ssh2-0.10/ssh2.c  -fPIC -DPIC -o .libs/ssh2.o
    /home/ssh2-0.10/ssh2.c: In function 'zif_ssh2_methods_negotiated':
    /home/ssh2-0.10/ssh2.c:481: warning: passing argument 2 of 'libssh2_session_methods' makes integer from pointer without a cast
    /home/ssh2-0.10/ssh2.c:481: error: too many arguments to function 'libssh2_session_methods'
    /home/ssh2-0.10/ssh2.c: In function 'zif_ssh2_fingerprint':
    /home/ssh2-0.10/ssh2.c:536: warning: assignment discards qualifiers from pointer target type
    /home/ssh2-0.10/ssh2.c: In function 'zif_ssh2_publickey_add':
    /home/ssh2-0.10/ssh2.c:1038: warning: passing argument 1 of '_efree' discards qualifiers from pointer target type
    /home/ssh2-0.10/ssh2.c: In function 'zif_ssh2_publickey_list':
    /home/ssh2-0.10/ssh2.c:1097: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
    /home/ssh2-0.10/ssh2.c:1098: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
    /home/ssh2-0.10/ssh2.c:1106: warning: initialization discards qualifiers from pointer target type
    /home/ssh2-0.10/ssh2.c:1107: warning: passing argument 2 of '_zend_hash_add_or_update' discards qualifiers from pointer target type
    make: *** [ssh2.lo] Error 1
    
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 Goodspeed, 03.09.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Die gibt es nicht für Etch ...
    Also noch n bissl warten ... auf Lenny upgraden, sobald es stable ist ... freuen.
     
  12. #10 sisko, 03.09.2008
    Zuletzt bearbeitet: 03.09.2008
    sisko

    sisko Grünschnabel

    Dabei seit:
    02.09.2008
    Beiträge:
    5
    Zustimmungen:
    0
    hm. das ist aber doof. gibts ne alternative? ich muss ueber php auf einen anderen server zugreifen koennen um dort programme zu starten, stoppen etc.
    ich weis nicht ob das mit openssh-server auch geht.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    hab noch ein wenig gegoogled und 2 beitraege gefunden. der erste meinte man sollte unten angefuehrten eintrag der config.h zufuegen, aber das brachte nicht. hab das dann direkt in der ssh2.c gemacht, die ja auch den fehler brachte, und es klappt. meine ssh2.so liegt nun dort wo sie hin sollte. :)

    das muss eingefuet werden:

    Code:
    #define LIBSSH2_APINO 200412301450
     
Thema:

kann ssh2 nicht isntallieren

Die Seite wird geladen...

kann ssh2 nicht isntallieren - Ähnliche Themen

  1. Wie kann ich x Zeichen hinter einem bestimmten Wort ausgeben ?

    Wie kann ich x Zeichen hinter einem bestimmten Wort ausgeben ?: In mehreren Dateien ist immer mehrfach ein bestimmtes Wort enthalten, gefolgt von einem "=". Ich möchte mir die dahinter folgenden 10 Zeichen...
  2. Wie kann ich das RAM löschen?

    Wie kann ich das RAM löschen?: Wie kann ich das RAM löschen? Danke im Vorraus
  3. Nicht erkannte Zeichen nach Update

    Nicht erkannte Zeichen nach Update: Hi, nachdem ich mein Kali Linux geupdated habe, ist mir aufgefallen dass viele Zeichen auf verschiedenen Nutzeroberflächen nur fehlerhaft...
  4. Bq Aquaris M10 Tablet mit Ubuntu Touch kann vorbestellt werden

    Bq Aquaris M10 Tablet mit Ubuntu Touch kann vorbestellt werden: Seit dem gestrigen Ostermontag kann das erste Tablet mit Ubuntu Touch und Konvergenz vorbestellt werden. Weiterlesen...
  5. Ethernet wird nicht erkannt

    Ethernet wird nicht erkannt: Ich habe das Problem, dass die Netzwerk karte von keinem System mehr geladen wird. Vor zwei Tagen habe ich das Netzteil vom Pc, das etwa eine...