Kann keine user unter samba anlegen!

Dieses Thema im Forum "Samba" wurde erstellt von Spear_Hawk, 30.08.2006.

  1. #1 Spear_Hawk, 30.08.2006
    Spear_Hawk

    Spear_Hawk Grünschnabel

    Dabei seit:
    13.03.2006
    Beiträge:
    9
    Zustimmungen:
    0
    Ort:
    Irgendwo in Deutschland
    Hallo @all,

    bin gerade beim einrichten von Samba auf meinem Debian Rechner, jetzt steh ich nur vor dem Problem das ich keine User unter samba anlegen kann. Ich wollte einen User, der schon auf meiner Kiste existiert und ein /home Verzeichnis hat und sich auch an der shell anmelden kann, als samba user anlegen. Habe dazu den Befehl smbpasswd -a username verwendet, was auch ohne murren ausgeführt wurde. Danach wollte ich mich dann an swat mit diesem User und Passwort anmelden, aber das ging nicht.

    An der smb.conf hab ich eigentlich fast nichts verändert

    Code:
    # Global parameters
    [global]
            workgroup =
            server string = %h server (Samba %v)
            security = SHARE
            obey pam restrictions = Yes
            passdb backend = tdbsam, guest
            passwd program = /usr/bin/passwd %u
            passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spas
    sword:* %n\n .
            syslog = 0
            log file = /var/log/samba/log.%m
            max log size = 1000
            dns proxy = No
            panic action = /usr/share/samba/panic-action %d
            invalid users = root
    
    [homes]
            comment = Home Directories
            create mask = 0700
            directory mask = 0700
            browseable = No
    
    [printers]
            comment = All Printers
            path = /tmp
            create mask = 0700
            printable = Yes
            browseable = No
    
    [print$]
            comment = Printer Drivers
            path = /var/lib/samba/printers
    
    Könnte es vielleicht an dem Eintrag "passwd program = /usr/bin/passwd %u"
    liegen welcher automatisch angelegt wurde?? Kann leider nicht in die passwd reinschauen da kommt nur Buchstabensalat

    wäre für Hilfe dankbar
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Nimm mal den ganzen passwd-Kram raus und versuche es dann nochmal. Der ist naemlich erstmal total unnoetig, wenn du eh nur Systembenutzer nutzt. Hier mal eine Beispiel-Konfiguration fuer die einfache Freigabe (wirklich nur minimal, also gut als Basis um darauf aufzubauen *denk*):

    Code:
    [global]
            workgroup = WORKGROUP # <- hier die Arbeitsgruppe anpassen
            os level = 2
            kernel oplocks = No
            security = user
            encrypt passwords = Yes
            guest account = systemuser # <- user anpassen
            map to guest = Bad User
            username map = /etc/samba/smbusers
            socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
            local master = No
            interfaces = 192.168.0.100/255.255.255.0 # <- hier die IP anpassen
            wins support = No
    
    [homes]
           comment = Home Directories
           read only = No
           create mask = 0640
           directory mask = 0750
           browseable = No
    
    Und wirf mal einen Blick in http://www.linuxhaven.de/dlhp/HOWTO/DE-Samba-HOWTO.html :)
     
  4. #3 Spear_Hawk, 31.08.2006
    Spear_Hawk

    Spear_Hawk Grünschnabel

    Dabei seit:
    13.03.2006
    Beiträge:
    9
    Zustimmungen:
    0
    Ort:
    Irgendwo in Deutschland
    Erstmal danke theton für den Vorschlag, würde so funktionieren, aber es muss doch auch mithilfe des smbpasswd gehen. Hab jetzt schon den halben tag lang rumprobiert, und bin noch zu keinem richtigen Erfolg gekommen. Was ich in meinem ersten post vergessen habe zu erwähnen, ist dass ich unter /etc/samba keine smbpasswd Datei hatte. Den Grund dafür hab ich inzwischen rausgefunden, in meiner smb.conf stand nämlich folgendes:
    Code:
    	passdb backend = [COLOR="blue"]tdbsam[/COLOR], guest
    	algorithmic rid base = 1000
    	enable privileges = No
    	pam password change = No
    	passwd program = /usr/bin/passwd %u
    	passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
    Hab das tdbsam durch smbpasswd ersetzt und siehe da er hat dann automatisch unter /etc/samba die smbpasswd angelegt. Hab dann versucht mit smbpasswd einen user anzulegen was dann auch geklappt hat, zumindest steht der User danach mal in dem file. Nur leider kann ich mich danach immer noch nicht an swat mit dem angelegten user anmelden. Hab dann noch folgendes geändert aber ohne großen Erfolg:

    Code:
    smb passwd file = /etc/samba/smbpasswd
    	private dir = /etc/samba
    	passdb backend = smbpasswd
    	algorithmic rid base = 1000
    	enable privileges = No
    	pam password change = No
    	passwd program = /usr/bin/smbpasswd %u
    	passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
    Hat jemand noch einen Vorschlag wie ich das hinkriegen könnte, ansonsten werde ich es wohl so wie theton empfohlen hat machen.

    ps: meine samba version: 3.0.14a-Debian
     
  5. #4 phrenicus, 01.09.2006
    phrenicus

    phrenicus Routinier

    Dabei seit:
    24.05.2006
    Beiträge:
    253
    Zustimmungen:
    0
    Ort:
    Tübingen, Germany
    Hallo,

    was willst Du denn mit SWAT als normaler User machen? SWAT dient dazu, SAMBA zu konfigurieren, das macht man doch besser als root. Und wenn Du Deine smb.conf mit SWAT bearbeitest, sicherst Du sie besser vorher weg, weil dieses Tool sie Dir einfach ohne Rückfrage mit schwachsinnigen Einträgen überschreibt.
    Melde Dich doch mal von Windows aus mit diesem User an Deinem SAMBA-Server an, das müsste jetzt gehen. Und als Tipp: Lass SWAT weg und konfigurier die smb.conf von Hand. Ist besser so. So bleibt sie lesbar und Du weißt, was Du getan hast.

    Gruß
     
  6. #5 Spear_Hawk, 01.09.2006
    Spear_Hawk

    Spear_Hawk Grünschnabel

    Dabei seit:
    13.03.2006
    Beiträge:
    9
    Zustimmungen:
    0
    Ort:
    Irgendwo in Deutschland
    Ok ist mir jezt irgendwie peinlich :rolleyes:,
    ich beschäftige mich noch nicht solange mit Linux und bei meinem ersten samba server den ich auf suse aufgesetzt hatte, konnte ich mich mit dem user den ich in die smbpasswd eingetragen habe auch an swat anmelden. Ich nahm das jezt halt als Kontrollmöglichkeit ob der user richtig angelegt wurde und da das diesmal nicht ging, dachte ich das dann auch der Zugriff von Windows auch nicht funktioniert.
    Tja falsch gedacht, das nächste mal werde ich es zuerst mal alle Möglichkeiten restlos ausschöpfen und in Zukunft ohne Swat die smb.conf direkt editieren.

    Danke phrenicus für den Hinweis, hätte da wahrscheinlich noch ewig gesucht.
     
Thema:

Kann keine user unter samba anlegen!

Die Seite wird geladen...

Kann keine user unter samba anlegen! - Ähnliche Themen

  1. Keine Netzwerkgeräte erkannt...

    Keine Netzwerkgeräte erkannt...: Hallo, bin heute neu hier im Forum und sag erstmal "Hallo" an alle und nun gleich meine Frage. Ich habe CentOS 7 KDE auf meiner Virtualbox...
  2. Putty>Server kann bekomme keine Verbindung

    Putty>Server kann bekomme keine Verbindung: Hallo Leute, hoffe das ist hier richtig. Ich habe einen ubuntu Server. Mein Problem: Nach einem Update, bekomme ich mit Putty keine...
  3. Kann keine Dateien auf tftpd Server hochladen

    Kann keine Dateien auf tftpd Server hochladen: Hallo zusammen Bin dabei einen tftp Server einzurichten. Man kann vom Server Problemlos Dateien herunterladen. Aber wenn ich z.B. von einem...
  4. vsftpd kann mit keinem user einloggen (Noob alarm ;;)

    vsftpd kann mit keinem user einloggen (Noob alarm ;;): Hallo, ich habe gestern einen vsftpd user installiert aber aus welchem grund auch immer kann ich mit keinem user auf dem ftp via filezilla...
  5. Linux kann keine Umlaute in Dateinamen lesen

    Linux kann keine Umlaute in Dateinamen lesen: Moin :) Ich habe hier ein großes Problem. Meine beiden Linux-Systeme (einmal Kubuntu 8.10 "Hardy" KDE4 - leider noch - und Fedora 9 mit...