Kann apache net starten

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von Figo, 31.05.2007.

  1. Figo

    Figo Grünschnabel

    Dabei seit:
    31.05.2007
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo, ich habe einen v-server mit debian und confixx!
    Ich kann meinen Apache server nicht mehr starten, wenn ich die ip von meinem server eingebe, sagt er mir die seite ist vorrübergehend nicht erreichbar! ich denke das mein apache net mehr läuft! wollte ihn starten doch da kam die fehlermeldung! :
    /etc/init.d/apache start
    Configuration syntax error detected. Not reloading.

    Syntax error on line 49 of /etc/apache/confixx_mhost.conf:
    Invalid command 'suPHP_engine', perhaps mis-spelled or defined by a module not included in the server configuration

    Kann mir einer helfen! bin ein absoluter noobie! ;)
    Danke
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Giglio

    Giglio Doppel-As

    Dabei seit:
    21.12.2006
    Beiträge:
    140
    Zustimmungen:
    0
    Hi,

    naja du hast einen Fehler in deiner Apache config.

    Poste doch mal die Datei /etc/apache/confixx_mhost.conf

    Mfg

    Sebi
     
  4. Figo

    Figo Grünschnabel

    Dabei seit:
    31.05.2007
    Beiträge:
    4
    Zustimmungen:
    0
    ################### CONFIXX APACHE MAIN CONFIG FILE ######################
    # created at Thu May 31 13:44:00 2007
    #
    # !!! Do not make any changes in this file !!!
    #
    # 1. We cannot guarantee that the software will work properly, if
    # the contents of this file are modified.
    # 2. This file would be rewritten after each Confixx software update and
    # in some other cases. Thus all your changes would be lost unless you made
    # a backup of the file.
    #
    # If you need to modify this file, you can insert some custom "Include"
    # directives. E.g.
    # Include /path/to/your/file
    # Includes inserted directly after <VirtualHost> tag would keep their
    # location inchanged after the file is updated. Other includes would
    # be moved to be inserted before the </VirtualHost> tag.
    ##########################################################################

    Listen 80
    Listen 443

    <Directory "/home/www/confixx/html">

    AllowOverride all

    <IfModule mod_access.c>
    Allow from all
    </IfModule>

    <IfModule mod_rewrite.c>

    RewriteEngine On
    Options +FollowSymlinks

    RewriteRule ^reseller/res[0-9]+/(.*)$ reseller/$1 [L]

    RewriteRule ^user/[a-zA-Z][-a-zA-Z0-9_]{0,4}[0-9]+/(.*)$ user/$1 [L]

    RewriteRule ^ftplogin/[a-zA-Z][-a-zA-Z0-9_]{0,4}[0-9]+/(.*)$ ftplogin/$1 [L]
    RewriteRule ^ftplogin/[a-zA-Z][-a-zA-Z0-9_]{0,4}[0-9]+f[0-9]+/(.*)$ ftplogin/$1 [L]

    RewriteRule ^poplogin/[a-zA-Z][-a-zA-Z0-9_]{0,4}[0-9]+p[0-9]+/(.*)$ poplogin/$1 [L]

    </IfModule>

    AddDefaultCharset off

    suPHP_engine on

    </Directory>


    NameVirtualHost 89.110.145.113:80

    <VirtualHost 89.110.145.113:80>

    ServerName 89.110.145.113

    DocumentRoot /home/www/confixx/html/gesperrt

    Options FollowSymLinks
    suPHP_ConfigPath /etc/apache/confixx_phpini
    <IfModule mod_dir.c>
    DirectoryIndex index.php index.html index.htm index.shtml index.cgi
    </IfModule>


    </VirtualHost>

    <VirtualHost 89.110.145.113:80>

    ServerName v354.ncsrv.de

    #User confixx
    #Group confixx
    DocumentRoot /home/www/confixx/html
    Options FollowSymLinks

    suPHP_ConfigPath /etc/apache/confixx_phpini

    ScriptAlias /cgi-bin/ /home/www/confixx/html/cgi-bin/

    <IfModule mod_dir.c>
    DirectoryIndex index.html index.htm index.shtml index.cgi index.php
    </IfModule>


    CustomLog /var/log/apache/v354.ncsrv.de_access.log "%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\""
    ErrorLog /var/log/apache/v354.ncsrv.de_error.log


    </VirtualHost>

    NameVirtualHost 89.110.145.113:443

    <VirtualHost 89.110.145.113:443>

    ServerName 89.110.145.113

    DocumentRoot /home/www/confixx/html/gesperrt

    Options FollowSymLinks
    suPHP_ConfigPath /etc/apache/confixx_phpini
    <IfModule mod_dir.c>
    DirectoryIndex index.php index.html index.htm index.shtml index.cgi
    </IfModule>


    <IfModule mod_ssl.c>

    SSLEngine on
    SSLCertificateKeyFile /etc/apache/ssl.key/v354.ncsrv.de.key
    SSLCertificateFile /etc/apache/ssl.crt/v354.ncsrv.de.crt


    SetEnvIf User-Agent ".*MSIE.*" \
    nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0

    <Files ~ "\.(cgi|shtml|phtml|php3?)$">
    SSLOptions +StdEnvVars
    </Files>

    <Directory "/home/www/confixx/html/cgi-bin">
    SSLOptions +StdEnvVars
    </Directory>

    </IfModule>


    </VirtualHost>

    <VirtualHost 89.110.145.113:443>

    ServerName v354.ncsrv.de

    #User confixx
    #Group confixx
    DocumentRoot /home/www/confixx/html
    Options FollowSymLinks

    suPHP_ConfigPath /etc/apache/confixx_phpini

    ScriptAlias /cgi-bin/ /home/www/confixx/html/cgi-bin/

    <IfModule mod_dir.c>
    DirectoryIndex index.html index.htm index.shtml index.cgi index.php
    </IfModule>


    <IfModule mod_ssl.c>

    SSLEngine on
    SSLCertificateKeyFile /etc/apache/ssl.key/v354.ncsrv.de.key
    SSLCertificateFile /etc/apache/ssl.crt/v354.ncsrv.de.crt


    SetEnvIf User-Agent ".*MSIE.*" \
    nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0

    <Files ~ "\.(cgi|shtml|phtml|php3?)$">
    SSLOptions +StdEnvVars
    </Files>

    <Directory "/home/www/confixx/html/cgi-bin">
    SSLOptions +StdEnvVars
    </Directory>

    </IfModule>


    CustomLog /var/log/apache/v354.ncsrv.de_access.ssl.log "%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\""
    ErrorLog /var/log/apache/v354.ncsrv.de_error.ssl.log


    </VirtualHost>

    Include /etc/apache/confixx_vhost.conf
    # ^- Dieser Eintrag sollte unbedingt am Ende der Datei bleiben
    ## /CONFIXX
     
  5. Giglio

    Giglio Doppel-As

    Dabei seit:
    21.12.2006
    Beiträge:
    140
    Zustimmungen:
    0
    Hi,

    hast du für deinen Webserver php installiert?
    Ihn mit php konfiguiert?

    Mfg

    Sebi
     
  6. Figo

    Figo Grünschnabel

    Dabei seit:
    31.05.2007
    Beiträge:
    4
    Zustimmungen:
    0
    ähhh... wie kann ich das nachschauen? es lief alles super bis die meinen lizenzschlüssel erneuert haben!
    wenn nich wie mache ich das?
    bin echt noch nen richtiger noob!
     
  7. .mike.

    .mike. Doppel-As

    Dabei seit:
    27.08.2006
    Beiträge:
    207
    Zustimmungen:
    0
    und dann braucht man meiner meinung nach auch keinen server wenn man nicht damit umgehen kann
     
  8. Figo

    Figo Grünschnabel

    Dabei seit:
    31.05.2007
    Beiträge:
    4
    Zustimmungen:
    0
    wie soll man was lernen wenn man nichts ausprobieren darf!
    und anscheinend hast du auch keine ahnung ansonsten würdest du nen konstruktiven post hinterlassen!
     
  9. #8 frickelhase, 31.05.2007
    frickelhase

    frickelhase Mitglied

    Dabei seit:
    14.12.2006
    Beiträge:
    42
    Zustimmungen:
    0
    Was ist denn das für eine Anwendung, dieses "Apache Net" ?

    Kann apache net starten ...

    Und was stört dich daran, dass du diese net-Anwendung ("Apache Net") starten kannst ? Wenn dir diese Anwendung für das Net nicht gefällt, starte sie doch einfach nicht ? ??? ?
     
  10. defcon

    defcon Kaiser
    Moderator

    Dabei seit:
    22.08.2005
    Beiträge:
    1.486
    Zustimmungen:
    1
    Ort:
    Bruchsal
    Indem man zu Hause auf seinem Rechner sich erstmal die Grundlagen aneignet, bevor man an Servern rumschraubt.
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. Giglio

    Giglio Doppel-As

    Dabei seit:
    21.12.2006
    Beiträge:
    140
    Zustimmungen:
    0
    @frickelhase find ich net wirklich lustig

    Brauchst du für diesen Webserver php?
    Wenn nicht setz einfach ein # vor die suPHP anweisungen. Ist zwar nicht der feine Weg aber könnte funktionieren.

    Mfg

    Sebi
     
  13. .mike.

    .mike. Doppel-As

    Dabei seit:
    27.08.2006
    Beiträge:
    207
    Zustimmungen:
    0
    ich denke nicht dass man viel über linux lernt wenn man den server dann mit confixx konfiguriert -> dann lieber erst mal aufm eigenen rechner nen apache konfigurieren
    den tipp mit auskommentieren hätte ich dir auch geben können - wollte aber nicht und zur lösung des eigentlichen problems hilfts ja auch nicht weiter
     
Thema:

Kann apache net starten

Die Seite wird geladen...

Kann apache net starten - Ähnliche Themen

  1. Apache: Fehlermeldung & Viruelle Hosts nicht erkannt

    Apache: Fehlermeldung & Viruelle Hosts nicht erkannt: Hallo, ich habe das Problem das Apache beim Start eine Fehlermeldung gibt und ich diese nicht beheben kann. Fehlermeldung: Starting web...
  2. apache2: Kann Perl-File nicht ausführen

    apache2: Kann Perl-File nicht ausführen: Hi, habe eben FastCGI und Perl installiert, Nun habe ich das Problem, dass er Perl nicht ausführen kann. Der originale »cgi-bin« Ordner in...
  3. Apache Problem - Fehlermeldung - Wer kann helfen?

    Apache Problem - Fehlermeldung - Wer kann helfen?: Hallo, komme mit meinem Apacheproblemchen müßig, aber immerhin step-by-step weiter. Grundlage: Apache shutdown einmal in der Woche zu einer...
  4. habe eine .de domain, kann ich mit hilfe von apache1.3 subdomains erstellen?

    habe eine .de domain, kann ich mit hilfe von apache1.3 subdomains erstellen?: Guten Abend, ich habe ne .de domain. Möchte nun subdomains erstellen. z.b wiki.meinedomain.de mp3.meinedomain.de ist das Möglich?
  5. Wie kann ich x Zeichen hinter einem bestimmten Wort ausgeben ?

    Wie kann ich x Zeichen hinter einem bestimmten Wort ausgeben ?: In mehreren Dateien ist immer mehrfach ein bestimmtes Wort enthalten, gefolgt von einem "=". Ich möchte mir die dahinter folgenden 10 Zeichen...