IRQ-Konflikte

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von dunkler_Elf, 10.06.2006.

  1. #1 dunkler_Elf, 10.06.2006
    dunkler_Elf

    dunkler_Elf Eroberer

    Dabei seit:
    05.06.2006
    Beiträge:
    67
    Zustimmungen:
    0
    hallo,

    gibt es eine möglichkeit unter SuSE eine bestimmte interrupt vergabe zu erzwingen?

    an dem betroffenen pc belegen der interne usb-controller und die internen netzwerkkarte den gleichen interrupt. unter windows funktioniert das auch, ebenso wie unter kanotix. SuSE bingt es allerdings zum ansturz sobald man die netzwerkkarte benutzen möchte.

    eine erzwungenen irq vergabe durch das bios ist aufgrund mangelnder einstellmöglichkeiten leider nicht realisierbar. nicht einmal das deaktivieren des (für mich unnötigen) usb-controllers nutzt mir etwas, da das betriebssystem ihn wieder aktivieren kann.

    also brauch ich eine möglichkeit entweder die irq vergabe von SuSE zu erzwingen oder den usb controller endgültig zu deaktivieren.

    weiß vielleicht jemand einen rat für mich? ^^'

    mfg dunkler_Elf
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Ja, du kannst bei vielen Treiber-Modulen den IRQ als Argument beim Laden des Moduls uebergeben. Ob das von den Treibern, mit denen du Probleme hast, unterstuetzt wird, erfaehrst du mit 'modinfo <modulname>'.
     
  4. #3 dunkler_Elf, 13.06.2006
    dunkler_Elf

    dunkler_Elf Eroberer

    Dabei seit:
    05.06.2006
    Beiträge:
    67
    Zustimmungen:
    0
    *hmm*

    und das wäre dann zum beispiel "eth0"?

    und wie übergebe ich das dann als argument?
     
  5. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Das haette dir Goggle auch beantworten koennen: http://www.tldp.org/HOWTO/Module-HOWTO/ :) (speziell Kapitel 8 duerfte das sein, was du suchst)
    Ausserdem ist eth0 ein Device, das von einem Modul angelegt wird. Kann somit also wohl nicht das Modul sein. Welches Modul das ist, haengt von der Karte ab und ist garantiert das, das die Fehlermeldungen in der messages-Datei ausspuckt, wenn es zu einem IRQ-Konflikt kommt.
     
  6. #5 dunkler_Elf, 13.06.2006
    dunkler_Elf

    dunkler_Elf Eroberer

    Dabei seit:
    05.06.2006
    Beiträge:
    67
    Zustimmungen:
    0
    *hmm*

    er gibt keine fehlermeldung aus ... er reagiert nur einfach gar nicht mehr ... ich hatte nur vermutet, dass es ein irq-konflikt ist, da das problem auftaucht, wenn ich das netzwerk verwenden möchte ... hab nachgeguckt, dass mehrere geräte die gleiche adresse belegen ... es lief nur zweimal zufällig ... vermutlich als sie zufällig andere adressen zugewiesen bekamen.

    es ärgert mich, dass das bios das nicht richtig verwalten kann (bzw. dass man es im bios manuell einstellen kann). das würde nerven sparen.

    hab aufgrund meiner weiterbildung eh nur wenig zeit ... da kommt es vor dass ich ein oder zwei wochen nicht dazu komme mich darum zu kümmern. :(
     
  7. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Tja, wenn du das nur vermutet hast, wuerde ich mal tippen, dass es nicht am IRQ liegt, wenn es sich um PCI und USB-Geraete handelt. Ich dachte, dass du das sicher weisst. Die Zeiten der IRQ-Probleme sind seit ISA-Slots eigentlich grossteils vorbei. Ich tippe da mal eher auf das gute alte ACPI-Problem, das man ja gerade von SuSE sehr gut kennt. Schonmal die Kernel-Parameter 'acpi=off noapic' beim Booten probiert? Wenn das nicht hilft mal in die /var/log/messages einen Blick werfen und schauen, welche Meldungen kurz vor dem letzten Absturz geloggt wurden. (Die Meldungen koennen auch in einer der /var/log/messages-<datum>.gz sein.) Koennte auch einfach ein Fehler in den hotplug-Einstellungen sein.
     
  8. #7 dunkler_Elf, 14.06.2006
    dunkler_Elf

    dunkler_Elf Eroberer

    Dabei seit:
    05.06.2006
    Beiträge:
    67
    Zustimmungen:
    0
    *hmm*

    nein, sicher bin ich mir nicht ... wäre nicht das erste mal dass ich probleme mit IRQ sharing hätte ... *hmm* ... die option "acpi = off" hatte ich schon mal am anfang probiert, glaube ich ... hat damals nichts gebracht ... oder ich hab was falsch gemacht ... das möchte ich mal nicht ausschließen ... *hmm* ...
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Dann schau in der messages und der syslog nach, was fuer Meldungen kurz vor und beim Einfrieren des Systems dort auftauchen. Die koennen sicherlich mehr Aufschluss geben als wilde Mutmassungen.
     
  11. #9 dunkler_Elf, 15.06.2006
    dunkler_Elf

    dunkler_Elf Eroberer

    Dabei seit:
    05.06.2006
    Beiträge:
    67
    Zustimmungen:
    0
    *hmm*

    zwischenzeitlich hatte ich kanotix auf dem rechner ... damit gab es das problem nicht ... da ich aber gerne überall die gleiche distribution drauf haben wollte hab ich nun wieder suse installiert um mich mit dem problem zu befassen ... aber nach der neuinstallation war es weg ... nun tritt es einfach nicht mehr auf.

    nicht dass ich mich deswegen beschweren wollte ... aber ein bißchen seltsam ist das schon.

    trotzdem danke für deine hilfe. :))
     
Thema:

IRQ-Konflikte